[PATCH] gnu: moonfish: update to 1.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Z
Z
zamfofex wrote on 19 Jan 12:33 +0100
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
f2389b0a676917a2e50bad7518710238b7576338.1737286437.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): Update to 1.

Change-Id: I0981fc8a24501d5b1bfe04be2f50f92544d620dd
---
gnu/packages/games.scm | 67 +++++++++++++++++++++++-------------------
1 file changed, 36 insertions(+), 31 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3d71a7cf8b..a570e7187e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022, 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
-;;; Copyright © 2022, 2023 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2022, 2023, 2025 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
@@ -11304,36 +11304,41 @@ (define-public stockfish
(license license:gpl3+))))
(define-public moonfish
- (let ((commit "fb2cb4f53876b1b0c6060464e0dd5a05ab00e502")
- (revision "2"))
- (package
- (name "moonfish")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~zamfofex/moonfish")
- (commit commit)))
- (sha256
- (base32
- "1rbhdahp0s2qm1zi7lpr0bb6zq02y76fc9d9nc2k5n03zh2as97i"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" %output))
- #:tests? #f ;no check target
- #:phases #~(modify-phases %standard-phases
- (delete 'configure)))) ;no configure script
- (inputs (list bearssl cjson))
- (home-page "https://git.sr.ht/~zamfofex/moonfish")
- (synopsis "Simple chess engine written in C")
- (description
- "moonfish is a toy UCI chess engine written in C for fun. It has TUI/CLI
-tools for using any UCI engine and also to connect UCI engines to Lichess, as
-well as for converting engines between UCI and UGI.")
- (license license:agpl3+))))
+ (package
+ (name "moonfish")
+ (version "1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~zamfofex/moonfish")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0p5rdrqiip6n5wdxjvlsg7qnwdwrpl9g3j1mx7q0i9a8zmkj2ryv"))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet #~(begin
+ ;; Avoid relying on '/dev/stderr', which doesn't work at the
+ ;; top-level of a Guix build, because it refers to a pipe
+ ;; that the build user doesn't have permission to access.
+ (substitute* "scripts/check.sh"
+ (("\\btee /dev/stderr\\b")
+ "tee"))))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (inputs (list libressl cjson))
+ (home-page "https://moonfish.neocities.org")
+ (synopsis "Simple chess engine written in C")
+ (description
+ "moonfish is a toy UCI chess engine written in C. It has TUI/CLI tools
+for using any UCI engine and also to connect UCI engines to Lichess and IRC.")
+ (license license:agpl3+)))
(define-public morris
(package

base-commit: 0b06a5bc97938cae3da19e566c2f6f71cc299d78
--
2.47.1
?
?
??? wrote 6 days ago
(name . zamfofex)(address . zamfofex@twdb.moe)
8734h08xqg.fsf@envs.net
zamfofex <zamfofex@twdb.moe> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (moonfish): Update to 1.

Pushed to master, thank you!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75669@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75669
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch