[PATCH] gnu: Add r-vscdebugger

  • Open
  • quality assurance status badge
Details
One participant
  • Jonas Freimuth
Owner
unassigned
Submitted by
Jonas Freimuth
Severity
normal
J
J
Jonas Freimuth wrote on 18 Jan 19:35 +0100
(address . guix-patches@gnu.org)(name . Jonas Freimuth)(address . jonas.freimuth@posteo.de)
71c704547d5077c20a1389d92f421d26bee9e4b7.1737225321.git.jonas.freimuth@posteo.de
* gnu/packages/statistics.scm (r-vscdebugger): New variable.

Change-Id: Ie21c638de839b08ddce7c49b08ec7b3bd12c240a
---
gnu/packages/statistics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d6ad9fdff9..84a47e15c5 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7103,6 +7103,31 @@ (define-public r-languageserver
completion.")
(license license:expat))))
+(define-public r-vscdebugger
+ (let ((commit "83e91154629de8cb81d043dea24fd78f77c6108c")
+ (revision "1"))
+ (package
+ (name "r-vscdebugger")
+ (version (git-version "0.5.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ManuelHentschel/vscDebugger")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zn2smrpkdjy66ka2w7na4513hymrix2nqv6jwlgzm9ib6hp6fl9"))))
+ (properties `((upstream-name . "vscDebugger")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-jsonlite r-r6))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ManuelHentschel/vscDebugger")
+ (synopsis "Support for Visual Studio Code Debugger")
+ (description
+ "This package provides support for a visual studio code debugger.")
+ (license license:expat))))
+
(define-public python-rpy2
(package
(name "python-rpy2")

base-commit: 750b13031bd41661b4375e990e9af76ee304d2b9
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75666@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75666
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch