[PATCH] gnu: Add mbpoll.

  • Done
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 2 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
be44c307bf8e0a37d0905916ca2944d05f966288.1737269271.git.poptsov.artyom@gmail.com
* gnu/packages/engineering.scm (mbpoll): New variable.

Change-Id: I356425b47ae4a5201465c9f1e0244602a1cf9dc2
---
gnu/packages/engineering.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f9c4ac9bbd..d0d23934e0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Konstantinos Agiannis <agiannis.kon@gmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022, 2024, 2025 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Theofilos Pechlivanis <theofilos.pechlivanis@gmail.com>
@@ -217,6 +217,33 @@ (define-public librecad
plans and designs.")
(license license:gpl2)))
+(define-public mbpoll
+ (package
+ (name "mbpoll")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/epsilonrt/mbpoll")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h5qsgy5hkrq92nxfkl564w21g5vp9nnch04fdqij06ckvzf7vdc"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config))
+ (inputs (list libmodbus))
+ (home-page "https://github.com/epsilonrt/mbpoll")
+ (synopsis
+ "Command line utility to communicate with ModBus slave (RTU or TCP)")
+ (description
+ "@code{mbpoll} is a command line utility to communicate with
+@url{https://en.wikipedia.org/wiki/Modbus, ModBus} slave (RTU or TCP).")
+ (license license:gpl3)))
+
(define-public geda-gaf
(package
(name "geda-gaf")

base-commit: dc50af1ca527af0ef03dae4eef3757272428b1a7
--
2.47.1
Artyom V. Poptsov wrote 1 months ago
(address . 75665-done@debbugs.gnu.org)
87bjvha5an.fsf@gmail.com
Merged to the "master" branch as
9366217997d759a4150cf5e44d83b947ac2028ab

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmeiZ7MZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfk//D/4siycTrzE1ZsjLq4w6wESD
4zCLkXrpFEJyUfHeHNErMlHIelhmV3feuUXup/jcRFRQZpYxwBf2wU7bYSPqhepL
ucsDn3muOlTGz+r3Gi3n8nH2o7rf9FJd+79xbEjnIXItfhWOHadzo6rrsknmCgat
QJvnW9itnQKUSfi6vZK/cacazz+PKid9+MajzY7t0HPWYFw9TLsNxcGJuQ7ar0VL
0Kd8VSwV3kWCLKL+zMIo3ueizOgvD1pRZs7EWwZmBoXVgcMM9WBenkwjllC/f80M
3ta5kgBMLORRSHbuF092J8/LWoHg2rP9ykhAI+XvJqZawmKb/UBuPZ3gNE9LnHFc
fof0qPd+5Ro/FdKgAze2ORf+BYiLhWDfD9WjtPKdFufBbm021tozQbE6DtIz6MPe
xBXPpwDpIdN7EDwKKU2oUAhFL3AR9NA2PFx3gORi+iZqA75MvPT3L6Piz3cLuFV5
u9l8nbpVXP8FsXu4pymV6eKglmnfPba+yFbFpbGLDv597j8YQOltkJ6DdvAcYEaT
sSZWMquZL4l1pVkvmDB8IMCB86EXC+Imy8oGf96fgSmVunySea4JNoxPnWo25heR
GTlFxvMjC6uJI5fC87Bi2atsannWz/8ueWOvWNmBerqDW8g4vyqNTjzupH5qHXm3
+jgBBKVJdYINqeSMcZVliw==
=/jd/
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75665@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75665
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help