Crash in element->html involving SVG object

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 19 Jan 05:19 +0100
(address . bug-mumi@gnu.org)(name . guix-sysadmin)(address . guix-sysadmin@gnu.org)
87wmera10s.fsf@gmail.com
Hi,

Seen on the berlin server in /var/log/mumi.log, after Mumi crashed:

Toggle snippet (253 lines)
[...]
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 260:13 19 (for-each #<procedure 7f1558dc7f20 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 346:8 18 (element->html li _ ((a (@ (href "/")) (svg (@ …) …))) #)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 260:13 17 Uncaught exception in task:
2025-01-19 03:46:04 In fibers.scm:
2025-01-19 03:46:04 (for-each #<procedure 7f1558dc7dc0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 172:8 6 (_)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 346:8 16
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 (element->html a _ ((svg (@ (width "97.896") (…) …) …)) #)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:04 260:13 15
2025-01-19 03:46:04 In fibers/web/server.scm:
2025-01-19 03:46:04 (for-each #<procedure 7f1558dc7b20 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 214:25 4 (_)
2025-01-19 03:46:04 346:8 14 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:04 (element->html svg _ ((defs (linearGradient (…) …) …) …) …)
2025-01-19 03:46:04 83:4 3 (write-bytes #<closed: file 7f141e46e310> #vu8(253 55 …) …)
2025-01-19 03:46:04 In unknown file:
2025-01-19 03:46:04 2
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 (port-write #<closed: file 7f141e46e310> #vu8(253 55 …) …)
2025-01-19 03:46:04 260:13 13
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 (for-each #<procedure 7f1558dc7380 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 1685:16 1 346:8 12 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 (element->html g _ ((path (@ (d …) …) …) …) …)
2025-01-19 03:46:04 Uncaught exception in task:
2025-01-19 03:46:04 In fibers.scm:
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 172:8 6 (_)
2025-01-19 03:46:04 260:13 11 (for-each #<procedure 7f141f179360 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:04 337:2 10 (element->html path ((d "m108.81 136.28c-0.42374 …") #) …)
2025-01-19 03:46:04 In fibers/web/server.scm:
2025-01-19 03:46:04 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:04 In procedure fport_write: Broken pipe
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 260:13 9 214:25 4 (_)
2025-01-19 03:46:04 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:04 (for-each #<procedure 7f141f179220 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:04 83:4 3 (write-bytes #<closed: file 7f141e46e230> #vu8(42 32 …) …)
2025-01-19 03:46:04 In mumi/web/sxml.scm:
2025-01-19 03:46:04 In unknown file:
2025-01-19 03:46:04 2 330:2 8 (port-write #<closed: file 7f141e46e230> #vu8(42 32 # …) …)
2025-01-19 03:46:04 (_ _)
2025-01-19 03:46:04 In unknown file:
2025-01-19 03:46:04 7
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 (string-for-each #<procedure escape (c)> "m108.81 136.…" …)
2025-01-19 03:46:04 6 (display #\6 #<output: string 7f125003de00>)
2025-01-19 03:46:04 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 In web/http.scm:
2025-01-19 03:46:04 2054:35 5 (flush)
2025-01-19 03:46:04 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:04 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 725:6 4 (put-char #<closed: file 7f15712dc9a0> #\4)
2025-01-19 03:46:04 83:4 3 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:04 In procedure fport_write: Broken pipe
2025-01-19 03:46:04 (write-bytes #<closed: file 7f15712dc9a0> #vu8(46 50 …) …)
2025-01-19 03:46:04 In unknown file:
2025-01-19 03:46:04 2 (port-write #<closed: file 7f15712dc9a0> #vu8(46 50 # …) …)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:04 In procedure fport_write: Broken pipe
2025-01-19 03:46:04 Uncaught exception in task:
2025-01-19 03:46:04 In fibers.scm:
2025-01-19 03:46:04 172:8 6 (_)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:04 In fibers/web/server.scm:
2025-01-19 03:46:04 214:25 4 (_)
2025-01-19 03:46:04 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:04 83:4 3 (write-bytes #<closed: file 7f141e46e770> #vu8(65 99 …) …)
2025-01-19 03:46:04 In unknown file:
2025-01-19 03:46:04 2 (port-write #<closed: file 7f141e46e770> #vu8(65 99 # …) …)
2025-01-19 03:46:04 In ice-9/boot-9.scm:
2025-01-19 03:46:04 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:04 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:04 In procedure fport_write: Broken pipe
2025-01-19 03:46:05 Uncaught exception in task:
2025-01-19 03:46:05 In fibers.scm:
2025-01-19 03:46:05 172:8 30 (_)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 1752:10 29 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:05 In fibers/web/server.scm:
2025-01-19 03:46:05 212:30 28 (_)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 27 (for-each #<procedure 7f1299d69f40 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 26 (element->html html _ ((head (title "[PATCH 00…") …) #) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 25 (for-each #<procedure 7f1299d69b80 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 24 (element->html body _ ((script (@ (src "/js/t…"))) # …) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 23 (for-each #<procedure 7f1298491e60 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 22 (element->html nav _ ((ul (li (a (@ (# #)) (…))) #) #) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 21 (for-each #<procedure 7f1298491800 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 20 (element->html ul _ ((li (a (@ (href "/")) (# …))) (…)) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 19 (for-each #<procedure 7f12984916a0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 18 (element->html li _ ((a (@ (href "/")) (svg (@ …) …))) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 17 (for-each #<procedure 7f1298491540 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 16 (element->html a _ ((svg (@ (width "97.896") (…) …) …)) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 15 (for-each #<procedure 7f12984912a0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 14 (element->html svg _ ((defs (linearGradient (…) …) …) …) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 13 (for-each #<procedure 7f1296e67b00 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 12 (element->html g _ ((path (@ (d "m108.81 13…") #) #) …) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 11 (for-each #<procedure 7f12904faba0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 337:2 10 (element->html path ((d "m108.81 136.28c-0.42374 …") #) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 9 (for-each #<procedure 7f12904faa60 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 330:2 8 (_ _)
2025-01-19 03:46:05 In unknown file:
2025-01-19 03:46:05 7 (string-for-each #<procedure escape (c)> "m108.81 136.…" …)
2025-01-19 03:46:05 6 (display #\1 #<output: string 7f12a0218070>)
2025-01-19 03:46:05 In web/http.scm:
2025-01-19 03:46:05 2054:35 5 (flush)
2025-01-19 03:46:05 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:05 Uncaught exception in task:
2025-01-19 03:46:05 In fibers.scm:
2025-01-19 03:46:05 725:6 4 (put-char #<closed: file 7f141e46e7e0> #\0)
2025-01-19 03:46:05 172:8 30 (_)
2025-01-19 03:46:05 83:4 3 (write-bytes #<closed: file 7f141e46e7e0> #vu8(55 34 …) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 In unknown file:
2025-01-19 03:46:05 2 (port-write #<closed: file 7f141e46e7e0> #vu8(55 34 # …) …)
2025-01-19 03:46:05 1752:10 29 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 In fibers/web/server.scm:
2025-01-19 03:46:05 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:05 212:30 28 (_)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 27 (for-each #<procedure 7f127b90e620 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 26 (element->html html _ ((head (title "[PATCH 0/…") …) #) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:05 In procedure fport_write: Broken pipe
2025-01-19 03:46:05 260:13 25 (for-each #<procedure 7f127b90e260 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 24 (element->html body _ ((script (@ (src "/js/t…"))) # …) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 23 (for-each #<procedure 7f1279a4f640 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 22 (element->html nav _ ((ul (li (a (@ (# #)) (…))) #) #) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 21 (for-each #<procedure 7f1277a1afe0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 20 (element->html ul _ ((li (a (@ (href "/")) (# …))) (…)) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 19 (for-each #<procedure 7f1277a1ae80 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 18 (element->html li _ ((a (@ (href "/")) (svg (@ …) …))) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 17 (for-each #<procedure 7f1277a1ad20 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 16 (element->html a _ ((svg (@ (width "97.896") (…) …) …)) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 15 (for-each #<procedure 7f1277a1aa80 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 14 (element->html svg _ ((defs (linearGradient (…) …) …) …) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 13 (for-each #<procedure 7f1277a1a2e0 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 346:8 12 (element->html g _ ((path (@ (d "m108.81 13…") #) #) …) #)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 11 (for-each #<procedure 7f1274577340 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 337:2 10 (element->html path ((d "m108.81 136.28c-0.42374 …") #) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 260:13 9 (for-each #<procedure 7f1274577200 at mumi/web/sxml.sc…> …)
2025-01-19 03:46:05 In mumi/web/sxml.scm:
2025-01-19 03:46:05 330:2 8 (_ _)
2025-01-19 03:46:05 In unknown file:
2025-01-19 03:46:05 7 (string-for-each #<procedure escape (c)> "m108.81 136.…" …)
2025-01-19 03:46:05 6 (display #\7 #<output: string 7f127ccacbd0>)
2025-01-19 03:46:05 In web/http.scm:
2025-01-19 03:46:05 2054:35 5 (flush)
2025-01-19 03:46:05 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:05 725:6 4 (put-char #<closed: file 7f141e46e2a0> #\space)
2025-01-19 03:46:05 83:4 3 (write-bytes #<closed: file 7f141e46e2a0> #vu8(54 51 …) …)
2025-01-19 03:46:05 In unknown file:
2025-01-19 03:46:05 2 (port-write #<closed: file 7f141e46e2a0> #vu8(54 51 # …) …)
2025-01-19 03:46:05 In ice-9/boot-9.scm:
2025-01-19 03:46:05 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:05 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:05 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:05 In procedure fport_write: Broken pipe
2025-01-19 03:46:06 GC Warning: Repeated allocation of very large block (appr. size 10532 KiB):
2025-01-19 03:46:06 May lead to memory leak and poor performance
2025-01-19 03:46:10 Uncaught exception in task:
2025-01-19 03:46:10 In fibers.scm:
2025-01-19 03:46:10 172:8 6 (_)
2025-01-19 03:46:10 In ice-9/boot-9.scm:
2025-01-19 03:46:10 1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:10 In fibers/web/server.scm:
2025-01-19 03:46:10 214:25 4 (_)
2025-01-19 03:46:10 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:10 83:4 3 (write-bytes #<closed: file 7f14e5fa7850> #vu8(70 114 …) …)
2025-01-19 03:46:10 In unknown file:
2025-01-19 03:46:10 2 (port-write #<closed: file 7f14e5fa7850> #vu8(70 114 …) …)
2025-01-19 03:46:10 In ice-9/boot-9.scm:
2025-01-19 03:46:10 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:10 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:10 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:10 In procedure fport_write: Broken pipe
2025-01-19 03:46:11 Uncaught exception in task:
2025-01-19 03:46:11 In fibers.scm:
2025-01-19 03:46:11 172:8 6 (_)
2025-01-19 03:46:11 In ice-9/boot-9.scm:
2025-01-19 03:46:11 1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
2025-01-19 03:46:11 In fibers/web/server.scm:
2025-01-19 03:46:11 214:25 4 (_)
2025-01-19 03:46:11 In ice-9/suspendable-ports.scm:
2025-01-19 03:46:11 83:4 3 (write-bytes #<closed: file 7f14f3541850> #vu8(70 114 …) …)
2025-01-19 03:46:11 In unknown file:
2025-01-19 03:46:11 2 (port-write #<closed: file 7f14f3541850> #vu8(70 114 …) …)
2025-01-19 03:46:11 In ice-9/boot-9.scm:
2025-01-19 03:46:11 1685:16 1 (raise-exception _ #:continuable? _)
2025-01-19 03:46:11 1685:16 0 (raise-exception _ #:continuable? _)
2025-01-19 03:46:11 ice-9/boot-9.scm:1685:16: In procedure raise-exception:
2025-01-19 03:46:11 In procedure fport_write: Broken pipe

I've restarted it, but opening this Mumi issue so that it can be
investigated.

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75663@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75663
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch