[PATCH 0/1] gnu: lsof: Skip LTlock test

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Jordan Moore
Owner
unassigned
Submitted by
Jordan Moore
Severity
normal
J
J
Jordan Moore wrote on 19 Jan 00:33 +0100
(address . guix-patches@gnu.org)(name . Jordan Moore)(address . lockbox@struct.foo)
cover.1737242342.git.lockbox@struct.foo
lsof check stage fails on CoW filesystems (eg. btrfs, zfs).
This unconditionally skips the check. I was looking at how
to work around this and checked Gentoo's source builds, but
noticed they explicity opt out of lsof tests [1]. This patch
removes the single failing test, and allows builds on CoW
filesystems.

Note: I ran into this while standing up a build farm.


Jordan Moore (1):
gnu: lsof: Skip LTlock test

gnu/packages/lsof.scm | 2 ++
1 file changed, 2 insertions(+)


base-commit: 42295555ca9648e894569f40e9b28768be3f788a
--
2.46.0
J
J
Jordan Moore wrote on 19 Jan 00:59 +0100
[PATCH] gnu: lsof: Skip LTlock test
(address . 75661@debbugs.gnu.org)(name . Jordan Moore)(address . lockbox@struct.foo)
f5f97e1e793ad3154433f5d8ea57e78e80f1b8df.1737244730.git.lockbox@struct.foo
Change-Id: I074247549c34992ccc17840d196fbb00f79cc39f
---
gnu/packages/lsof.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index a6ac0306de..f9b2906ec6 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -73,6 +73,8 @@ (define-public lsof
;; Fails with ‘ERROR!!! client gethostbyaddr() failure’.
(("(TESTS \\+=.*) tests/LTsock" _ prefix)
prefix)
+ ;; Fails on CoW filesystems (eg. btrfs)
+ (("tests/LTlock") "")
;; Fails because /proc not mounted in sandbox
(("\tdialects/linux/tests/case-20-epoll.bash \\\\")
"\\")))))))

base-commit: 42295555ca9648e894569f40e9b28768be3f788a
--
2.46.0
J
J
Jordan Moore wrote on 19 Jan 01:02 +0100
Re: [PATCH 0/1] gnu: lsof: Skip LTlock test
(address . 75661@debbugs.gnu.org)
8933af29-4513-4f16-926e-0a9495d5903c@app.fastmail.com
This might need to get bumped to another branch like core-packages-team (if accepted), but that was just merged iirc.

- Jordan
Attachment: file
L
L
Leo Famulari wrote on 19 Jan 07:31 +0100
Re: [bug#75661] [PATCH 0/1] gnu: lsof: Skip LTlock test
(name . Jordan Moore)(address . lockbox@struct.foo)(address . 75661@debbugs.gnu.org)
Z4ycOuyz1-vd-VJ6@jasmine.lan
On Sat, Jan 18, 2025 at 07:02:33PM -0500, Jordan Moore wrote:
Toggle quote (2 lines)
> Subject: [bug#75661] [PATCH 0/1] gnu: lsof: Skip LTlock test

Thanks, I can reproduce the failure and it is fixed with your patch.

Toggle quote (2 lines)
> This might need to get bumped to another branch like core-packages-team (if accepted), but that was just merged iirc.

`guix refresh -l lsof` reports approximately 225 dependents, which I
think is fine on the master branch for a "safe" change like this. Is
there more to the story that would require this to go through the
core-packages-team branch?
J
J
Jordan Moore wrote on 19 Jan 16:39 +0100
(name . Leo Famulari)(address . leo@famulari.name)(address . 75661@debbugs.gnu.org)
3700ec55-fcf7-4e97-a51d-b119771b507c@app.fastmail.com
Toggle quote (5 lines)
> `guix refresh -l lsof` reports approximately 225 dependents, which I
> think is fine on the master branch for a "safe" change like this. Is
> there more to the story that would require this to go through the
> core-packages-team branch?
>
Oh no go ahead, I misread that as 2200 packages when I checked

- Jordan
Attachment: file
L
L
Leo Famulari wrote on 20 Jan 03:40 +0100
(name . Jordan Moore)(address . lockbox@struct.foo)(address . 75661-done@debbugs.gnu.org)
Z423jtS6QpdrxKhp@jasmine.lan
On Sun, Jan 19, 2025 at 10:39:31AM -0500, Jordan Moore wrote:
Toggle quote (2 lines)
> Oh no go ahead, I misread that as 2200 packages when I checked

Great! Pushed as eeabdd8eb346f5fb332385c11292ab3bd1ca12a5
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75661@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75661
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch