[PATCH 0/1] gnu: Add cutecom.

  • Done
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 2 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1737226834.git.poptsov.artyom@gmail.com
This patch adds cutecom:

I wasn't able to build v0.51.0 succesfully with Qt5 (as it requires) so I
decided to use v0.60.0-RC1 as the main change in this version is the added Qt6
support.

Artyom V. Poptsov (1):
gnu: Add cutecom.

gnu/packages/engineering.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)


base-commit: 2c42614b372fa48b30462c0bff8d716e02236905
--
2.47.1
Artyom V. Poptsov wrote 2 months ago
[PATCH 1/1] gnu: Add cutecom.
(address . 75654@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
49c7268c33b1bf00a8ddfa6d58d1757e90e2121b.1737226834.git.poptsov.artyom@gmail.com
* gnu/packages/engineering.scm (cutecom): New variable.

Change-Id: Ib560ba855074514e9e2df1884b49722218b1a410
---
gnu/packages/engineering.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f9c4ac9bbd..6616b16c66 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Konstantinos Agiannis <agiannis.kon@gmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022, 2024, 2025 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Theofilos Pechlivanis <theofilos.pechlivanis@gmail.com>
@@ -175,6 +175,33 @@ (define-module (gnu packages engineering)
#:use-module (gnu packages xorg)
#:use-module ((srfi srfi-1) #:hide (zip)))
+(define-public cutecom
+ (package
+ (name "cutecom")
+ (version "0.60.0-RC1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cutecom/cutecom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k67x4l27ac6sb944b42zscm0ffq2fxbghapspgj75g4dr8ip38a"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;no tests
+ (inputs
+ (list qtbase qttools qtserialport))
+ (home-page "https://gitlab.com/cutecom/cutecom")
+ (synopsis "Graphical serial terminal")
+ (description
+ "@code{cutecom} is a graphical serial terminal, like @code{minicom}. It is
+aimed mainly at hardware developers or other people who need a terminal to talk to
+their devices.")
+ (license license:gpl3)))
+
(define-public librecad
(package
(name "librecad")
--
2.47.1
Artyom V. Poptsov wrote 1 months ago
Re: [PATCH 0/1] gnu: Add cutecom.
(address . 75654-done@debbugs.gnu.org)
87sep2mevd.fsf@gmail.com
Merged to the "master" branch as
e90bd12f49e08f4d30007e80eaf5649ef98b5517

In addition, I fixed the license: the project uses GPLv3+, as mentioned
by ngz on #guix IRC channel on irc.libera.chat.

Also just found out that there's a duplicate bugreport 73757 by Aaron
Covrig, that adds cutecom v0.51.0:

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmeZrEEZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfs4+D/47q7asooaA3+ac0mW/a9et
kjQC+muSJYc0CXtSM3aWT60M0TD2TA+r4TTBsSC/sD9eIi6hvGiHL7ZXGiVEPjGi
cTol/SVlYo5cryugKHjKBaslXMkDsSUQgYp5LAtLRL7ZwwW4a6pC6a5qbsDh9tr9
mUo84dj5thJjll+OfIj0Qw1cUZZ6Ju0bTugT3OhJrCJo7H20ob7VmY5dNqfwkGFc
71zDE+I5/Ufhz4TlSX3hvGwIaoxZOuqlc8vbiGfsb1UnAH/6Un7Aa1XZMlGwGzTy
yctSlH4s/z8S9thDQr6evck7JqWFKuKbypT/0U5YHfqtBHRy+hSXmraEQbiTEDGO
8ebNsRbim4NBWFewfJYQlm80YtUH/Af7DsoPyGKPZ8qp0zoUiG8w91kV8iLUeqZW
LVGb5i/7V1+1ANIdoPUu5Wz6LfhEL0ckkEpLse+2w/6PacgKNL1BgGf4qJ7gwvgO
Wm7sH07dyxY7fxAxkIAyryV8yUDgLf202Ruwer2r4nShsBYFNuyLTz2W4iGHzNrP
rzoITw78AALhKJ0c1nSH6oLIL5kx5n9w/FTyPCUsevg3+gUg6RgmcupkVxogPn3Q
bODMW8zg8E+K5k4X0XOY5Dh2G0udohkvcN4KiRnliAuKGqGSWYIh24kAJ/1y9ivG
7JB+Tjgk9Mj1fI+8qPAajg==
=L8xM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75654@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75654
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help