[PATCH] gnu: Add rtorrent-xml-rpc.

  • Open
  • quality assurance status badge
Details
2 participants
  • Divya Ranjan
  • Bruno Victal
Owner
unassigned
Submitted by
Divya Ranjan
Severity
normal

Debbugs page

Divya Ranjan wrote 2 months ago
(address . guix-patches@gnu.org)(name . Divya Ranjan)(address . divya@subvertising.org)
20250118080548.22699-1-divya@subvertising.org
* gnu/packages/bittorrent.scm (rtorrent-xml-rpc): New variable.
---
gnu/packages/bittorrent.scm | 72 ++++++++++++++++++++++---------------
1 file changed, 43 insertions(+), 29 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0d52d25e08..1e2e42f064 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2025 Divya Ranjan Pattanaik <divya@subvertising.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -256,39 +257,52 @@ (define-public rtorrent
(home-page "https://github.com/rakshasa/rtorrent")
(license l:gpl2+)))
-(define-public tremc
- (let ((commit "d8deaa5ac25bb45a2ca3a930309d6ecc74836a54")
- (revision "1"))
+(define-public rtorrent-xml-rpc
(package
- (name "tremc")
- (version (git-version "0.9.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tremc/tremc")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08kpqmgisja98918f2hlmdrld5662dqlkssp0pqlki38l6fvbj7r"))))
- (build-system gnu-build-system)
+ (inherit rtorrent)
+ (name "rtorrent-xml-rpc")
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; The software is just a Python script that must be copied into place.
- (delete 'configure)
- (delete 'build))))
+ `(#:configure-flags '("--with-xmlrpc-c")))
(inputs
- (list python))
- (synopsis "Console client for the Transmission BitTorrent daemon")
- (description "Tremc is a console client, with a curses interface, for the
+ (modify-inputs (package-inputs rtorrent)
+ (append xmlrpc-c)))
+ (description
+ "rTorrent is a BitTorrent client with an ncurses interface. It supports
+full encryption, DHT, PEX, and Magnet Links. Built with XML-RPC support.")))
+
+(define-public tremc
+ (let ((commit "d8deaa5ac25bb45a2ca3a930309d6ecc74836a54")
+ (revision "1"))
+ (package
+ (name "tremc")
+ (version (git-version "0.9.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tremc/tremc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08kpqmgisja98918f2hlmdrld5662dqlkssp0pqlki38l6fvbj7r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The software is just a Python script that must be copied into place.
+ (delete 'configure)
+ (delete 'build))))
+ (inputs
+ (list python))
+ (synopsis "Console client for the Transmission BitTorrent daemon")
+ (description "Tremc is a console client, with a curses interface, for the
Transmission BitTorrent daemon.")
- (home-page "https://github.com/tremc/tremc")
- (license l:gpl3+))))
+ (home-page "https://github.com/tremc/tremc")
+ (license l:gpl3+))))
(define-public aria2
(package
--
2.47.1
Bruno Victal wrote 4 weeks ago
(name . Divya Ranjan)(address . divya@subvertising.org)(address . 75644@debbugs.gnu.org)
f965badf-c8b3-40a4-8ae1-8a54c327856e@makinata.eu
Hi Divya,

On 2025-01-18 08:05, Divya Ranjan via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/bittorrent.scm (rtorrent-xml-rpc): New variable.

Is it worth defining a package variant just for the XML-RPC support?
Why not just build rtorrent with XML-RPC baked in? Unless there's a cycle
or XML-RPC addition increases the package size by intolerable amounts,
I'd say you should simply enable the feature in the base rtorrent package
otherwise if everyone starts defining "minimalist" package variants its going
to result in a combinatorial explosion.

My 2¢,

--
Cheers,
Bruno.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75644@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75644
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help