Tomáš ?ech <sleep_walker@gnu.org> writes:
Toggle quote (37 lines)
> * gnu/packages/xfce.scm (xfce4-i3-workspaces-plugin): New variable.
> ---
> gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
> index 43722cf484..efc20a9d2c 100644
> --- a/gnu/packages/xfce.scm
> +++ b/gnu/packages/xfce.scm
> @@ -16,6 +16,7 @@
> ;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
> +;;; Copyright © 2025 Tomáš ?ech <sleep_walker@gnu.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -590,6 +591,28 @@ (define-public xfce4-pulseaudio-plugin
> (license gpl2+)
> (properties `((release-tag-prefix . ,(string-append name "-"))))))
>
> +(define-public xfce4-i3-workspaces-plugin
> + (package
> + (name "xfce4-i3-workspaces-plugin")
> + (version "1.4.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/denesb/xfce4-i3-workspaces-plugin")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1l957xzs479mnl1la6lx3ysaiqc0z8l84jg442wif9k8x9z6iah8"))))
> + (build-system gnu-build-system)
> + (native-inputs (list xfce4-dev-tools libxfce4ui xfce4-panel i3-wm i3ipc-glib json-glib))
Hello, things other than xfce4-dev-tools should go into inputs, since
native-inputs is only for things running during build.
Toggle quote (4 lines)
> + (inputs (list glib gtk+ libxfce4util xfce4-panel))
> + (home-page "https://github.com/denesb/xfce4-i3-workspaces-plugin")
> + (synopsis "Workspace plugin for Xfce4 panel for running i3 window manager in Xfce4 desktop")
Not for running i3 window manager, maybe "Xfce panel workspace switcher plugin for the i3 window manager"
Toggle quote (3 lines)
> + (description
> + "A workspace panel plugin for Xfce4, which communicates with i3 window manager.")
Description should be a full sentence, maybe "This package provides a
workspace switcher panel plugin for Xfce, which ...".
Toggle quote (4 lines)
> + (license gpl3+)))
> +
Could you send an update, thank you!