[PATCH 0/2] introduce xfce4-i3-workspaces-plugin

  • Open
  • quality assurance status badge
Details
2 participants
  • ???
  • Tomáš ?ech
Owner
unassigned
Submitted by
Tomáš ?ech
Severity
normal
T
T
Tomáš ?ech wrote 15 hours ago
(address . guix-patches@gnu.org)(name . Tomáš ?ech)(address . sleep_walker@gnu.org)
cover.1736890009.git.sleep_walker@gnu.org
Some people combine experience of i3wm together with comfort of Xfce4. As Xfce
is modular, it is well possible to replace standard Xfce4's window manager
with i3. Xfce4's workspace module on panel is not working nicely with i3 so
there is reimplemented plugin tailored to i3wm.

This patchset introduces xfce4-i3-workspaces-plugin and i3ipc-glib library as
its dependency to communicate with i3wm.

Tomáš ?ech (2):
gnu: Add i3ipc-glib
gnu: Add xfce4-i3-workspaces-plugin

gnu/packages/wm.scm | 35 +++++++++++++++++++++++++++++++++++
gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
2 files changed, 58 insertions(+)


base-commit: d663d4b6cae2289bcdd8bdcd02d58ed30769f1e2
--
2.47.1
T
T
Tomáš ?ech wrote 15 hours ago
[PATCH 1/2] gnu: Add i3ipc-glib
(address . 75567@debbugs.gnu.org)(name . Tomáš ?ech)(address . sleep_walker@gnu.org)
bedfaaab1d3576123ece65eeb71333d162acca21.1736890009.git.sleep_walker@gnu.org
* gnu/packages/wm.scm (i3ipc-glib): New variable.
---
gnu/packages/wm.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 941ef45730..f66f72e54c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -78,6 +78,7 @@
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
+;;; Copyright © 2025 Tomáš ?ech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -570,6 +571,40 @@ (define-public i3-wm
(define-public i3-gaps
(deprecated-package "i3-gaps" i3-wm))
+(define-public i3ipc-glib
+ (package
+ (name "i3ipc-glib")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/altdesktop/i3ipc-glib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01fzvrbnzcwx0vxw29igfpza9zwzp2s7msmzb92v01z0rz0y5m0p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list
+ autoconf
+ automake
+ glib
+ `(,glib "bin")
+ gobject-introspection
+ gtk-doc
+ json-glib
+ libtool
+ libxcb
+ pkg-config
+ which))
+ (home-page "https://github.com/altdesktop/i3ipc-glib")
+ (synopsis "C interface library to i3 window manager")
+ (description "An inter-process communication library to i3 window manager written in C.")
+ (license license:gpl3)))
+
+
(define-public i3lock
(package
(name "i3lock")
--
2.47.1
T
T
Tomáš ?ech wrote 15 hours ago
[PATCH 2/2] gnu: Add xfce4-i3-workspaces-plugin
(address . 75567@debbugs.gnu.org)(name . Tomáš ?ech)(address . sleep_walker@gnu.org)
cadccffc47ec43cfbd9a1a78e2c6293573c0a5a6.1736890009.git.sleep_walker@gnu.org
* gnu/packages/xfce.scm (xfce4-i3-workspaces-plugin): New variable.
---
gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 43722cf484..efc20a9d2c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
+;;; Copyright © 2025 Tomáš ?ech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -590,6 +591,28 @@ (define-public xfce4-pulseaudio-plugin
(license gpl2+)
(properties `((release-tag-prefix . ,(string-append name "-"))))))
+(define-public xfce4-i3-workspaces-plugin
+ (package
+ (name "xfce4-i3-workspaces-plugin")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/denesb/xfce4-i3-workspaces-plugin")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l957xzs479mnl1la6lx3ysaiqc0z8l84jg442wif9k8x9z6iah8"))))
+ (build-system gnu-build-system)
+ (native-inputs (list xfce4-dev-tools libxfce4ui xfce4-panel i3-wm i3ipc-glib json-glib))
+ (inputs (list glib gtk+ libxfce4util xfce4-panel))
+ (home-page "https://github.com/denesb/xfce4-i3-workspaces-plugin")
+ (synopsis "Workspace plugin for Xfce4 panel for running i3 window manager in Xfce4 desktop")
+ (description
+ "A workspace panel plugin for Xfce4, which communicates with i3 window manager.")
+ (license gpl3+)))
+
(define-public xfce4-whiskermenu-plugin
(package
(name "xfce4-whiskermenu-plugin")
--
2.47.1
?
?
??? wrote 11 hours ago
(name . Tomáš ?ech)(address . sleep_walker@gnu.org)(address . 75567@debbugs.gnu.org)
877c6w6e2q.fsf@envs.net
Tomáš ?ech <sleep_walker@gnu.org> writes:

Toggle quote (37 lines)
> * gnu/packages/xfce.scm (xfce4-i3-workspaces-plugin): New variable.
> ---
> gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
> index 43722cf484..efc20a9d2c 100644
> --- a/gnu/packages/xfce.scm
> +++ b/gnu/packages/xfce.scm
> @@ -16,6 +16,7 @@
> ;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
> +;;; Copyright © 2025 Tomáš ?ech <sleep_walker@gnu.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -590,6 +591,28 @@ (define-public xfce4-pulseaudio-plugin
> (license gpl2+)
> (properties `((release-tag-prefix . ,(string-append name "-"))))))
>
> +(define-public xfce4-i3-workspaces-plugin
> + (package
> + (name "xfce4-i3-workspaces-plugin")
> + (version "1.4.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/denesb/xfce4-i3-workspaces-plugin")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1l957xzs479mnl1la6lx3ysaiqc0z8l84jg442wif9k8x9z6iah8"))))
> + (build-system gnu-build-system)
> + (native-inputs (list xfce4-dev-tools libxfce4ui xfce4-panel i3-wm i3ipc-glib json-glib))

Hello, things other than xfce4-dev-tools should go into inputs, since
native-inputs is only for things running during build.

Toggle quote (4 lines)
> + (inputs (list glib gtk+ libxfce4util xfce4-panel))
> + (home-page "https://github.com/denesb/xfce4-i3-workspaces-plugin")
> + (synopsis "Workspace plugin for Xfce4 panel for running i3 window manager in Xfce4 desktop")

Not for running i3 window manager, maybe "Xfce panel workspace switcher plugin for the i3 window manager"
Toggle quote (3 lines)
> + (description
> + "A workspace panel plugin for Xfce4, which communicates with i3 window manager.")

Description should be a full sentence, maybe "This package provides a
workspace switcher panel plugin for Xfce, which ...".
Toggle quote (4 lines)
> + (license gpl3+)))
> +


Could you send an update, thank you!
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75567@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75567
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch