[PATCH] gnu: Add cl-trivial-battery

  • Open
  • quality assurance status badge
Details
One participant
  • Junker
Owner
unassigned
Submitted by
Junker
Severity
normal
J
J
Junker wrote 28 hours ago
(address . guix-patches@gnu.org)
f6c02d69610aefdd37350f19dddeb12171b51fc8.1736796132.git.dk@junkeria.club
Change-Id: Icdcf77738ba71e4705410aadedd6fe6f7babf1e1
---
gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e799e1a8e..61204ca4e2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -29978,6 +29978,35 @@ (define-public cl-trivial-backtrace
(define-public ecl-trivial-backtrace
(sbcl-package->ecl-package sbcl-trivial-backtrace))
+(define-public sbcl-trivial-battery
+ (let ((commit "318c9da88b4d11d3f33062e0fd09be660a383404")
+ (revision "1"))
+ (package
+ (name "sbcl-trivial-battery")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pokepay/trivial-battery")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12ni2502v9gjszhjsh0aai08cm64gl8g815xghdjhcf7y34ffl2b"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-split-sequence))
+ (home-page "https://github.com/pokepay/trivial-battery")
+ (synopsis "A trivial library for getting the battery information.")
+ (description
+ "This package provides a Common Lisp library for getting the battery information.")
+ (license license:bsd-2))))
+
+(define-public cl-trivial-battery
+ (sbcl-package->cl-source-package sbcl-trivial-battery))
+
+(define-public ecl-trivial-battery
+ (sbcl-package->ecl-package sbcl-trivial-battery))
+
(define-public sbcl-trivial-benchmark
(let ((commit "1fbc8d15f09ed8aa426bc73956b8b7c9b2668802")
(revision "2"))

base-commit: 9edb4fe373893becde2ce3e6703b33093fd0b04a
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75554@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75554
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch