(address . guix-patches@gnu.org)(address . ludo@gnu.org)
From: Sören Tempel <soeren@soeren-tempel.net>
In #68757, v3 instead of v4 of the patchset was committed by accident.
This patch revives the (minor) changes made in the v4.
* gnu/service/dns.scm: Remove exports of no longer existing names.
(unbound-service-type): Fix at typo (unbound -> Unbound).
(unbound-shepherd-service): Run after user processes.
(unbound-account-service): Determine shell based on shadow package.
---
gnu/services/dns.scm | 24 +++++++++++-------------
1 file changed, 11 insertions(+), 13 deletions(-)
Toggle diff (56 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index c74001fac29..dcfb90235c1 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -56,18 +56,14 @@ (define-module (gnu services dns)
dnsmasq-configuration
unbound-service-type
- unbound-zone
- unbound-server
unbound-configuration
unbound-configuration?
- unbound-configuration-server
- unbound-configuration-remote-control
- unbound-configuration-forward-zone
- unbound-configuration-stub-zone
- unbound-configuration-auth-zone
- unbound-configuration-view
- unbound-configuration-python
- unbound-configuration-dynlib))
+ unbound-server
+ unbound-server?
+ unbound-zone
+ unbound-zone?
+ unbound-remote
+ unbound-remote?))
;;;
;;; Knot DNS.
@@ -1065,7 +1061,9 @@ (define (unbound-shepherd-service config)
(list (shepherd-service
(documentation "Unbound daemon.")
(provision '(unbound dns))
- (requirement '(networking))
+ ;; unbound may be bound to a particular IP address, hence
+ ;; only start it after the networking service has started.
+ (requirement '(user-processes networking))
(actions (list (shepherd-configuration-action config-file)))
(start #~(make-forkexec-constructor
(list (string-append #$unbound "/sbin/unbound")
@@ -1080,11 +1078,11 @@ (define unbound-account-service
(system? #t)
(comment "Unbound daemon user")
(home-directory "/var/empty")
- (shell "/run/current-system/profile/sbin/nologin"))))
+ (shell (file-append shadow "/sbin/nologin")))))
(define unbound-service-type
(service-type (name 'unbound)
- (description "Run the unbound DNS resolver.")
+ (description "Run the Unbound DNS resolver.")
(extensions
(list (service-extension account-service-type
(const unbound-account-service))
base-commit: 4fef7b26941940515533b4b463b505b28567afe6