[PATCH v0 0/4] Add beanbag

  • Open
  • quality assurance status badge
Details
2 participants
  • Ashvith Shetty
  • Hilton Chain
Owner
unassigned
Submitted by
Ashvith Shetty
Severity
normal
A
A
Ashvith Shetty wrote on 12 Jan 19:11 +0100
(address . guix-patches@gnu.org)
20250112181145.7801-1-ashvithshetty10@gmail.com
This patch series includes beanbag, as well as it's dependencies. One
such dependency, `zig-wayland-beanbag`, is a package variant of
`zig-wayland`. `zigimg`, another dependency, does not have a tag
available yet, and hence the use of commit to pin to the version
required by beanbag.

Ashvith Shetty (4):
gnu: Add zig-clap.
gnu: Add zig-wayland-beanbag.
gnu: Add zig-img.
gnu: Add beanbag.

gnu/packages/zig-xyz.scm | 102 +++++++++++++++++++++++++++++++++++++++
1 file changed, 102 insertions(+)

--
2.47.1
A
A
Ashvith Shetty wrote on 12 Jan 19:19 +0100
[PATCH v0 1/4] gnu: Add zig-clap.
(address . 75522@debbugs.gnu.org)
20250112181920.8248-1-ashvithshetty10@gmail.com
* gnu/packages/zig-xyz.scm (zig-clap): New variable.

Change-Id: Ib438ffa083bd96102e4058d2c64dccecadff1aa5
---
gnu/packages/zig-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index a76dbb0473..afb609ad50 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -301,6 +302,26 @@ (define-public zig-xkbcommon
(home-page "https://codeberg.org/ifreund/zig-xkbcommon")
(license license:expat)))
+(define-public zig-clap
+ (package
+ (name "zig-clap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hejsil/zig-clap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/Hejsil/zig-clap")
+ (synopsis "Command line argument parsing library")
+ (description
+ "A simple and easy to use command line argument parser library for Zig.")
+ (license license:expat)))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.47.1
A
A
Ashvith Shetty wrote on 12 Jan 19:19 +0100
[PATCH v0 2/4] gnu: Add zig-wayland-beanbag.
(address . 75522@debbugs.gnu.org)
20250112181920.8248-2-ashvithshetty10@gmail.com
This is a package variant of zig-wayland required by beanbag.

* gnu/packages/zig-xyz.scm (zig-wayland-beanbag): New variable.

Change-Id: Id429a70e4cc30772357a706cd2b83798ce5ca1af
---
gnu/packages/zig-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index afb609ad50..bf86c0897a 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -240,6 +240,24 @@ (define-public zig-wayland
(home-page "https://codeberg.org/ifreund/zig-wayland")
(license license:expat)))
+(define zig-wayland-beanbag
+ (let ((commit "4761e625bcc8218650625edc4734710b29a9ff0b")
+ (revision "0"))
+ (hidden-package
+ (package
+ (inherit zig-wayland)
+ (name "zig-wayland")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ifreund/zig-wayland")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v669w8mnm5bp8508cvy41189njai8j92r6l9j5advk8589c18f7"))))))))
+
(define-public zig-wlroots
(package
(name "zig-wlroots")
--
2.47.1
A
A
Ashvith Shetty wrote on 12 Jan 19:19 +0100
[PATCH v0 3/4] gnu: Add zig-img.
(address . 75522@debbugs.gnu.org)
20250112181920.8248-3-ashvithshetty10@gmail.com
zig-img is required by beanbag. However, there's no tags at the
moment, so we'll be using the commit mentioned in beanbag's repo.

* gnu/packages/zig-xyz.scm (zig-img): New variable.

Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
---
gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index bf86c0897a..a6f5fbd453 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -340,6 +340,28 @@ (define-public zig-clap
"A simple and easy to use command line argument parser library for Zig.")
(license license:expat)))
+(define-public zig-img
+ (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
+ (revision "0"))
+ (package
+ (name "zig-img")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigimg/zigimg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/zigimg/zigimg")
+ (synopsis "Zig library for reading and writing different image formats")
+ (description
+ "This is a zig library for reading and writing different image formats.")
+ (license license:expat))))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.47.1
A
A
Ashvith Shetty wrote on 12 Jan 19:19 +0100
[PATCH v0 4/4] gnu: Add beanbag.
(address . 75522@debbugs.gnu.org)
20250112181920.8248-4-ashvithshetty10@gmail.com
* gnu/packages/zig-xyz.scm (beanbag): New variable.

Change-Id: Icbe3bfe8af1d6754ffdae38d896ee8c9dace0dab
---
gnu/packages/zig-xyz.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index a6f5fbd453..64ee303854 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -189,6 +189,47 @@ (define-public zig-known-folders
(home-page "https://github.com/ziglibs/known-folders")
(license license:expat))))
+(define-public beanbag
+ (package
+ (name "beanbag")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/bwbuhse/beanbag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i37hvg4jz9v2wfx41ycyqfq87wdh6nawgpic1mmqnj32jglkx7y"))
+ (snippet (rename-zig-dependencies '(("clap" . "zig-clap")
+ ("zigimg" . "zig-img"))))))
+ (build-system zig-build-system)
+ (arguments
+ (list
+ ;; Nothing to test
+ #:tests? #f
+ #:install-source? #f
+ #:zig-release-type "safe"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-deps
+ (lambda* (#:key inputs #:allow-other-keys)
+ (delete-file-recursively "protocol")
+ (substitute* "build.zig"
+ (("b\\.path\\(\"protocol\\/wlr-layer-shell-unstable-v1.xml\"\\)")
+ (string-append ".{ .cwd_relative = \""
+ (search-input-file inputs
+ "share/wlr-protocols/unstable/wlr-layer-shell-unstable-v1.xml")
+ "\" }"))))))))
+ (inputs (list zig-clap zig-img zig-pixman zig-wayland-beanbag
+ wlr-protocols))
+ (native-inputs (list pkg-config wlr-protocols))
+ (home-page "https://codeberg.org/bwbuhse/beanbag")
+ (synopsis "Wallpaper app for Wayland compositors")
+ (description
+ "beanbag is a wallpaper app for Wayland compositors, heavily inspired by dnkl's wbg.")
+ (license license:gpl3)))
+
(define-public zig-pixman
(package
(name "zig-pixman")
--
2.47.1
H
H
Hilton Chain wrote on 14 Jan 07:37 +0100
Re: [bug#75522] [PATCH v0 1/4] gnu: Add zig-clap.
(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
87h661529n.wl-hako@ultrarare.space
On Mon, 13 Jan 2025 02:19:00 +0800,
Ashvith Shetty wrote:
Toggle quote (8 lines)
>
>[...]
> + (build-system zig-build-system)
> + (home-page "https://github.com/Hejsil/zig-clap")
> + (synopsis "Command line argument parsing library")
> + (description
> + "A simple and easy to use command line argument parser library for Zig.")

Please use a complete sentence.

Toggle quote (7 lines)
> + (license license:expat)))
> +
> (define-public zig-zls-0.10
> (package
> (name "zig-zls")
> --
> 2.47.1
H
H
Hilton Chain wrote on 14 Jan 07:55 +0100
Re: [bug#75522] [PATCH v0 2/4] gnu: Add zig-wayland-beanbag.
(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
87frll51gs.wl-hako@ultrarare.space
On Mon, 13 Jan 2025 02:19:01 +0800,
Ashvith Shetty wrote:
Toggle quote (9 lines)
>
> This is a package variant of zig-wayland required by beanbag.
> * gnu/packages/zig-xyz.scm (zig-wayland-beanbag): New variable.
>
> Change-Id: Id429a70e4cc30772357a706cd2b83798ce5ca1af
> ---
> gnu/packages/zig-xyz.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

You can package beanbag 0.1.1 instead, which supports zig-wayland 0.2.0.

Toggle quote (17 lines)
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index afb609ad50..bf86c0897a 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -240,6 +240,24 @@ (define-public zig-wayland
> (home-page "https://codeberg.org/ifreund/zig-wayland")
> (license license:expat)))
>
> +(define zig-wayland-beanbag
> + (let ((commit "4761e625bcc8218650625edc4734710b29a9ff0b")
> + (revision "0"))
> + (hidden-package
> + (package
> + (inherit zig-wayland)
> + (name "zig-wayland")
> + (version (git-version "0.3.0" revision commit))

BTW, 0.3.0 + revision > 0.3.0.

Toggle quote (15 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/ifreund/zig-wayland")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1v669w8mnm5bp8508cvy41189njai8j92r6l9j5advk8589c18f7"))))))))
> +
> (define-public zig-wlroots
> (package
> (name "zig-wlroots")
> --
> 2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75522@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75522
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch