[PATCH v0 0/4] Add beanbag

  • Open
  • quality assurance status badge
Details
3 participants
  • Ashvith Shetty
  • Ashvith Shetty
  • Hilton Chain
Owner
unassigned
Submitted by
Ashvith Shetty
Severity
normal

Debbugs page

Ashvith Shetty wrote 2 months ago
(address . guix-patches@gnu.org)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . ekaitz@elenq.tech)
20250112181145.7801-1-ashvithshetty10@gmail.com
This patch series includes beanbag, as well as it's dependencies. One
such dependency, `zig-wayland-beanbag`, is a package variant of
`zig-wayland`. `zigimg`, another dependency, does not have a tag
available yet, and hence the use of commit to pin to the version
required by beanbag.

Ashvith Shetty (4):
gnu: Add zig-clap.
gnu: Add zig-wayland-beanbag.
gnu: Add zig-img.
gnu: Add beanbag.

gnu/packages/zig-xyz.scm | 102 +++++++++++++++++++++++++++++++++++++++
1 file changed, 102 insertions(+)

--
2.47.1
Ashvith Shetty wrote 2 months ago
[PATCH v0 1/4] gnu: Add zig-clap.
(address . 75522@debbugs.gnu.org)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . ekaitz@elenq.tech)
20250112181920.8248-1-ashvithshetty10@gmail.com
* gnu/packages/zig-xyz.scm (zig-clap): New variable.

Change-Id: Ib438ffa083bd96102e4058d2c64dccecadff1aa5
---
gnu/packages/zig-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index a76dbb0473..afb609ad50 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -301,6 +302,26 @@ (define-public zig-xkbcommon
(home-page "https://codeberg.org/ifreund/zig-xkbcommon")
(license license:expat)))
+(define-public zig-clap
+ (package
+ (name "zig-clap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hejsil/zig-clap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/Hejsil/zig-clap")
+ (synopsis "Command line argument parsing library")
+ (description
+ "A simple and easy to use command line argument parser library for Zig.")
+ (license license:expat)))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.47.1
Ashvith Shetty wrote 2 months ago
[PATCH v0 2/4] gnu: Add zig-wayland-beanbag.
(address . 75522@debbugs.gnu.org)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . ekaitz@elenq.tech)
20250112181920.8248-2-ashvithshetty10@gmail.com
This is a package variant of zig-wayland required by beanbag.

* gnu/packages/zig-xyz.scm (zig-wayland-beanbag): New variable.

Change-Id: Id429a70e4cc30772357a706cd2b83798ce5ca1af
---
gnu/packages/zig-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index afb609ad50..bf86c0897a 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -240,6 +240,24 @@ (define-public zig-wayland
(home-page "https://codeberg.org/ifreund/zig-wayland")
(license license:expat)))
+(define zig-wayland-beanbag
+ (let ((commit "4761e625bcc8218650625edc4734710b29a9ff0b")
+ (revision "0"))
+ (hidden-package
+ (package
+ (inherit zig-wayland)
+ (name "zig-wayland")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ifreund/zig-wayland")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v669w8mnm5bp8508cvy41189njai8j92r6l9j5advk8589c18f7"))))))))
+
(define-public zig-wlroots
(package
(name "zig-wlroots")
--
2.47.1
Ashvith Shetty wrote 2 months ago
[PATCH v0 3/4] gnu: Add zig-img.
(address . 75522@debbugs.gnu.org)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . ekaitz@elenq.tech)
20250112181920.8248-3-ashvithshetty10@gmail.com
zig-img is required by beanbag. However, there's no tags at the
moment, so we'll be using the commit mentioned in beanbag's repo.

* gnu/packages/zig-xyz.scm (zig-img): New variable.

Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
---
gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index bf86c0897a..a6f5fbd453 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -340,6 +340,28 @@ (define-public zig-clap
"A simple and easy to use command line argument parser library for Zig.")
(license license:expat)))
+(define-public zig-img
+ (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
+ (revision "0"))
+ (package
+ (name "zig-img")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigimg/zigimg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/zigimg/zigimg")
+ (synopsis "Zig library for reading and writing different image formats")
+ (description
+ "This is a zig library for reading and writing different image formats.")
+ (license license:expat))))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.47.1
Ashvith Shetty wrote 2 months ago
[PATCH v0 4/4] gnu: Add beanbag.
(address . 75522@debbugs.gnu.org)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . ekaitz@elenq.tech)
20250112181920.8248-4-ashvithshetty10@gmail.com
* gnu/packages/zig-xyz.scm (beanbag): New variable.

Change-Id: Icbe3bfe8af1d6754ffdae38d896ee8c9dace0dab
---
gnu/packages/zig-xyz.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index a6f5fbd453..64ee303854 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -189,6 +189,47 @@ (define-public zig-known-folders
(home-page "https://github.com/ziglibs/known-folders")
(license license:expat))))
+(define-public beanbag
+ (package
+ (name "beanbag")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/bwbuhse/beanbag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i37hvg4jz9v2wfx41ycyqfq87wdh6nawgpic1mmqnj32jglkx7y"))
+ (snippet (rename-zig-dependencies '(("clap" . "zig-clap")
+ ("zigimg" . "zig-img"))))))
+ (build-system zig-build-system)
+ (arguments
+ (list
+ ;; Nothing to test
+ #:tests? #f
+ #:install-source? #f
+ #:zig-release-type "safe"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-deps
+ (lambda* (#:key inputs #:allow-other-keys)
+ (delete-file-recursively "protocol")
+ (substitute* "build.zig"
+ (("b\\.path\\(\"protocol\\/wlr-layer-shell-unstable-v1.xml\"\\)")
+ (string-append ".{ .cwd_relative = \""
+ (search-input-file inputs
+ "share/wlr-protocols/unstable/wlr-layer-shell-unstable-v1.xml")
+ "\" }"))))))))
+ (inputs (list zig-clap zig-img zig-pixman zig-wayland-beanbag
+ wlr-protocols))
+ (native-inputs (list pkg-config wlr-protocols))
+ (home-page "https://codeberg.org/bwbuhse/beanbag")
+ (synopsis "Wallpaper app for Wayland compositors")
+ (description
+ "beanbag is a wallpaper app for Wayland compositors, heavily inspired by dnkl's wbg.")
+ (license license:gpl3)))
+
(define-public zig-pixman
(package
(name "zig-pixman")
--
2.47.1
Hilton Chain wrote 2 months ago
Re: [bug#75522] [PATCH v0 1/4] gnu: Add zig-clap.
(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . 75522@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87h661529n.wl-hako@ultrarare.space
On Mon, 13 Jan 2025 02:19:00 +0800,
Ashvith Shetty wrote:
Toggle quote (8 lines)
>
>[...]
> + (build-system zig-build-system)
> + (home-page "https://github.com/Hejsil/zig-clap")
> + (synopsis "Command line argument parsing library")
> + (description
> + "A simple and easy to use command line argument parser library for Zig.")

Please use a complete sentence.

Toggle quote (7 lines)
> + (license license:expat)))
> +
> (define-public zig-zls-0.10
> (package
> (name "zig-zls")
> --
> 2.47.1
Hilton Chain wrote 2 months ago
Re: [bug#75522] [PATCH v0 2/4] gnu: Add zig-wayland-beanbag.
(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)(address . 75522@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87frll51gs.wl-hako@ultrarare.space
On Mon, 13 Jan 2025 02:19:01 +0800,
Ashvith Shetty wrote:
Toggle quote (9 lines)
>
> This is a package variant of zig-wayland required by beanbag.
> * gnu/packages/zig-xyz.scm (zig-wayland-beanbag): New variable.
>
> Change-Id: Id429a70e4cc30772357a706cd2b83798ce5ca1af
> ---
> gnu/packages/zig-xyz.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

You can package beanbag 0.1.1 instead, which supports zig-wayland 0.2.0.

Toggle quote (17 lines)
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index afb609ad50..bf86c0897a 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -240,6 +240,24 @@ (define-public zig-wayland
> (home-page "https://codeberg.org/ifreund/zig-wayland")
> (license license:expat)))
>
> +(define zig-wayland-beanbag
> + (let ((commit "4761e625bcc8218650625edc4734710b29a9ff0b")
> + (revision "0"))
> + (hidden-package
> + (package
> + (inherit zig-wayland)
> + (name "zig-wayland")
> + (version (git-version "0.3.0" revision commit))

BTW, 0.3.0 + revision > 0.3.0.

Toggle quote (15 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/ifreund/zig-wayland")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1v669w8mnm5bp8508cvy41189njai8j92r6l9j5advk8589c18f7"))))))))
> +
> (define-public zig-wlroots
> (package
> (name "zig-wlroots")
> --
> 2.47.1
Ashvith Shetty wrote 4 weeks ago
[PATCH v1 0/3] Add beanbag
(address . 75522@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty0010@zohomail.in)
20250220190940.14643-1-ashvithshetty0010@zohomail.in
This patch series downgrades `beanbag` to 0.1.1, removes
`zig-wayland-beanbag` and fixes the synopsis and description for
`zig-clap`.

Ashvith Shetty (3):
gnu: Add zig-clap.
gnu: Add zig-img.
gnu: Add beanbag.

gnu/packages/zig-xyz.scm | 102 +++++++++++++++++++++++++++++++++++++++
1 file changed, 102 insertions(+)

--
2.48.1
Ashvith Shetty wrote 4 weeks ago
[PATCH v1 2/3] gnu: Add zig-img.
(address . 75522@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
20250220190940.14643-3-ashvithshetty0010@zohomail.in
From: Ashvith Shetty <ashvithshetty10@gmail.com>

zig-img is required by beanbag. However, there's no tags at the
moment, so we'll be using the commit mentioned in beanbag's repo.

* gnu/packages/zig-xyz.scm (zig-img): New variable.

Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
---
gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 9b6bf09b56..e8fa59227d 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -343,6 +343,28 @@ (define-public zig-clap
@end itemize")
(license license:expat)))
+(define-public zig-img
+ (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
+ (revision "0"))
+ (package
+ (name "zig-img")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zigimg/zigimg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/zigimg/zigimg")
+ (synopsis "Zig library for reading and writing different image formats")
+ (description
+ "This is a zig library for reading and writing different image formats.")
+ (license license:expat))))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.48.1
Ashvith Shetty wrote 4 weeks ago
[PATCH v1 1/3] gnu: Add zig-clap.
(address . 75522@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
20250220190940.14643-2-ashvithshetty0010@zohomail.in
From: Ashvith Shetty <ashvithshetty10@gmail.com>

* gnu/packages/zig-xyz.scm (zig-clap): New variable.

Change-Id: I8982047890799dfe32113f63e63dd7b6110eb8c6
---
gnu/packages/zig-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index a76dbb0473..9b6bf09b56 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -301,6 +302,47 @@ (define-public zig-xkbcommon
(home-page "https://codeberg.org/ifreund/zig-xkbcommon")
(license license:expat)))
+(define-public zig-clap
+ (package
+ (name "zig-clap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hejsil/zig-clap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
+ (build-system zig-build-system)
+ (arguments
+ (list
+ #:zig zig-0.13))
+ (home-page "https://github.com/Hejsil/zig-clap")
+ (synopsis "Command line argument parsing library for Zig")
+ (description
+ "A simple and easy to use command line argument parser library for Zig.
+
+Features include:
+@itemize
+@item Short arguments -a
+@itemize
+@item Chaining -abc where a and b does not take values.
+@item Multiple specifications are tallied (e.g. -v -v).
+@end itemize
+@item Long arguments --long
+@item Supports both passing values using spacing and = (-a 100, -a=100)
+@itemize
+@item Short args also support passing values with no spacing or = (-a100)
+@item This all works with chaining (-ba 100, -ba=100, -ba100)
+@end itemize
+@item Supports options that can be specified multiple times (-e 1 -e 2 -e 3)
+@item Print help message from parameter specification.
+@item Parse help message to parameter specification.
+@end itemize")
+ (license license:expat)))
+
(define-public zig-zls-0.10
(package
(name "zig-zls")
--
2.48.1
Ashvith Shetty wrote 4 weeks ago
[PATCH v1 3/3] gnu: Add beanbag.
(address . 75522@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
20250220190940.14643-4-ashvithshetty0010@zohomail.in
From: Ashvith Shetty <ashvithshetty10@gmail.com>

* gnu/packages/zig-xyz.scm (beanbag): New variable.

Change-Id: I07ebb8f6e632e4c24e183ad8d9f01f1bf17373f0
---
gnu/packages/zig-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index e8fa59227d..03118cfe85 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -189,6 +189,44 @@ (define-public zig-known-folders
(home-page "https://github.com/ziglibs/known-folders")
(license license:expat))))
+(define-public beanbag
+ (package
+ (name "beanbag")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/bwbuhse/beanbag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1d2h5bqicqnyawswdq7bg1w9frjk0ra2sva1as2qgc5s7pjclyql"))
+ (snippet (rename-zig-dependencies '(("clap" . "zig-clap")
+ ("zigimg" . "zig-img"))))))
+ (build-system zig-build-system)
+ (arguments
+ (list
+ ;; Nothing to test
+ #:tests? #f
+ #:install-source? #f
+ #:zig-release-type "safe"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-deps
+ (lambda* (#:key inputs #:allow-other-keys)
+ (delete-file-recursively "protocol")
+ (substitute* "build.zig"
+ (("protocol\\/wlr-layer-shell-unstable-v1.xml")
+ (string-append (search-input-file inputs
+ "share/wlr-protocols/unstable/wlr-layer-shell-unstable-v1.xml")))))))))
+ (inputs (list zig-clap zig-img zig-pixman zig-wayland))
+ (native-inputs (list pkg-config wlr-protocols))
+ (home-page "https://codeberg.org/bwbuhse/beanbag")
+ (synopsis "Wallpaper app for Wayland compositors")
+ (description
+ "beanbag is a wallpaper app for Wayland compositors, heavily inspired by dnkl's wbg.")
+ (license license:gpl3)))
+
(define-public zig-pixman
(package
(name "zig-pixman")
--
2.48.1
Hilton Chain wrote 4 weeks ago
(name . Ashvith Shetty)(address . ashvithshetty0010@zohomail.in)(address . 75522@debbugs.gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
87zfiezhav.wl-hako@ultrarare.space
On Fri, 21 Feb 2025 03:09:12 +0800,
Ashvith Shetty wrote:
Toggle quote (55 lines)
>
> From: Ashvith Shetty <ashvithshetty10@gmail.com>
>
> * gnu/packages/zig-xyz.scm (beanbag): New variable.
>
> Change-Id: I07ebb8f6e632e4c24e183ad8d9f01f1bf17373f0
> ---
> gnu/packages/zig-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index e8fa59227d..03118cfe85 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -189,6 +189,44 @@ (define-public zig-known-folders
> (home-page "https://github.com/ziglibs/known-folders")
> (license license:expat))))
>
> +(define-public beanbag
> + (package
> + (name "beanbag")
> + (version "0.1.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/bwbuhse/beanbag")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1d2h5bqicqnyawswdq7bg1w9frjk0ra2sva1as2qgc5s7pjclyql"))
> + (snippet (rename-zig-dependencies '(("clap" . "zig-clap")
> + ("zigimg" . "zig-img"))))))
> + (build-system zig-build-system)
> + (arguments
> + (list
> + ;; Nothing to test
> + #:tests? #f
> + #:install-source? #f
> + #:zig-release-type "safe"
> + #:phases #~(modify-phases %standard-phases
> + (add-after 'unpack 'remove-deps
> + (lambda* (#:key inputs #:allow-other-keys)
> + (delete-file-recursively "protocol")
> + (substitute* "build.zig"
> + (("protocol\\/wlr-layer-shell-unstable-v1.xml")
> + (string-append (search-input-file inputs
> + "share/wlr-protocols/unstable/wlr-layer-shell-unstable-v1.xml")))))))))
> + (inputs (list zig-clap zig-img zig-pixman zig-wayland))
> + (native-inputs (list pkg-config wlr-protocols))
> + (home-page "https://codeberg.org/bwbuhse/beanbag")
> + (synopsis "Wallpaper app for Wayland compositors")
> + (description
> + "beanbag is a wallpaper app for Wayland compositors, heavily inspired by dnkl's wbg.")

Either capitalize the first word or use @code (or @command etc. depending on
context) markup, this issue should be found by ‘guix lint’.

Since wbg is packaged, you can reference it by ‘@code{wbg}’.

Toggle quote (8 lines)
> + (license license:gpl3)))
> +
> (define-public zig-pixman
> (package
> (name "zig-pixman")
> --
> 2.48.1
>
Hilton Chain wrote 4 weeks ago
Re: [PATCH v1 1/3] gnu: Add zig-clap.
(name . Ashvith Shetty)(address . ashvithshetty0010@zohomail.in)(address . 75522@debbugs.gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
871pvq1rwk.wl-hako@ultrarare.space
On Fri, 21 Feb 2025 03:09:10 +0800,
Ashvith Shetty wrote:
Toggle quote (44 lines)
>
> From: Ashvith Shetty <ashvithshetty10@gmail.com>
>
> * gnu/packages/zig-xyz.scm (zig-clap): New variable.
>
> Change-Id: I8982047890799dfe32113f63e63dd7b6110eb8c6
> ---
> gnu/packages/zig-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index a76dbb0473..9b6bf09b56 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -3,6 +3,7 @@
> ;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
> ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
> ;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
> +;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -301,6 +302,47 @@ (define-public zig-xkbcommon
> (home-page "https://codeberg.org/ifreund/zig-xkbcommon")
> (license license:expat)))
>
> +(define-public zig-clap
> + (package
> + (name "zig-clap")
> + (version "0.9.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/Hejsil/zig-clap")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
> + (build-system zig-build-system)
> + (arguments
> + (list
> + #:zig zig-0.13))

zig-0.13 is the default, no need to set the argument.

Toggle quote (5 lines)
> + (synopsis "Command line argument parsing library for Zig")
> + (description
> + "A simple and easy to use command line argument parser library for Zig.

In case you didn't get what a full sentence is: you need a subject and a predicate.

Toggle quote (20 lines)
> +
> +Features include:
> +@itemize
> +@item Short arguments -a
> +@itemize
> +@item Chaining -abc where a and b does not take values.
> +@item Multiple specifications are tallied (e.g. -v -v).
> +@end itemize
> +@item Long arguments --long
> +@item Supports both passing values using spacing and = (-a 100, -a=100)
> +@itemize
> +@item Short args also support passing values with no spacing or = (-a100)
> +@item This all works with chaining (-ba 100, -ba=100, -ba100)
> +@end itemize
> +@item Supports options that can be specified multiple times (-e 1 -e 2 -e 3)
> +@item Print help message from parameter specification.
> +@item Parse help message to parameter specification.
> +@end itemize")
> + (license license:expat)))

Please use proper texinfo markups for codes.

Also when writing synopses and descriptions, please consider yourself an end
user and explain the package to yourself first, instead of just copying upstream
documentation. Keep in mind this is a distribution.

Toggle quote (7 lines)
> +
> (define-public zig-zls-0.10
> (package
> (name "zig-zls")
> --
> 2.48.1

BTW variables in zig-xyz.scm are sorted alphabetically. When adding new
variables, please follow this rule as well.
Hilton Chain wrote 4 weeks ago
Re: [PATCH v1 2/3] gnu: Add zig-img.
(name . Ashvith Shetty)(address . ashvithshetty0010@zohomail.in)(address . 75522@debbugs.gnu.org)(name . Ashvith Shetty)(address . ashvithshetty10@gmail.com)
8734g61t9w.wl-hako@ultrarare.space
On Fri, 21 Feb 2025 03:09:11 +0800,
Ashvith Shetty wrote:
Toggle quote (6 lines)
>
> From: Ashvith Shetty <ashvithshetty10@gmail.com>
>
> zig-img is required by beanbag. However, there's no tags at the
> moment, so we'll be using the commit mentioned in beanbag's repo.

Please reflect this information as a comment in package definition instead.

Toggle quote (36 lines)
> * gnu/packages/zig-xyz.scm (zig-img): New variable.
>
> Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
> ---
> gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 9b6bf09b56..e8fa59227d 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -343,6 +343,28 @@ (define-public zig-clap
> @end itemize")
> (license license:expat)))
>
> +(define-public zig-img
> + (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
> + (revision "0"))
> + (package
> + (name "zig-img")
> + (version (git-version "0.1.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/zigimg/zigimg")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
> + (build-system zig-build-system)
> + (home-page "https://github.com/zigimg/zigimg")
> + (synopsis "Zig library for reading and writing different image formats")
> + (description
> + "This is a zig library for reading and writing different image formats.")

zig -> Zig

Toggle quote (8 lines)
> + (license license:expat))))
> +
> (define-public zig-zls-0.10
> (package
> (name "zig-zls")
> --
> 2.48.1
>
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75522@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75522
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help