[PATCH] gnu: Add emacs-denote-explore.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Olivier Rojon
Owner
unassigned
Submitted by
Olivier Rojon
Severity
normal
O
O
Olivier Rojon wrote on 11 Jan 12:03 +0100
(address . guix-patches@gnu.org)(name . Olivier Rojon)(address . o.rojon@posteo.net)
20250111110321.26189-1-o.rojon@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-denote-explore): New variable.

Change-Id: I6b94926c522467607060e66e65e030efdbc5f70e
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d256f30bf..2e882179bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18785,6 +18785,36 @@ (define-public emacs-denote-menu
view your Denote directory.")
(license license:gpl3+)))
+(define-public emacs-denote-explore
+ (package
+ (name "emacs-denote-explore")
+ (version "3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pprevos/denote-explore")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0773691jxyv039y407c8dppkky41b3icacavddcv9m8v481763b7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-denote emacs-dash))
+ (home-page "https://github.com/pprevos/denote-explore")
+ (synopsis "Analyse and visualise a collection of Denote notes")
+ (description
+ "The Denote-Explore package provides auxiliary functions to
+maintain and explore your collection of Denote files. Denote-Explore provides
+four groups of Emacs commands:
+@enumerate
+@item Summary statistics: Count and visualise notes, attachments and keywords.
+@item Random walks: Generate new ideas using serendipity.
+@item Janitor: Manage your denote collection.
+@item Visualisations: Visualise your Denote network as a network
+graph. (optional dependencies \"GraphViz\", \"d3js\", to be acquired separately!)
+@end enumerate")
+ (license license:gpl3)))
+
(define-public emacs-logos
(let ((commit "eeedd3ef289faa4fa2b726013255747a41a6ba9c")) ;version bump
(package
--
2.47.1
N
N
Nicolas Goaziou wrote on 25 Jan 18:48 +0100
(address . 75489-done@debbugs.gnu.org)(name . Olivier Rojon)(address . o.rojon@posteo.net)
87ed0qbx9d.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-denote-explore): New variable.

Applied, with a license fix. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75489@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75489
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch