[PATCH] gnu: emacs-ledger-mode: Update to 4.0.0-1.356d804.

  • Open
  • quality assurance status badge
Details
One participant
  • Morgan Smith
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal
M
M
Morgan Smith wrote on 10 Jan 21:05 +0100
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB34242D3BBD0820AE67062635C51C2@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/finance.scm (emacs-ledger-mode): Update to 4.0.0-1.356d804.

Change-Id: Id6d23dc7c2d7a32c91c69a9c26d0d2a47d3f9fa9
---
gnu/packages/finance.scm | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 149bebfa2f..a2992344d1 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -409,8 +409,8 @@ (define-public ledger
(define-public emacs-ledger-mode
;; The last release was on Nov 8, 2019 and doesn't build with Emacs 28.
- (let ((commit "11e850395448ee7012dba16bd6df103f5552ebfb")
- (revision "0"))
+ (let ((commit "356d8049ede02c06db4f487d1d6076f74d6098c5")
+ (revision "1"))
(package
(name "emacs-ledger-mode")
(version (git-version "4.0.0" revision commit))
@@ -422,18 +422,19 @@ (define-public emacs-ledger-mode
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0hzky36vrlb7kvpyz4gy3zn01zdlmlx0s58w6ggk5djbcvjc2rfx"))))
+ (base32 "1wssagczhils0nx12b2nq2jk2gp9j26jn8nrqdrj255nzl40aia1"))))
(build-system emacs-build-system)
(arguments
(list
- ;; ledger-test.el is needed at runtime (but probably not for a good reason).
- #:exclude #~'()
#:tests? #t
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-require-tests-at-runtime
+ (lambda _
+ (substitute* "ledger-mode.el"
+ (("\\(require 'ledger-test\\)") ""))))
(add-after 'unpack 'patch-path
(lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "ledger-exec.el")
(emacs-substitute-variables "ledger-exec.el"
("ledger-binary-path" (search-input-file inputs "/bin/ledger")))))
(add-after 'build 'build-doc
@@ -446,7 +447,9 @@ (define-public emacs-ledger-mode
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(with-directory-excursion "../source/test"
- (invoke "make" "test-batch"))))))))
+ ;; Test does not respect `ledger-binary-path' and thus fails
+ (delete-file-recursively "report-test.el")
+ (invoke "make" "test"))))))))
(inputs
(list ledger))
(native-inputs

base-commit: ef025dd4c4e8cc51498146ecde619cfef9eb0779
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75479@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75479
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch