[PATCH] add hyprlock

  • Open
  • quality assurance status badge
Details
2 participants
  • squishypinkelephant
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
squishypinkelephant
Severity
normal

Debbugs page

squishypinkelephant wrote 2 months ago
(address . guix-patches@gnu.org)(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)
d9e5cebbccc70670e5f3245f1b99c585253a3247.1736349966.git.squishypinkelephant@gmail.com
loosely dependent on the patch i've submit for hyprpaper to pull (guix packages file)

Change-Id: I541ac276c25b51f66aa5fd5d275e7b3897d5d6a1
---
gnu/packages/xdisorg.scm | 47 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 17ec74ca63..61ff5546ae 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3707,6 +3707,53 @@ (define-public hyprcursor
"This package provides Hyprland cursor format, library and utilities.")
(license license:bsd-3)))
+(define-public hyprlock
+ (package
+ (name "hyprlock")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprlock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07404h6w5934yimpwb0p9dxg1w3nv702bckm4m99jbjrda6jqhmi"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:cmake ,cmake-3.30
+ #:phases
+ (modify-phases %standard-phases
+ ;; remove when fixed
+ (add-after 'unpack 'fixgldiscover
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ ((" opengl") " gl")
+ (("OpenGL REQUIRED") "OpenGL REQUIRED COMPONENTS GLES2 EGL")))))
+ #:tests? #f)) ;; no test
+ (native-inputs (list gcc-14 pkg-config))
+ (inputs
+ (list cairo
+ file
+ hyprlang
+ hyprutils
+ libdrm
+ libjpeg-turbo
+ libwebp
+ libxkbcommon
+ linux-pam
+ mesa
+ pango
+ sdbus-c++
+ wayland
+ wayland-protocols))
+ (home-page "https://hyprland.org/")
+ (synopsis "Hyprland's screen locking utility")
+ (description
+ "Hyprland's simple, yet multi-threaded and GPU-accelerated screen locking utility.")
+ (license license:bsd-3)))
+
(define-public hyprpaper
(package
(name "hyprpaper")

base-commit: 43d64438c8c31600e392534d9373ff30dbf3bb05
--
2.47.1
Tanguy Le Carrour wrote 2 weeks ago
(address . guix-patches-bounces+larch=yhetil.org@gnu.org)
D81KGW0BD4W8.2OSR58EKF1G41@bioneland.org
Hi,

Thanks for working on this!


On Wed Jan 8, 2025 at 4:49 PM CET, squishypinkelephant wrote:
Toggle quote (2 lines)
> loosely dependent on the patch i've submit for hyprpaper to pull (guix packages file)

I tried your patch with the following modifications and it works fine on my
machine:

```scheme
; …
(version "0.7.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "03ivr5nsjwiwvpdxpjnldwawy8sx8qgwhs57242xkb0zz0w0gvsk"))))
; …
(inputs (list cairo
file
hyprgraphics
hyprlang
hyprutils
hyprwayland-scanner
libdrm
libjpeg-turbo
libwebp
libxkbcommon
linux-pam
mesa
pango
sdbus-c++
wayland
wayland-protocols))
```

--
Tanguy
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75436@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75436
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help