[PATCH] add hyprpaper

  • Open
  • quality assurance status badge
Details
3 participants
  • squishypinkelephant
  • Tanguy Le Carrour
  • Andrew Wong
Owner
unassigned
Submitted by
squishypinkelephant
Severity
normal

Debbugs page

squishypinkelephant wrote 2 months ago
(address . guix-patches@gnu.org)(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)
15154ede5d768949fa4622c715d6ae7cff108211.1736349777.git.squishypinkelephant@gmail.com
Change-Id: I014a9bace20d0ebbf7ccb01458355e8d51b2d930
---
gnu/packages/xdisorg.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 46d1b714b3..7f211b6370 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -113,6 +113,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages file)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
@@ -3706,6 +3707,45 @@ (define-public hyprcursor
"This package provides Hyprland cursor format, library and utilities.")
(license license:bsd-3)))
+(define-public hyprpaper
+ (package
+ (name "hyprpaper")
+ (version "0.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprpaper")
+ ;(commit (string-append "v" version))
+ (commit "251e8e2593cdd2ef0a015f4f6e211a7bab3a63ed")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02szlhmgxffh0mq67l3da9cn13rnk42c0ans3ail5m4sk08pvrcq"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; no test
+ #:cmake ,cmake-3.30))
+ (native-inputs (list gcc-14 pkg-config))
+ (inputs
+ (list cairo
+ file
+ hyprgraphics
+ hyprlang
+ hyprutils
+ hyprwayland-scanner
+ libglvnd
+ mesa
+ pango
+ wayland
+ wayland-protocols))
+ (home-page "https://hyprland.org/")
+ (synopsis "Wallpaper utility for Hyprland")
+ (description
+ "Hyprpaper is a blazing fast wallpaper utility for Hyprland with the ability to
+dynamically change wallpapers through sockets. It will work on all wlroots-based
+compositors, though.")
+ (license license:bsd-3)))
+
(define-public hyprpicker
(package
(name "hyprpicker")

base-commit: 3fbeb1cda7ec2ca48b3aa9091ae72efc6f7ee70c
--
2.47.1
Andrew Wong wrote 1 months ago
(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)(name . guix-patches)(address . guix-patches@gnu.org)
aab1d864-4830-420f-b473-0056472d330a@icloud.com
squishypinkelephant, is this upstreamed from saayix? if so, I've just
sent in a patch (bug#75990) that should enable the latest update to
0.7.4 to be upstreamed.
Tanguy Le Carrour wrote 2 weeks ago
(address . 75435@debbugs.gnu.org)
D81K63ICR4FG.2T62W1G7RTE3D@bioneland.org
Hi,

Thanks for working on this!


On Sat Feb 1, 2025 at 11:22 AM CET, Andrew Wong via Guix-patches via wrote:
Toggle quote (4 lines)
> squishypinkelephant, is this upstreamed from saayix? if so, I've just
> sent in a patch (bug#75990) that should enable the latest update to
> 0.7.4 to be upstreamed.

For what it is worth, it works with the latest version:

``
(version "0.7.4")
(source (origin
(method git-fetch)
(uri (git-reference
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"151r6s04yy3digl3g6gs49xx41yv4xldmbnqr87gp5nz705hjsd6"))))
```

--
Tanguy
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75435@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75435
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help