[PATCH] update hyprlang and dependents

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • squishypinkelephant
Owner
unassigned
Submitted by
squishypinkelephant
Severity
normal
S
S
squishypinkelephant wrote on 8 Jan 16:47 +0100
(address . guix-patches@gnu.org)(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)
3fbeb1cda7ec2ca48b3aa9091ae72efc6f7ee70c.1736349688.git.squishypinkelephant@gmail.com
glad to see hyprland finally added, here's a small update patch.

hyprlang 0.6.0 requires gcc-14
hyprcursor needs a version bump to support the upgrade as well,
old (0.1.10) won't work with new hyprlang.

xdg-desktop-portal-hyprland, hypridle, and hyprcursor also needs
to match hyprlang on gcc-14

Change-Id: I56eec7302ee34d83795e8f29c01bafb1b1c8a14c
---
gnu/packages/cpp.scm | 6 +++---
gnu/packages/freedesktop.scm | 2 +-
gnu/packages/wm.scm | 2 +-
gnu/packages/xdisorg.scm | 6 +++---
4 files changed, 8 insertions(+), 8 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..efbbf4e4ec 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -701,7 +701,7 @@ (define-public hyprgraphics
(define-public hyprlang
(package
(name "hyprlang")
- (version "0.5.3")
+ (version "0.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -710,7 +710,7 @@ (define-public hyprlang
(file-name (git-file-name name version))
(sha256
(base32
- "0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
+ "18f8vlg5ypw35gyi8gy0wqh5jvg1q67qywrb750bx8pk9gi1agx2"))))
(build-system cmake-build-system)
(arguments
(list
@@ -723,7 +723,7 @@ (define-public hyprlang
(string-append
"set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
all))))))))
- (native-inputs (list gcc-13 pkg-config))
+ (native-inputs (list gcc-14 pkg-config))
(inputs (list hyprutils))
(home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")
(synopsis "Official implementation library for hypr config language")
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c6f18e9949..eb1359fd88 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3306,7 +3306,7 @@ (define-public xdg-desktop-portal-hyprland
(("\\<(hyprland-share-picker)\\>" _ cmd)
(string-append #$output "/bin/" cmd))))))))
(native-inputs
- (list gcc-13 hyprwayland-scanner pkg-config))
+ (list gcc-14 hyprwayland-scanner pkg-config))
(inputs
(list bash-minimal
grim
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 1da2e752ff..d9588b2fb8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -339,7 +339,7 @@ (define-public hypridle
"1622iz8bl8mi7gj2sc2jq6z7622l7l2izj1l9ajwj2mxpwpkdhbs"))))
(build-system cmake-build-system)
(arguments (list #:tests? #f)) ;No tests.
- (native-inputs (list gcc-13 pkg-config))
+ (native-inputs (list gcc-14 pkg-config))
(inputs
(list hyprlang
hyprutils
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index eadb30fab2..46d1b714b3 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3686,7 +3686,7 @@ (define-public hsetroot
(define-public hyprcursor
(package
(name "hyprcursor")
- (version "0.1.10")
+ (version "0.1.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3695,10 +3695,10 @@ (define-public hyprcursor
(file-name (git-file-name name version))
(sha256
(base32
- "1rdn03ln7pqcwp8h4nmi7nc489q8y25dd3v4paq8ykvwzhvs3a1n"))))
+ "0k050802bpgdn1hnrfgadxs54hx0zak3y3jzbjnsb69i6ayydr1c"))))
(build-system cmake-build-system)
(arguments (list #:tests? #f)) ;TODO: No themes currently packaged.
- (native-inputs (list gcc-13 pkg-config))
+ (native-inputs (list gcc-14 pkg-config))
(inputs (list cairo hyprlang (librsvg-for-system) libzip tomlplusplus))
(home-page "https://standards.hyprland.org/hyprcursor/")
(synopsis "Cursor theme format")

base-commit: e5f68e3e474a6ce5e9c5ca6b24bdc2364ef42991
--
2.47.1
J
J
John Kehayias wrote on 1 Feb 21:20 +0100
(name . squishypinkelephant)(address . squishypinkelephant@gmail.com)(address . 75434-done@debbugs.gnu.org)
87tt9dl8ni.fsf@protonmail.com
On Wed, Jan 08, 2025 at 09:47 AM, squishypinkelephant wrote:

Toggle quote (10 lines)
> glad to see hyprland finally added, here's a small update patch.
>
> hyprlang 0.6.0 requires gcc-14
> hyprcursor needs a version bump to support the upgrade as well,
> old (0.1.10) won't work with new hyprlang.
>
> xdg-desktop-portal-hyprland, hypridle, and hyprcursor also needs
> to match hyprlang on gcc-14
>

Thanks for the patches, but I already had #75923 in my inbox which has
now been applied with these same changes. It wasn't clear to me if some
of these needed to be made in the same commit (as here, but mixed with
version update too), but generally want each independent change to be
one commit.

Sorry for any duplicated work!

John

Toggle quote (93 lines)
> Change-Id: I56eec7302ee34d83795e8f29c01bafb1b1c8a14c
> ---
> gnu/packages/cpp.scm | 6 +++---
> gnu/packages/freedesktop.scm | 2 +-
> gnu/packages/wm.scm | 2 +-
> gnu/packages/xdisorg.scm | 6 +++---
> 4 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index d3a8223a9c..efbbf4e4ec 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -701,7 +701,7 @@ (define-public hyprgraphics
> (define-public hyprlang
> (package
> (name "hyprlang")
> - (version "0.5.3")
> + (version "0.6.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -710,7 +710,7 @@ (define-public hyprlang
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
> + "18f8vlg5ypw35gyi8gy0wqh5jvg1q67qywrb750bx8pk9gi1agx2"))))
> (build-system cmake-build-system)
> (arguments
> (list
> @@ -723,7 +723,7 @@ (define-public hyprlang
> (string-append
> "set(PKG_CONFIG_EXECUTABLE " #$(pkg-config-for-target) ")\n"
> all))))))))
> - (native-inputs (list gcc-13 pkg-config))
> + (native-inputs (list gcc-14 pkg-config))
> (inputs (list hyprutils))
> (home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")
> (synopsis "Official implementation library for hypr config language")
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index c6f18e9949..eb1359fd88 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -3306,7 +3306,7 @@ (define-public xdg-desktop-portal-hyprland
> (("\\<(hyprland-share-picker)\\>" _ cmd)
> (string-append #$output "/bin/" cmd))))))))
> (native-inputs
> - (list gcc-13 hyprwayland-scanner pkg-config))
> + (list gcc-14 hyprwayland-scanner pkg-config))
> (inputs
> (list bash-minimal
> grim
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 1da2e752ff..d9588b2fb8 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -339,7 +339,7 @@ (define-public hypridle
> "1622iz8bl8mi7gj2sc2jq6z7622l7l2izj1l9ajwj2mxpwpkdhbs"))))
> (build-system cmake-build-system)
> (arguments (list #:tests? #f)) ;No tests.
> - (native-inputs (list gcc-13 pkg-config))
> + (native-inputs (list gcc-14 pkg-config))
> (inputs
> (list hyprlang
> hyprutils
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index eadb30fab2..46d1b714b3 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -3686,7 +3686,7 @@ (define-public hsetroot
> (define-public hyprcursor
> (package
> (name "hyprcursor")
> - (version "0.1.10")
> + (version "0.1.11")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -3695,10 +3695,10 @@ (define-public hyprcursor
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "1rdn03ln7pqcwp8h4nmi7nc489q8y25dd3v4paq8ykvwzhvs3a1n"))))
> + "0k050802bpgdn1hnrfgadxs54hx0zak3y3jzbjnsb69i6ayydr1c"))))
> (build-system cmake-build-system)
> (arguments (list #:tests? #f)) ;TODO: No themes currently packaged.
> - (native-inputs (list gcc-13 pkg-config))
> + (native-inputs (list gcc-14 pkg-config))
> (inputs (list cairo hyprlang (librsvg-for-system) libzip tomlplusplus))
> (home-page "https://standards.hyprland.org/hyprcursor/")
> (synopsis "Cursor theme format")
>
> base-commit: e5f68e3e474a6ce5e9c5ca6b24bdc2364ef42991
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75434@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75434
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch