[PATCH 0/2] Add roll-back action to guix deploy

  • Open
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Ludovic Courtès
  • Evgeny Pisemsky
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 7 Jan 01:18 +0100
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
cover.1736208948.git.arunisaac@systemreboot.net
Hi,

I implement a roll-back action for guix deploy. This is convenient to roll
back all machines in a `guix deploy' configuration.

By the by, PATCH 1 fixes a bug necessary to make this work.

Regards,
Arun

Arun Isaac (2):
machine: ssh: Return monadic value from roll-back-managed-host.
deploy: Add roll-back action.

doc/guix.texi | 7 ++++
gnu/machine/ssh.scm | 6 ++-
guix/scripts/deploy.scm | 90 +++++++++++++++++++++++++++++++++--------
3 files changed, 84 insertions(+), 19 deletions(-)


base-commit: 67a535351f8678969e412e8dba9197a883b524d0
--
2.47.1
A
A
Arun Isaac wrote on 7 Jan 01:28 +0100
[PATCH 1/2] machine: ssh: Return monadic value from roll-back-managed-host.
(address . 75414@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
9d154b115a6a1bb7a7fb0cc24d1bd8c90a1437ab.1736208948.git.arunisaac@systemreboot.net
Previously, <unspecified> would be returned. That was a bug. Monadic
procedures must always return monadic values.

* gnu/machine/ssh.scm (roll-back-managed-host): Return monadic value.

Change-Id: I3db2879dbfbcab5e9d251fa5ed02c8653adbeafb
---
gnu/machine/ssh.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/machine/ssh.scm b/gnu/machine/ssh.scm
index bc4289ef7d..73d5dc513e 100644
--- a/gnu/machine/ssh.scm
+++ b/gnu/machine/ssh.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2024 Ricardo <rekado@elephly.net>
+;;; Copyright © 2025 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -621,8 +622,9 @@ (define (roll-back-managed-host machine)
#:store-directory-prefix store-dir
#:old-entries old-entries)))
(remote-result (machine-remote-eval machine remote-exp)))
- (when (eqv? 'error remote-result)
- (raise roll-back-failure))))
+ (if (eqv? 'error remote-result)
+ (raise roll-back-failure)
+ (return remote-result))))
;;;
--
2.47.1
A
A
Arun Isaac wrote on 7 Jan 01:28 +0100
[PATCH 2/2] deploy: Add roll-back action.
(address . 75414@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
48a1e0e70b6e9aef50c847e5882fd996c0a5476d.1736208948.git.arunisaac@systemreboot.net
* guix/scripts/deploy.scm (guix-deploy): Add the roll-back action.
(show-what-to-deploy): Optionally support the roll-back action.
(roll-back-machine*): New function.
(show-help): Document the roll-back action.
* doc/guix.texi (Invoking guix deploy): Document the roll-back action.

Change-Id: Ic5084f287aefb2d1d28380ca4ba1c6971cb913e7
---
doc/guix.texi | 7 ++++
guix/scripts/deploy.scm | 90 +++++++++++++++++++++++++++++++++--------
2 files changed, 80 insertions(+), 17 deletions(-)

Toggle diff (151 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index b2bcab8791..c08c2c70ef 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -44354,6 +44354,13 @@ Invoking guix deploy
The @command{guix deploy -x} command returns zero if and only if the
command succeeded on all the machines.
+You may also wish to roll back configurations on machines to a previous
+generation. You can do that using
+
+@example
+guix deploy roll-back @var{file}
+@end example
+
@c FIXME/TODO: Separate the API doc from the CLI doc.
Below are the data types you need to know about when writing a
diff --git a/guix/scripts/deploy.scm b/guix/scripts/deploy.scm
index 941ee199f0..3f1b8b27a7 100644
--- a/guix/scripts/deploy.scm
+++ b/guix/scripts/deploy.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2024 Richard Sent <richard@freakingpenguin.com>
+;;; Copyright © 2025 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,8 +51,13 @@ (define-module (guix scripts deploy)
(define (show-help)
- (display (G_ "Usage: guix deploy [OPTION] FILE...
-Perform the deployment specified by FILE.\n"))
+ (display (G_ "Usage: guix deploy [OPTION] [ACTION] FILE...
+Perform the deployment specified by FILE.
+Optionally, perform ACTION.\n\n"))
+ (display (G_ "The valid values for ACTION are:\n"))
+ (newline)
+ (display (G_ "\
+ roll-back switch to the previous operating system configuration\n"))
(show-build-options-help)
(newline)
(display (G_ "
@@ -118,20 +124,32 @@ (define (load-source-file file)
environment-modules))))
(load* file module)))
-(define* (show-what-to-deploy machines #:key (dry-run? #f))
- "Show the list of machines to deploy, MACHINES."
+(define* (show-what-to-deploy machines #:key (dry-run? #f) (roll-back? #f))
+ "Show the list of machines in MACHINES to deploy or roll back."
(let ((count (length machines)))
(if dry-run?
- (format (current-error-port)
- (N_ "The following ~d machine would be deployed:~%"
- "The following ~d machines would be deployed:~%"
+ (if roll-back?
+ (format (current-error-port)
+ (N_ "The following ~d machine would be rolled back:~%"
+ "The following ~d machines would be rolled back:~%"
count)
count)
- (format (current-error-port)
- (N_ "The following ~d machine will be deployed:~%"
- "The following ~d machines will be deployed:~%"
+ (format (current-error-port)
+ (N_ "The following ~d machine would be deployed:~%"
+ "The following ~d machines would be deployed:~%"
+ count)
+ count))
+ (if roll-back?
+ (format (current-error-port)
+ (N_ "The following ~d machine will be rolled back:~%"
+ "The following ~d machines will be rolled back:~%"
+ count)
count)
- count))
+ (format (current-error-port)
+ (N_ "The following ~d machine will be deployed:~%"
+ "The following ~d machines will be deployed:~%"
+ count)
+ count)))
(display (indented-string
(fill-paragraph (string-join (map machine-display-name machines)
", ")
@@ -175,6 +193,35 @@ (define (deploy-machine* store machine)
(info (G_ "successfully deployed ~a~%")
(machine-display-name machine))))
+(define (roll-back-machine* store machine)
+ "Roll back MACHINE, taking care of error handling."
+ (info (G_ "rolling back ~a...~%")
+ (machine-display-name machine))
+
+ (guard* (c
+ ;; On Guile 3.0, exceptions such as 'unbound-variable' are compound
+ ;; and include a '&message'. However, that message only contains
+ ;; the format string. Thus, special-case it here to avoid
+ ;; displaying a bare format string.
+ (((exception-predicate &exception-with-kind-and-args) c)
+ (raise c))
+
+ ((message-condition? c)
+ (leave (G_ "failed to roll back ~a: ~a~%")
+ (machine-display-name machine)
+ (condition-message c)))
+ ((formatted-message? c)
+ (leave (G_ "failed to roll back ~a: ~a~%")
+ (machine-display-name machine)
+ (apply format #f
+ (gettext (formatted-message-string c)
+ %gettext-domain)
+ (formatted-message-arguments c)))))
+ (run-with-store store (roll-back-machine machine)))
+
+ (info (G_ "successfully rolled back ~a~%")
+ (machine-display-name machine)))
+
(define (invoke-command store machine command)
"Invoke COMMAND, a list of strings, on MACHINE. Display its output (if any)
and its error code if it's non-zero. Return true if COMMAND succeeded, false
@@ -291,9 +338,18 @@ (define-command (guix-deploy . args)
machines)))
(_
(leave (G_ "'-x' specified but no command given~%"))))
- (begin
- (show-what-to-deploy machines #:dry-run? dry-run?)
- (unless dry-run?
- (map/accumulate-builds store
- (cut deploy-machine* store <>)
- machines)))))))))))
+ (match args
+ (("roll-back" _ ...)
+ (show-what-to-deploy machines
+ #:dry-run? dry-run?
+ #:roll-back? #t)
+ (unless dry-run?
+ (map/accumulate-builds store
+ (cut roll-back-machine* store <>)
+ machines)))
+ (_
+ (show-what-to-deploy machines #:dry-run? dry-run?)
+ (unless dry-run?
+ (map/accumulate-builds store
+ (cut deploy-machine* store <>)
+ machines))))))))))))
--
2.47.1
L
L
Ludovic Courtès wrote on 19 Jan 23:00 +0100
Re: [bug#75414] [PATCH 1/2] machine: ssh: Return monadic value from roll-back-managed-host.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 75414@debbugs.gnu.org)
87wmeqo461.fsf@gnu.org
Howdy Arun,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (7 lines)
> Previously, <unspecified> would be returned. That was a bug. Monadic
> procedures must always return monadic values.
>
> * gnu/machine/ssh.scm (roll-back-managed-host): Return monadic value.
>
> Change-Id: I3db2879dbfbcab5e9d251fa5ed02c8653adbeafb

LGTM!
L
L
Ludovic Courtès wrote on 19 Jan 23:07 +0100
Re: [bug#75414] [PATCH 2/2] deploy: Add roll-back action.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
87r04yo3uh.fsf@gnu.org
Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (8 lines)
> * guix/scripts/deploy.scm (guix-deploy): Add the roll-back action.
> (show-what-to-deploy): Optionally support the roll-back action.
> (roll-back-machine*): New function.
> (show-help): Document the roll-back action.
> * doc/guix.texi (Invoking guix deploy): Document the roll-back action.
>
> Change-Id: Ic5084f287aefb2d1d28380ca4ba1c6971cb913e7

[...]

Toggle quote (2 lines)
> +You may also wish to roll back configurations on machines to a previous
> +generation. You can do that using
^
I would add a colon.

Toggle quote (5 lines)
> (define (show-help)
> - (display (G_ "Usage: guix deploy [OPTION] FILE...
> -Perform the deployment specified by FILE.\n"))
> + (display (G_ "Usage: guix deploy [OPTION] [ACTION] FILE...

Hmm I would rather have ‘guix deploy --roll-back’, although that’d be
different from ‘guix system’, primarily because I don’t see what other
actions we could have, and in particular how we’d name the default
action (‘guix deploy deploy’? ‘guix deploy really’? ‘guix deploy
please’?).

Tough issue!

But note that if we make it a ‘--roll-back’ option, we can easily change
our mind later and make it an action, whereas the converse would be more
difficult.

Apart from that it looks great to me.

Thank you!

Ludo’.
E
E
Evgeny Pisemsky wrote on 24 Jan 16:45 +0100
(address . 75414@debbugs.gnu.org)
87ikq4p657.fsf@pisemsky.site
Toggle quote (6 lines)
> Hmm I would rather have ‘guix deploy --roll-back’, although that’d be
> different from ‘guix system’, primarily because I don’t see what other
> actions we could have, and in particular how we’d name the default
> action (‘guix deploy deploy’? ‘guix deploy really’? ‘guix deploy
> please’?).

The default action is =system reconfigure= on remote machine(s).

This patch implements =system roll-back= on remote machine(s)

I really miss =system delete-generations= on remote machine(s), which
understands =build-locally?= and does not trigger a lot of downloads
just to update grub, which happens when I run it directly on machine.

So one can see the tendency here - reimplementing system actions for
deploy. Since machine definition includes system definition, how bad
is the idea to just make deploy a feature of specific system actions?
Even in the manual they follow each other in the same system section.

On the other hand, it is clear that all system commands work with a
single operating system, and adding deploy may be conceptually wrong.

But if it is not, I think about an UI analogous to guix container:

#+begin_example
guix system reconfigure --machine servers.scm
guix machine exec servers.scm -- herd restart something
#+end_example

The first command actually works with systems on remote machine(s).
The second one is specific to machine(s), without affecting systems.

To me this is more flexible than one command that does everything. I
can imagine a situation when I just need to run some command on all
machines without reconfiguring them, which is currently impossible.

Of course, this is not an objection to the patch, just a brain dump.
L
L
Ludovic Courtès wrote on 25 Jan 00:13 +0100
(name . Evgeny Pisemsky)(address . mail@pisemsky.site)
87lduzbyap.fsf@gnu.org
Hi,

Evgeny Pisemsky <mail@pisemsky.site> skribis:

Toggle quote (14 lines)
>> Hmm I would rather have ‘guix deploy --roll-back’, although that’d be
>> different from ‘guix system’, primarily because I don’t see what other
>> actions we could have, and in particular how we’d name the default
>> action (‘guix deploy deploy’? ‘guix deploy really’? ‘guix deploy
>> please’?).
>
> The default action is =system reconfigure= on remote machine(s).
>
> This patch implements =system roll-back= on remote machine(s)
>
> I really miss =system delete-generations= on remote machine(s), which
> understands =build-locally?= and does not trigger a lot of downloads
> just to update grub, which happens when I run it directly on machine.

Yes, I understand. My question is more about how we’d name that default
action.

And also noting that this is a broader change than just adding support
for roll-back.

Toggle quote (5 lines)
> #+begin_example
> guix system reconfigure --machine servers.scm
> guix machine exec servers.scm -- herd restart something
> #+end_example

‘guix machine’ might actually be a better name than ‘guix deploy’.

Toggle quote (4 lines)
> To me this is more flexible than one command that does everything. I
> can imagine a situation when I just need to run some command on all
> machines without reconfiguring them, which is currently impossible.

It’s possible:

guix deploy machines.scm -x -- herd restart something

But yes, it could very well be called ‘guix machine exec …’.

Anyway, we’re going beyond what this patch series intended to address!

Ludo’.
E
E
Evgeny Pisemsky wrote 5 days ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87jzaa95ar.fsf@pisemsky.site
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
>> To me this is more flexible than one command that does everything. I
>> can imagine a situation when I just need to run some command on all
>> machines without reconfiguring them, which is currently impossible.
>
> It’s possible:
>
> guix deploy machines.scm -x -- herd restart something

This is funny and sad at the same time, because I thought that this
option works like some kind of post-deploy hook, not separate action.

The reasons are how documentation puts it and how those commands look:
the verb "deploy" just make one think it always deploys. Confusing UI.

If my opinion matters, for the current =guix deploy= interface keep
adding actions as options, explicitly stating them as separate actions
in documentation. If/when the decision to introduce =guix machine= UI
will be made, it would be better to implement actual actions there -
like in the transition from =guix environment= to =guix shell=.
A
A
Arun Isaac wrote 4 days ago
(address . 75414@debbugs.gnu.org)
875xltnvla.fsf@systemreboot.net
Hi all,

Thanks everyone for the feedback!

Toggle quote (6 lines)
> If my opinion matters, for the current =guix deploy= interface keep
> adding actions as options, explicitly stating them as separate actions
> in documentation. If/when the decision to introduce =guix machine= UI
> will be made, it would be better to implement actual actions there -
> like in the transition from =guix environment= to =guix shell=.

I'm at FOSDEM now, and will be on vacation next week. I'll work on this
and send a new patch series when I'm back home.

Regards,
Arun
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75414@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75414
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch