[PATCH] gnu: pcb2gcode: Update to pre-release.

  • Done
  • quality assurance status badge
Details
2 participants
  • Evgeny Pisemsky
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal

Debbugs page

Evgeny Pisemsky wrote 2 months ago
(address . guix-patches@gnu.org)
875xmte6wc.fsf@pisemsky.site
From a3d86f0c6e89116b6a4840c69ff1ba2b6290e93c Mon Sep 17 00:00:00 2001
Message-ID: <a3d86f0c6e89116b6a4840c69ff1ba2b6290e93c.1736073815.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Sun, 5 Jan 2025 13:35:51 +0300
Subject: [PATCH] gnu: pcb2gcode: Update to pre-release.

* gnu/packages/engineering.scm (pcb2gcode): Update to pre-release, change
indentation, run guix style.
[version]: Use git-version.
[source]: Use specific commit, do not recurse submodules (there are none).

Change-Id: I97c5b6521c86606c572ce67efc60b13351b1b4cd
---
gnu/packages/engineering.scm | 55 ++++++++++++++++++------------------
1 file changed, 27 insertions(+), 28 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f9c4ac9bbd..15827c7fdc 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3489,37 +3489,36 @@ (define-public emacs-poke
(deprecated-package "emacs-poke" poke))
(define-public pcb2gcode
- (package
- (name "pcb2gcode")
- (version "2.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pcb2gcode/pcb2gcode")
- (commit (string-append "v" version))
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "01s41znkcq9x1rinsdqrrdj8p35isckrcxs14ajsi7wr39n1m5kk"))))
- (build-system gnu-build-system)
- (inputs
- (list boost
- geos
- gerbv
- glibmm
- gtkmm-2
- (librsvg-for-system)))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (home-page "https://github.com/pcb2gcode/pcb2gcode")
- (synopsis "Generate G-code for milling PCBs")
- (description "pcb2gcode is a command-line program for isolation routing
+ (let ((commit "8c084afd00c6653dfa9cbf24a1dbeeb24f592aa9")
+ (revision "0"))
+ (package
+ (name "pcb2gcode")
+ (version (git-version "2.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pcb2gcode/pcb2gcode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19hyzd1601l51bwlv43j8l602nfacbjwqf54m5xsmj50718bcks2"))))
+ (build-system gnu-build-system)
+ (inputs (list boost
+ geos
+ gerbv
+ glibmm
+ gtkmm-2
+ (librsvg-for-system)))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (home-page "https://github.com/pcb2gcode/pcb2gcode")
+ (synopsis "Generate G-code for milling PCBs")
+ (description
+ "pcb2gcode is a command-line program for isolation routing
and drilling of PCBs. It takes Gerber files as input and outputs G-code files
for the milling of PCBs. It also includes an autoleveller for the automatic
dynamic calibration of the milling depth.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
;; libdxfrw has no readme, no version release, no tags. Initial commit says
;; "libdxfrw-0.6.3 import", but it shares no git history with "upstream"

base-commit: e383e8e34097b064d4baa4207673c6ba30617347
--
2.47.1
Sharlatan Hellseher wrote 3 days ago
[PATCH] gnu: pcb2gcode: Update to pre-release.
(address . 75381-done@debbugs.gnu.org)
87tt81kf74.fsf@gmail.com
Hi,

Thank you for the fixing patch and sorry for the long wait time on
review (Guix team is working hard to improve patch review flow).

I could not apply patch as it is with mumi or git am directly; instead
changes were applied first and authored as Evgeny Pisemsky
<mail@pisemsky.site>.

Toggle snippet (8 lines)
> $(./pre-inst-env guix build pcb2gcode)/bin/pcb2gcode --version
2.5.0
Git commit:
Boost: 108300
Gerbv: 2.10.0
Geos: 3.12.1

Pushed to master as b1a268fc540885052634ee075a37259408818e17.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCgA0FiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmfOFw8WHHNoYXJsYXRh
bnVzQGdtYWlsLmNvbQAKCRB21ye/9izStcx3D/9EQw4wBTU7vTiBptF9HBz3tab7
/bYBdMAmoR+DztQMxdv8h0QjBLzdF9lyS3vBwhhmi/tu/5LTi0y4jBdOrGLIfhLL
5nRTMvCk8KDPQyolQEFue+T2C4ymngs6Gysf2vAfzDJ+yfeEY6Ue6QnQ70CGs5aY
9svnnyCigLiQ8YrO8lmgxgiYV5C9UBnGxPHL84E/x7a0HXAhymJia33bpE6rkUDO
laKrUlTkGwbEWbrmC+BWeNqno2MYh+O1VhZHWNlOEtNBMvYElPn1kR/e4mpIrHRk
OGg/MpAaERqx3blHtnaDRvClVLOXLGLPC9AxegJ1qpD/V5O1duTjupLMyef6OfcJ
IYxC4UC695sgRVcNV4BkrHiLgJEG6NKLA09c1QlBEfXJ1zPPUkM3k3cl04st85nd
2422Rax+Gob5MAAvXacF5jt/9nzOxvafN4TX99R/PVIw3k/PrUo1j2nTNgiaKyZB
kLbXx3P92c6GKJ4G6qcTjtzo9Z+jgpSTe+B6O0IGTZzWnLHIFU1C7FIGYz47IJJA
0P0TDjvOABgqaODZjc3XMu6dl8eO0eqtfHV3RiKYB0I5Fl/qV2s2X7rrhuAkzcOD
RDjkk20Uydxf6lu4Ilw1+0tw8Vi+N1TYZTip4g0MO3mkRHeVhHsN8DmU/MySUrSX
ZS3q1I3clGafGqEZfw==
=P2cM
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75381@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75381
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help