[PATCH] gnu: tractor: Update to 5.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danial Behzadi
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Danial Behzadi
Severity
normal
D
D
Danial Behzadi wrote on 4 Jan 15:07 +0100
(address . guix-patches@gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
9cbaa3d4ab5696ff2a3174c0ab18317e560e304e.1735570393.git.dani.behzi@ubuntu.com
---
gnu/packages/tor.scm | 14 +++++---------
1 file changed, 5 insertions(+), 9 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 421f673..f02fc82 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -438,21 +438,20 @@ (define-public nyx
(define-public tractor
(package
(name "tractor")
- (version "4.1.1")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "traxtor" version))
(sha256
(base32
- "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+ "0is50z3v0mw9am31zizblq5ai30vz83qp6qsdingbn7f7cqzldmh"))))
(build-system pyproject-build-system)
(native-inputs
(list python-setuptools python-wheel
(list glib "bin"))) ; for glib-compile-schemas.
(inputs
(list python-fire
- python-psutil
python-pygobject
python-requests
python-stem
@@ -465,19 +464,16 @@ (define-public tractor
(add-after 'install 'install-man-page
(lambda _
(let ((man1 (string-append #$output "/share/man/man1")))
- (install-file "tractor/man/tractor.1" man1))))
+ (install-file "data/tractor.1" man1))))
(add-after 'install 'install-bash-completion
(lambda _
- (mkdir "bash-completion")
- (rename-file "tractor/tractor-completion"
- "bash-completion/tractor")
(let ((bash-completion
(string-append #$output "/share/bash-completion/completions")))
- (install-file "bash-completion/tractor" bash-completion))))
+ (install-file "data/completion/bash/tractor" bash-completion))))
(add-after 'install 'install-gschema
(lambda _
(let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "tractor/tractor.gschema.xml" schemas)))))))
+ (install-file "src/tractor/tractor.gschema.xml" schemas)))))))
(home-page "https://framagit.org/tractor")
(synopsis "Setup an onion routing proxy")
(description
--
2.45.2
S
S
Sharlatan Hellseher wrote 6 days ago
(address . 75351-done@debbugs.gnu.org)
87o6zhiv91.fsf@gmail.com
Hi,

Thanks for the patch.

Pushed to master as

f61d448a075 * gnu: tractor: Update to 5.0.0.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmeiMkoACgkQdtcnv/Ys
0rV5tRAAtFhPKPWmLvZ14/UzMLqGve72tJ7FSX69Fw4F6m6dfvI7c0pByPHdBET2
OfBMG2SPIcRPeOvP/pVw421zcMWvvltwjJmYXB6Ek6lziqNleGjvWhGnLsOjYvJG
thmq8DtsO8dKCpHyROb7SvENuJcZ0qCOdLrbgrtHD0YRT5trRhxsr/3cXGfCKRJw
jVxRiAZJYi39AiLUVrscHcW8GewnjWEX3eujD51BkZ+028PxE+Hh6kun0xXTt1Z9
czy2EXA0/qRaPyvrr0OriyWdHIxDaVhnWbSBNXgLJmiBu31KbYbciXn+0aX3BJae
TNXePZcnP0vuAkdrXNd4zTgWzKB9Pp1rYMjVedJ7jJdLWrueoPysvSi3Er2aQzIM
Jy2PWLlIw8psW6bocGrWOHRRZOXHGBb8ut/BnVQBsEfi2WobkaX3RJvLokJA96Hv
ZyA71G6z/rI/GuqYDCIi2fVFtdTc+9b6WPwvvGKoXWWEdp5+hrwFDqvYbrSBlzcP
fdY4RbdkbxvI+DdcXsBvti5QKSfd3XWwU1IczkKIuZL/PUQmvIMALy5yvmQWCmO5
f3y3JBtxJhlErDqcGyWkL8VNYcG9FsNXQLaQYEsCaQAOauXr/L9jN1dK57T4sHFu
ndh53djFneOJy2TelDtRYYBjArgv7FE7ppqInvnbVuSmxEZFAgI=
=1Jzf
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75351@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75351
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch