[PATCH 0/6] Update xtensor-stack packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 3 Jan 21:33 +0100
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1735936141.git.sharlatanus@gmail.com
Hi Guix,

While refreshing AOCommon for Astro update I've noticed it started requiring
xtl, xsimd, xtensor, xtensor-blas, and xtensor-fftw from

This series of patches improve style and update 3 of them. I would package
xtensor-blas and xtensor-fftw in separate issue.


Sharlatan Hellseher (6):
gnu: xsimd: Improve package style.
gnu: xsimd: Update to 11.0.0.
gnu: xtl: Improve package style.
gnu: xtl: Update to 0.7.7.
gnu: xtensor: Improve package style.
gnu: xtensor: Update to 0.25.0.

gnu/packages/algebra.scm | 34 ++++++++++++---------
gnu/packages/cpp.scm | 66 +++++++++++++++++++---------------------
2 files changed, 51 insertions(+), 49 deletions(-)


base-commit: ce3ffac5d366ebf20e0d95779f2fe1ea6dde0202
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 1/6] gnu: xsimd: Improve package style.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
628be607cc460971c8e7dfbf5992e5c93375ad5e.1735936141.git.sharlatanus@gmail.com
* gnu/packages/cpp.scm (xsimd) [source] <url>: Fix redirection issue,
https://github.com/QuantStack/xsimd permamently redirects to
[arguments]: Use G-expressions.
[description]: Adjust fill column indentation.

Change-Id: I8096e07c026c9f08a9d647a44f9930900b3ae1bd
---
gnu/packages/cpp.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..5bd56e704f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -611,25 +611,26 @@ (define-public xsimd
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/QuantStack/xsimd")
+ (url "https://github.com/xtensor-stack/xsimd")
(commit version)))
(sha256
(base32 "1fcy0djwpwvls6yqxqa82s4l4gvwkqkr8i8bibbb3dm0lqvhnw52"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags (list "-DBUILD_TESTS=ON")
- #:test-target "xtest"))
+ (list
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
(native-inputs
(list googletest))
(home-page "https://github.com/xtensor-stack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description
- "xsimd provides a unified means for using @acronym{SIMD, single instruction
-multiple data} features for library authors. Namely, it enables manipulation of
-batches of numbers with the same arithmetic operators as for single values.
-It also provides accelerated implementation of common mathematical functions
-operating on batches.")
+ "xsimd provides a unified means for using @acronym{SIMD, single
+instruction multiple data} features for library authors. Namely, it enables
+manipulation of batches of numbers with the same arithmetic operators as for
+single values. It also provides accelerated implementation of common
+mathematical functions operating on batches.")
(license license:bsd-3)))
(define-public google-highway
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 3/6] gnu: xtl: Improve package style.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
95c2919e824254299494c46242ddfdf58bb4067f.1735936141.git.sharlatanus@gmail.com
* gnu/packages/cpp.scm (xtl): Shift order of fields.
[source] <url>: Fix redirection issue,
https://github.com/QuantStack/xtl permamently redirects to
[arguments] <test-target>: Set to "xtest".
<phases>: Use default 'check.
[home-page]: Fix it.

Change-Id: Ib3bc50b7a9e798be8888c2b1eac832d6a524bdae
---
gnu/packages/cpp.scm | 39 +++++++++++++++++----------------------
1 file changed, 17 insertions(+), 22 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 151b01f7e5..121cc64f17 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1061,30 +1061,25 @@ (define-public xtl
(package
(name "xtl")
(version "0.7.5")
- (source (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/QuantStack/xtl")
- (commit version)))
- (sha256
- (base32
- "1llfy6pkzqx2va74h9xafjylyvw6839a843mqc05n6x6wll5bkam"))
- (file-name (git-file-name name version))))
- (native-inputs
- (list doctest googletest nlohmann-json))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtensor-stack/xtl")
+ (commit version)))
+ (sha256
+ (base32 "1llfy6pkzqx2va74h9xafjylyvw6839a843mqc05n6x6wll5bkam"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
(arguments
(list
- #:configure-flags
- #~(list "-DBUILD_TESTS=ON")
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (with-directory-excursion "test"
- (invoke "./test_xtl")))))))
- (home-page "https://github.com/QuantStack/xtl")
- (build-system cmake-build-system)
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
+ (native-inputs
+ (list doctest
+ googletest
+ nlohmann-json))
+ (home-page "https://github.com/xtensor-stack/xtl")
(synopsis "C++ template library providing some basic tools")
(description "xtl is a C++ header-only template library providing basic
tools (containers, algorithms) used by other QuantStack packages.")
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 4/6] gnu: xtl: Update to 0.7.7.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
5ce7f036220f8c6a1ca3a5a037e07cc09b0ca72e.1735936141.git.sharlatanus@gmail.com
* gnu/packages/cpp.scm (xtl): Update to 0.7.7.

Change-Id: Ifeaf490093ea6af0f7341a3fd3f73acf8cf5e06f
---
gnu/packages/cpp.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 121cc64f17..f8971b9616 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1060,7 +1060,7 @@ (define-public tomlplusplus
(define-public xtl
(package
(name "xtl")
- (version "0.7.5")
+ (version "0.7.7")
(source
(origin
(method git-fetch)
@@ -1068,7 +1068,7 @@ (define-public xtl
(url "https://github.com/xtensor-stack/xtl")
(commit version)))
(sha256
- (base32 "1llfy6pkzqx2va74h9xafjylyvw6839a843mqc05n6x6wll5bkam"))
+ (base32 "1b42mjxchinsf2ylbvhyypfysg5sfphxqby53vlg82wvr23rijkz"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 2/6] gnu: xsimd: Update to 11.0.0.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
c94c96f82d3bef27ef28c5e5bfa8fcb29b7f190d.1735936141.git.sharlatanus@gmail.com
* gnu/packages/cpp.scm (xsimd): Update to 11.0.0.
[native-inputs]: Add doctest.

Change-Id: I8c49ff34288cdf5429034668ddd496c345ddfb34
---
gnu/packages/cpp.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5bd56e704f..151b01f7e5 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Peepo Froggings <peepofroggings@tutanota.de>
;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
+;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; This file is part of GNU Guix.
;;;
@@ -606,7 +607,7 @@ (define-public debug-assert
(define-public xsimd
(package
(name "xsimd")
- (version "9.0.1")
+ (version "11.0.0")
(source
(origin
(method git-fetch)
@@ -614,7 +615,7 @@ (define-public xsimd
(url "https://github.com/xtensor-stack/xsimd")
(commit version)))
(sha256
- (base32 "1fcy0djwpwvls6yqxqa82s4l4gvwkqkr8i8bibbb3dm0lqvhnw52"))
+ (base32 "148wylv88vp31rz7l357ch7k0l50apfk4x31qdqk9y4d2hj6ld3f"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -622,7 +623,8 @@ (define-public xsimd
#:configure-flags #~(list "-DBUILD_TESTS=ON")
#:test-target "xtest"))
(native-inputs
- (list googletest))
+ (list doctest
+ googletest))
(home-page "https://github.com/xtensor-stack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 5/6] gnu: xtensor: Improve package style.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
8def7467515b8fdb5acb54312a04fc8248a28e71.1735936141.git.sharlatanus@gmail.com
* gnu/packages/algebra.scm (xtensor): Shift fields order. Use
G-expressions.

Change-Id: Ica85f3e848a99eea45e07156eb659558fc6c0804
---
gnu/packages/algebra.scm | 30 ++++++++++++++++--------------
1 file changed, 16 insertions(+), 14 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5da77b6318..4d84958abf 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1164,22 +1164,24 @@ (define-public xtensor
(package
(name "xtensor")
(version "0.24.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xtensor-stack/xtensor")
- (commit version)))
- (sha256
- (base32
- "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
- (file-name (git-file-name name version))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtensor-stack/xtensor")
+ (commit version)))
+ (sha256
+ (base32 "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
- (native-inputs
- (list doctest googletest xtl))
(arguments
- `(#:configure-flags
- '("-DBUILD_TESTS=ON")
- #:test-target "xtest"))
+ (list
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
+ (native-inputs
+ (list doctest
+ googletest
+ xtl))
(home-page "https://xtensor.readthedocs.io/en/latest/")
(synopsis "C++ tensors with broadcasting and lazy computing")
(description "xtensor is a C++ library meant for numerical analysis with
--
2.46.0
S
S
Sharlatan Hellseher wrote on 3 Jan 21:35 +0100
[PATCH 6/6] gnu: xtensor: Update to 0.25.0.
(address . 75326@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
183165fb0270e8697550f3ebdbe0699ee97e4e3a.1735936141.git.sharlatanus@gmail.com
* gnu/packages/algebra.scm (xtensor): Update to 0.25.0.
[native-inputs]: Add nlohmann-json.

Change-Id: Iccaf397423d2a2b7b008082a9761c89ca2adc9a2
---
gnu/packages/algebra.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4d84958abf..a1217c53d3 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
+;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1163,7 +1164,7 @@ (define-public eigen-for-tensorflow
(define-public xtensor
(package
(name "xtensor")
- (version "0.24.6")
+ (version "0.25.0")
(source
(origin
(method git-fetch)
@@ -1171,7 +1172,7 @@ (define-public xtensor
(url "https://github.com/xtensor-stack/xtensor")
(commit version)))
(sha256
- (base32 "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
+ (base32 "0ziqybfm0fh6kr8qwxqacr04m9gm0njbn520izm6rsh9hysxsmw5"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -1181,6 +1182,7 @@ (define-public xtensor
(native-inputs
(list doctest
googletest
+ nlohmann-json
xtl))
(home-page "https://xtensor.readthedocs.io/en/latest/")
(synopsis "C++ tensors with broadcasting and lazy computing")
--
2.46.0
A
A
Andreas Enge wrote on 20 Jan 13:23 +0100
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
Z45ANrXYlkeTOcWg@jurong
Looks good, thank you!

Andreas

Am Fri, Jan 03, 2025 at 08:35:06PM +0000 schrieb Sharlatan Hellseher:
Toggle quote (2 lines)
> * gnu/packages/algebra.scm (xtensor): Update to 0.25.0.
> [native-inputs]: Add nlohmann-json.
S
S
Sharlatan Hellseher wrote on 22 Jan 00:39 +0100
[PATCH 0/6] Update xtensor-stack packages.
(address . 75326-done@debbugs.gnu.org)
87ldv3ivok.fsf@gmail.com
Pushed as:

5d6e4cedb56 * master gnu: xtensor: Update to 0.25.0.
5115dacc571 * gnu: xtensor: Improve package style.
e25dcf3bad5 * gnu: xtl: Update to 0.7.7.
27349661bb3 * gnu: xtl: Improve package style.
fbfff97ea94 * gnu: xsimd: Update to 11.0.0.
f165f68188c * gnu: xsimd: Improve package style.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmeQMBsACgkQdtcnv/Ys
0rVukRAApTYLB6kaHV0XEwuMFe7CNdpnaxkCbMOVR9K5tObKD4c6jhSV/5O2yuxp
HiL/VVULDmFzPk6SxNuqzWDWGJvSIrc2mRgQcQgNW9pLynLMrRiGP9O9Mmjpjk0+
uOQCFOKu3gJanx75l0N/ajWe+Tl7cZ2EKZVnV2SKy1dbyRRtxFxF9SvEHoaraF2k
2pc9/jU4HM4x0bj7gzAtg+h2hYzjBMMSfv8ETNqMoyeyvR064cPHogcWYyV7YyFM
pNmVxkAHko7BONKzLZ0ACPpjU/jf2Ws/FWe14yBR9uMDyb0dd4SflUGad6S7vIQO
iFI/mdqmR6uk9N2IK3nOTwtTE+0Dc2JzKGAsqCsOqTVbvzTRyYdCYQyCpeYC1mC7
1XZWsctA+InQrjSRMkk3hhJxSVsGGN+2QoJ1k9mlwBTG/QT/Krv5LK0JG13A2NQy
4YYz8J1gfeD6RF1DYsgp9PXk9SC4uTrK1fL0wraiO44HSYtCNHPrun8mykZLEp1N
v2hz7QxZ9zZJnFk0evi2pTE+z9sEJRVeuO/QXtbP1Yf92TY6uoe16PmH1jLNxykS
rj0aWROhqc18uDbpqEGcSTn5VIqDJaST+IKkEYqFLuoE6SWWAJw3H1Qn455dy0iI
Bm+vUeK2yGhmSqo08yv9bOcXLTw/59oaI/Z3jA5Xv75FPv7VPCA=
=mz6i
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75326@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75326
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch