[PATCH] gnu: greetd: Update to 0.10.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • muradm
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 3 Jan 14:09 +0100
(address . guix-patches@gnu.org)
20250103130943.20992-1-ngraves@ngraves.fr
* gnu/packages/admin.scm (greetd): Update to 0.10.3.
[arguments]<#:cargo-inputs>: Replace rust-nix-0.26 by rust-nix-0.27.
---
gnu/packages/admin.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 466df65dd9..045292a37d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5651,7 +5651,7 @@ (define-public udpcast
(define-public greetd
(package
(name "greetd")
- (version "0.9.0")
+ (version "0.10.3")
(home-page "https://git.sr.ht/~kennylevinsen/greetd")
(source (origin
(method git-fetch)
@@ -5660,11 +5660,11 @@ (define-public greetd
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1b79lb0vikh5vwpdlyga6zwzm11gpsd7ghp8zb0q2m6mlqlj5by3"))))
+ (base32 "1j3c7skby9scsq6p1f6nacbiy9b26y1sswchdsp8p3vv7fgdh2wf"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-nix" ,rust-nix-0.26)
+ (("rust-nix" ,rust-nix-0.27)
("rust-pam-sys" ,rust-pam-sys-0.5)
("rust-rpassword" ,rust-rpassword-5)
("rust-users" ,rust-users-0.11)
--
2.47.1
M
M
muradm wrote on 3 Jan 18:45 +0100
(address . 75312@debbugs.gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
a6dc636e5afa5442f92fb97df1c5f174aecb7f18.1735926326.git.mail@muradm.net
* gnu/packages/admin.scm (greetd): Update to 0.10.3.
* gnu/tests/desktop.scm (minimal-desktop): greetd don't share GREETD_SOCK any more.

Change-Id: I51af36f24fa4647dfde3aeb5c3d68b5cb353a8f9
---
gnu/packages/admin.scm | 6 +++---
gnu/tests/desktop.scm | 6 +++---
2 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 466df65dd9..045292a37d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5651,7 +5651,7 @@ (define-public udpcast
(define-public greetd
(package
(name "greetd")
- (version "0.9.0")
+ (version "0.10.3")
(home-page "https://git.sr.ht/~kennylevinsen/greetd")
(source (origin
(method git-fetch)
@@ -5660,11 +5660,11 @@ (define-public greetd
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1b79lb0vikh5vwpdlyga6zwzm11gpsd7ghp8zb0q2m6mlqlj5by3"))))
+ (base32 "1j3c7skby9scsq6p1f6nacbiy9b26y1sswchdsp8p3vv7fgdh2wf"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-nix" ,rust-nix-0.26)
+ (("rust-nix" ,rust-nix-0.27)
("rust-pam-sys" ,rust-pam-sys-0.5)
("rust-rpassword" ,rust-rpassword-5)
("rust-users" ,rust-users-0.11)
diff --git a/gnu/tests/desktop.scm b/gnu/tests/desktop.scm
index ef30442886..1c32076ccb 100644
--- a/gnu/tests/desktop.scm
+++ b/gnu/tests/desktop.scm
@@ -244,14 +244,14 @@ (define (run-minimal-desktop-test os vm)
(sort (filter expected-var user-env) string<?)))
- (test-assert "validate SEATD_SOCK and GREETD_SOCK"
+ (test-assert "validate SEATD_SOCK"
(begin
(marionette-type "env > env\n" marionette)
(sleep 1)
(define (sock-var? var)
(any (lambda (s) (string-contains var s))
- '("SEATD_SOCK" "GREETD_SOCK")))
+ '("SEATD_SOCK")))
(define (sock-var-sock var)
(car (cdr (string-split var #\=))))
@@ -262,7 +262,7 @@ (define (run-minimal-desktop-test os vm)
(out (filter sock-var? out))
(socks (map sock-var-sock out))
(socks (map wait-for-unix-socket-m socks)))
- (and (= 2 (length socks)) (every identity socks)))))
+ (and (= 1 (length socks)) (every identity socks)))))
(test-equal "seatd.sock ownership"
'("root" "seat")

base-commit: ce3ffac5d366ebf20e0d95779f2fe1ea6dde0202
--
2.47.1
L
L
Ludovic Courtès wrote on 20 Jan 00:28 +0100
(name . muradm)(address . mail@muradm.net)
87bjw2o01y.fsf@gnu.org
Hi muradm,

muradm <mail@muradm.net> skribis:

Toggle quote (5 lines)
> * gnu/packages/admin.scm (greetd): Update to 0.10.3.
> * gnu/tests/desktop.scm (minimal-desktop): greetd don't share GREETD_SOCK any more.
>
> Change-Id: I51af36f24fa4647dfde3aeb5c3d68b5cb353a8f9

‘greetd’ had been upgraded independently in
55cead2c49e0740c1595fdc5ecce7d050c36e080, but without updating the
‘minimal-desktop’ test.

I committed the test fix on your behalf as
bc6769f1211104dbc9341c064275cd930f5dfa3a.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75312@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75312
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch