[PATCH] gnu: dico: Update to 2.12, gcide: Update to 0.54.

  • Open
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
b466281dee27f8ae44885e0f0447030f26a2fc50.1735892014.git.atai@atai.org
* gnu/packages/dico.scm (dico): Update to 2.12.
* gnu/packages/dictionaries.scm (gcide): Update to 0.54.

Change-Id: I5e8bcc47c996642dd3b5a840f390debdfd3280e4
---
gnu/packages/dico.scm | 4 ++--
gnu/packages/dictionaries.scm | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/dico.scm b/gnu/packages/dico.scm
index 9f8c5cccc1..af0b6fd348 100644
--- a/gnu/packages/dico.scm
+++ b/gnu/packages/dico.scm
@@ -41,14 +41,14 @@ (define-module (gnu packages dico)
(define-public dico
(package
(name "dico")
- (version "2.11")
+ (version "2.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/dico/dico-"
version ".tar.xz"))
(sha256
(base32
- "0nic4mggc0yhms130k7x4qp5k9c42fwg6n8hmk5cmynh6gi9h7xc"))))
+ "1xvahrav8aml90qcj4cj3a33y0n7nm1k0ywgks1zy2q91v2qk2vj"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 21c3f668d2..a046764b21 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -119,14 +119,14 @@ (define-public vera
(define-public gcide
(package
(name "gcide")
- (version "0.53")
+ (version "0.54")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://gnu/gcide/gcide-" version ".tar.xz"))
(sha256
(base32
- "17rigzfmih5i1z5s5v1hdr1jw8rngf40768kblnh5kp19ncbvb6k"))))
+ "0hhxqlkgp3kkin4pqzfgfd24ckai29sm9dw8qc6icnqp6rpnyh92"))))
(build-system copy-build-system)
(arguments
'(#:install-plan

base-commit: a707ebe5d3875a49523bc17de2d36af6f1c18f7e
--
2.34.1
Ludovic Courtès wrote 2 months ago
(name . Andy Tai)(address . atai@atai.org)(address . 75309@debbugs.gnu.org)
877c6v3q0c.fsf@gnu.org
Andy Tai <atai@atai.org> skribis:

Toggle quote (5 lines)
> * gnu/packages/dico.scm (dico): Update to 2.12.
> * gnu/packages/dictionaries.scm (gcide): Update to 0.54.
>
> Change-Id: I5e8bcc47c996642dd3b5a840f390debdfd3280e4

Hi! I split it in two commits, since the two upgrades are unrelated.

However, the dico upgrade breaks its system test:

Toggle snippet (33 lines)
$ make check-system TESTS=dicod
[…]
Test begin:
test-name: "connect"
source-file: "/gnu/store/qyzjhz26fj846hsxfh4jnzsxvhmxc4h3-dicod-builder"
source-line: 1
source-form: (test-assert "connect" (let ((addr (make-socket-address AF_INET INADDR_LOOPBACK )
Test end:
result-kind: pass
actual-value: #<eof>
Test begin:
test-name: "CLIENT"
source-file: "/gnu/store/qyzjhz26fj846hsxfh4jnzsxvhmxc4h3-dicod-builder"
source-line: 1
source-form: (test-equal "CLIENT" "250 ok\r\n" (begin (display "CLIENT \"GNU Guile\"\r\n" %di)
Test end:
result-kind: fail
actual-value: #<eof>
expected-value: "250 ok\r\n"
Test begin:
test-name: "DEFINE"
source-file: "/gnu/store/qyzjhz26fj846hsxfh4jnzsxvhmxc4h3-dicod-builder"
source-line: 1
source-form: (test-assert "DEFINE" (begin (display "DEFINE ! hello\r\n" %dico-socket) (displa)
Test end:
result-kind: fail
actual-value: #f
actual-error: (system-error "fport_write" "~A" ("Broken pipe") (32))
Group end: dicod
# of expected passes 3
# of unexpected failures 2

Could you take a look?

For now I’ve only kept the gcide upgrade.

Thanks,
Ludo’.
Ludovic Courtès wrote 2 months ago
control message for bug #75309
(address . control@debbugs.gnu.org)
877c6ru8i4.fsf@gnu.org
tags 75309 + moreinfo
quit
Andy Tai wrote 2 months ago
Re: [bug#75309] [PATCH] gnu: dico: Update to 2.12, gcide: Update to 0.54.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 75309@debbugs.gnu.org)
CAJsg1E-On3891vA6JSHYQn9oT_pO2Mq8-H41vDqocJZ7XL5r9A@mail.gmail.com
Interesting.... GNU Guix itself has a test for dico

I will take a look

On Thu, Jan 16, 2025 at 4:24 AM Ludovic Courtès <ludo@gnu.org> wrote
Toggle quote (5 lines)
> However, the dico upgrade breaks its system test:
>
> --8<---------------cut here---------------start------------->8---
> $ make check-system TESTS=dicod
> […]
Ludovic Courtès wrote 3 weeks ago
(name . Andy Tai)(address . atai@atai.org)(address . 75309@debbugs.gnu.org)
87zfihexhn.fsf@gnu.org
Hi Andy,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (11 lines)
> Andy Tai <atai@atai.org> skribis:
>
>> * gnu/packages/dico.scm (dico): Update to 2.12.
>> * gnu/packages/dictionaries.scm (gcide): Update to 0.54.
>>
>> Change-Id: I5e8bcc47c996642dd3b5a840f390debdfd3280e4
>
> Hi! I split it in two commits, since the two upgrades are unrelated.
>
> However, the dico upgrade breaks its system test:

Did you have a chance to look into it?

Ludo’.
Andy Tai wrote 3 weeks ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 75309@debbugs.gnu.org)
CAJsg1E8k2=q3ntYShx4AOcnGbcry0egwMbGSpK-HZf9Ac5Y9+g@mail.gmail.com
Hi, I did try to look into it but for now I do not have enough background
on this particular program to really investigate the failure of the unit
test on Guix's side about this program... may take more time for me to
figure this out--or my guess is something changed in dico that broke the
unit test for it in Guix so maybe waiting for the next release to see if it
makes a difference

On Thu, Feb 20, 2025 at 2:12 AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (21 lines)
> Hi Andy,
>
> Ludovic Courtès <ludo@gnu.org> skribis:
>
> > Andy Tai <atai@atai.org> skribis:
> >
> >> * gnu/packages/dico.scm (dico): Update to 2.12.
> >> * gnu/packages/dictionaries.scm (gcide): Update to 0.54.
> >>
> >> Change-Id: I5e8bcc47c996642dd3b5a840f390debdfd3280e4
> >
> > Hi! I split it in two commits, since the two upgrades are unrelated.
> >
> > However, the dico upgrade breaks its system test:
>
> Did you have a chance to look into it?
>
> Ludo’.
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2025 民國114年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Andy Tai wrote 3 weeks ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 75309@debbugs.gnu.org)
CAJsg1E-1EpnEYDbqvDUR5yKXEQLqhKVRb872k7JpJPciATNiBg@mail.gmail.com
I forgot to mention if you have any guidance or clues on this dico
stuff, more than welcome.

On Fri, Feb 21, 2025 at 11:29 PM Andy Tai <atai@atai.org> wrote:
Toggle quote (3 lines)
>
> Hi, I did try to look into it but for now I do not have enough background on this particular program to really investigate the failure of the unit test on Guix's side about this program... may take more time for me to figure this out--or my guess is something changed in dico that broke the unit test for it in Guix so maybe waiting for the next release to see if it makes a difference
>
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help