Lars Bilke wrote 2 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
* gnu/packages/geo.scm (tetgen): New variable.
Change-Id: Iba2de71cf0a10ca5c7b65f9851d05fe63c944b30
---
gnu/packages/geo.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8b9b9a4cf7..ec48474708 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3614,3 +3614,29 @@ (define-public laszip
@code{LAZ} files. The @code{LAS} format is a file format designed for the
interchange and archiving of lidar point cloud data.")
(license license:asl2.0)))
+
+ (define-public tetgen
+ (package
+ (name "tetgen")
+ (synopsis
+ "Quality Tetrahedral Mesh Generator and 3D Delaunay Triangulator")
+ (license license:agpl3)
+ (description
+ "TetGen is a program to generate tetrahedral meshes of any 3D
+polyhedral domains. TetGen generates exact constrained Delaunay
+tetrahedralizations, boundary conforming Delaunay meshes, and Voronoi
+partitions.")
+ (home-page "https://wias-berlin.de/software/tetgen/")
+ (version "1.5.1-2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/tetgen")
+ (commit version)))
+ (sha256
+ (base32 "0hd8mvmzybvlgvfx131p8782v8hggmg53vlkgazpsw9d6ympfcrv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags (list "-DCMAKE_POSITION_INDEPENDENT_CODE=ON")))))
base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1