(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
* gnu/packages/xml.scm (xmlpatch): New variable.
Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5bbd1dd64e..bc354e74f7 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2023,3 +2023,25 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (synopsis "XML patch library")
+ (license license:lgpl2.1)
+ (description
+ "A C++ library for patching XML files with XPath expressions.")
+ (home-page "https://xmlpatch.sourceforge.net")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
+ (build-system cmake-build-system)
+ (inputs (list libxml2))
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))))
base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1