[PATCH] gnu: Add xmlpatch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 2 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
9c21c0e1bb3818bed293f84f4b4c122fc47258e2.1735828404.git.lars.bilke@ufz.de
* gnu/packages/xml.scm (xmlpatch): New variable.

Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5bbd1dd64e..bc354e74f7 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2023,3 +2023,25 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (synopsis "XML patch library")
+ (license license:lgpl2.1)
+ (description
+ "A C++ library for patching XML files with XPath expressions.")
+ (home-page "https://xmlpatch.sourceforge.net")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
+ (build-system cmake-build-system)
+ (inputs (list libxml2))
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Lars Bilke wrote 2 months ago
[PATCH v2] gnu: Add xmlpatch.
(address . 75285@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
55742d1323b110da95fe38062068741eb485bbeb.1735887922.git.lars.bilke@ufz.de
* gnu/packages/xml.scm (xmlpatch): New variable.

Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5bbd1dd64e..a42a9e0e0d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2023,3 +2023,25 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))
+ (inputs (list libxml2))
+ (home-page "https://xmlpatch.sourceforge.net")
+ (synopsis "XML patch library")
+ (description
+ "A C++ library for patching XML files with XPath expressions.")
+ (license license:lgpl2.1)))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Ludovic Courtès wrote 1 months ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)(address . 75285@debbugs.gnu.org)
87ed0oo0w1.fsf@gnu.org
Hi Lars,

Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (4 lines)
> * gnu/packages/xml.scm (xmlpatch): New variable.
>
> Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e

I think we at least need the changes below.

Looking at ‘xml-patch.spec.in’, it seems that the RPM package also
installs the ‘xml-patch’ and ‘xml-diff’ programs, which are not
installed here.

Could you take a look?

Thanks,
Ludo’.
Toggle diff (21 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3ef045fc03..7cd1b4d4af 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2051,6 +2051,7 @@ (define-public xmlpatch
(uri (git-reference
(url "https://github.com/ufz/xmlpatch")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
(build-system cmake-build-system)
@@ -2060,5 +2061,6 @@ (define-public xmlpatch
(home-page "https://xmlpatch.sourceforge.net")
(synopsis "XML patch library")
(description
- "A C++ library for patching XML files with XPath expressions.")
- (license license:lgpl2.1)))
+ "XML Patch is a C++ library for patching XML files with XPath
+expressions.")
+ (license license:lgpl2.1+)))
Lars Bilke wrote 1 months ago
[PATCH v3] gnu: Add xmlpatch.
(name . Lars Bilke)(address . lars.bilke@ufz.de)
fd0536e7f5cb806b1b2c14519d522f62f0fcfd4b.1738054288.git.lars.bilke@ufz.de
* gnu/packages/xml.scm (xmlpatch): New variable.

Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ea36774d36..31488ea309 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2040,3 +2040,28 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (version "0.4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10kjg7lz9p4xnv96053mj18dmc7lj7iqzx98z3aagnw6hfwdri7f"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))
+ (native-inputs (list pkg-config))
+ (inputs (list libxml2 glib))
+ (home-page "https://xmlpatch.sourceforge.net")
+ (synopsis "XML patch library")
+ (description
+ "XML Patch is a C++ library for patching XML files with XPath
+expressions.")
+ (license license:lgpl2.1+)))

base-commit: 44d9f05fb3a8f20044873597762e6d8d6a895783
--
2.46.1
Lars Bilke wrote 1 months ago
Re: [bug#75285] [PATCH v2] gnu: Add xmlpatch.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 75285@debbugs.gnu.org)
7C438CBD-D0AE-4F19-9503-6FF449F3BBF0@ufz.de
Hi Ludovic,

thanks for your comments. I have addressed all issues in v3, also
packaging xml-patch and xml-diff binaries.

Sincerely,
Lars

On 27 Jan 2025, at 14:13, Ludovic Courtès wrote:

Toggle quote (19 lines)
> Hi Lars,
>
> Lars Bilke <lars.bilke@ufz.de> skribis:
>
>> * gnu/packages/xml.scm (xmlpatch): New variable.
>>
>> Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
>
> I think we at least need the changes below.
>
> Looking at ‘xml-patch.spec.in’, it seems that the RPM package also
> installs the ‘xml-patch’ and ‘xml-diff’ programs, which are
> not
> installed here.
>
> Could you take a look?
>
> Thanks,
> Ludo’.
Attachment: file
Ludovic Courtès wrote 1 months ago
Re: [bug#75285] [PATCH v3] gnu: Add xmlpatch.
(name . Lars Bilke)(address . lars.bilke@ufz.de)(address . 75285-done@debbugs.gnu.org)
8734h3fc5z.fsf@gnu.org
Hi,

Applied v3 with the changes below. Thanks!

Ludo’.
Toggle diff (14 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 31488ea309..10cd6d98fa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2062,6 +2062,7 @@ (define-public xmlpatch
(home-page "https://xmlpatch.sourceforge.net")
(synopsis "XML patch library")
(description
- "XML Patch is a C++ library for patching XML files with XPath
-expressions.")
+ "XML Patch is a C++ library and command-line interface
+(the @command{xml-diff} and @command{xml-patch} commands) for patching XML
+files with XPath expressions.")
(license license:lgpl2.1+)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75285@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75285
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help