[PATCH] gnu: Add xmlpatch.

  • Open
  • quality assurance status badge
Details
One participant
  • Lars Bilke
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal
L
L
Lars Bilke wrote on 2 Jan 15:33 +0100
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
9c21c0e1bb3818bed293f84f4b4c122fc47258e2.1735828404.git.lars.bilke@ufz.de
* gnu/packages/xml.scm (xmlpatch): New variable.

Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5bbd1dd64e..bc354e74f7 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2023,3 +2023,25 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (synopsis "XML patch library")
+ (license license:lgpl2.1)
+ (description
+ "A C++ library for patching XML files with XPath expressions.")
+ (home-page "https://xmlpatch.sourceforge.net")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
+ (build-system cmake-build-system)
+ (inputs (list libxml2))
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
L
L
Lars Bilke wrote on 3 Jan 08:05 +0100
[PATCH v2] gnu: Add xmlpatch.
(address . 75285@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
55742d1323b110da95fe38062068741eb485bbeb.1735887922.git.lars.bilke@ufz.de
* gnu/packages/xml.scm (xmlpatch): New variable.

Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e
---
gnu/packages/xml.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5bbd1dd64e..a42a9e0e0d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2023,3 +2023,25 @@ (define-public xml-namespace-xsd
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "120r0hm83nwvybjprmjaiilz5yj1qb46c9klawg61kqby6wsnaa8"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))
+ (inputs (list libxml2))
+ (home-page "https://xmlpatch.sourceforge.net")
+ (synopsis "XML patch library")
+ (description
+ "A C++ library for patching XML files with XPath expressions.")
+ (license license:lgpl2.1)))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75285@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75285
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch