Lars Bilke wrote 2 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
* gnu/packages/cpp.scm (tclap): New variable.
Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
---
gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..cc39fc8851 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,35 @@ (define-public cpp-ada-url-parser
"Ada is a fast and spec-compliant URL parser written in C++.
Specification for URL parser can be found from the WHATWG website.")
(license license:gpl3+)))
+
+(define-public tclap
+ (package
+ (name "tclap")
+ (synopsis "Templatized Command Line Argument Parser")
+ (license license:expat)
+ (description
+ "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+ (home-page "https://sourceforge.net/p/tclap/discussion/")
+ (version "1.4.0-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/tclap/code")
+ (commit "81b3d2a0c47895c22e9bb8c577f5ab521f76e5d2")))
+ (sha256
+ (base32 "0w06phgcjjnskxl9f0vmy5lgx5y2irbx14j9c2k8fis8a9sdiq51"))))
+ (build-system cmake-build-system)
+ (native-inputs (list python))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ (invoke "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))))
base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1