[PATCH] gnu: Add tclap.

  • Done
  • quality assurance status badge
Details
3 participants
  • Lars Bilke
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 2 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
45e8fac7f0877360439107b5aab2df723865d14b.1735822628.git.lars.bilke@ufz.de
* gnu/packages/cpp.scm (tclap): New variable.

Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
---
gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..cc39fc8851 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,35 @@ (define-public cpp-ada-url-parser
"Ada is a fast and spec-compliant URL parser written in C++.
Specification for URL parser can be found from the WHATWG website.")
(license license:gpl3+)))
+
+(define-public tclap
+ (package
+ (name "tclap")
+ (synopsis "Templatized Command Line Argument Parser")
+ (license license:expat)
+ (description
+ "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+ (home-page "https://sourceforge.net/p/tclap/discussion/")
+ (version "1.4.0-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/tclap/code")
+ (commit "81b3d2a0c47895c22e9bb8c577f5ab521f76e5d2")))
+ (sha256
+ (base32 "0w06phgcjjnskxl9f0vmy5lgx5y2irbx14j9c2k8fis8a9sdiq51"))))
+ (build-system cmake-build-system)
+ (native-inputs (list python))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ (invoke "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Liliana Marie Prikler wrote 2 months ago
04020bef635b0a7b2e2afa3b321c06b18d3079fb.camel@gmail.com
Am Donnerstag, dem 02.01.2025 um 13:57 +0100 schrieb Lars Bilke:
Toggle quote (26 lines)
> * gnu/packages/cpp.scm (tclap): New variable.
>
> Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
> ---
>  gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index d3a8223a9c..cc39fc8851 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -3531,3 +3531,35 @@ (define-public cpp-ada-url-parser
>       "Ada is a fast and spec-compliant URL parser written in C++.
>  Specification for URL parser can be found from the WHATWG website.")
>      (license license:gpl3+)))
> +
> +(define-public tclap
> +  (package
> +    (name "tclap")
> +    (synopsis "Templatized Command Line Argument Parser")
> +    (license license:expat)
> +    (description
> +     "This is a simple C++ library that facilitates parsing command
> line
> +arguments in a type independent manner.")
> +    (home-page "https://sourceforge.net/p/tclap/discussion/")
The preferred order is name, version, source, build-system, arguments,
inputs (any order), home-page, synopsis, description, license :)
Toggle quote (30 lines)
> +    (version "1.4.0-1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.code.sf.net/p/tclap/code")
> +             (commit "81b3d2a0c47895c22e9bb8c577f5ab521f76e5d2")))
> +       (sha256
> +        (base32
> "0w06phgcjjnskxl9f0vmy5lgx5y2irbx14j9c2k8fis8a9sdiq51"))))
> +    (build-system cmake-build-system)
> +    (native-inputs (list python))
> +    (arguments
> +     (list
> +      #:phases #~(modify-phases %standard-phases
> +                   (replace 'check
> +                     (lambda* (#:key tests? parallel-tests? #:allow-
> other-keys)
> +                       (if tests?
> +                           (invoke "ctest" "-j"
> +                                   (if parallel-tests?
> +                                       (number->string (parallel-
> job-count))
> +                                       "1"))
> +                           (format #t "test suite not
> run~%")))))))))
>
> base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
> --
> Cheers
Lars Bilke wrote 2 months ago
[PATCH v2] gnu: Add tetgen.
(address . 75282@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
ef5d091bd627535359ba8951c074b11c282b05bd.1735887637.git.lars.bilke@ufz.de
* gnu/packages/geo.scm (tetgen): New variable.

Change-Id: Iba2de71cf0a10ca5c7b65f9851d05fe63c944b30
---
gnu/packages/geo.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8b9b9a4cf7..17e495de41 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3614,3 +3614,29 @@ (define-public laszip
@code{LAZ} files. The @code{LAS} format is a file format designed for the
interchange and archiving of lidar point cloud data.")
(license license:asl2.0)))
+
+ (define-public tetgen
+ (package
+ (name "tetgen")
+ (version "1.5.1-2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/tetgen")
+ (commit version)))
+ (sha256
+ (base32 "0hd8mvmzybvlgvfx131p8782v8hggmg53vlkgazpsw9d6ympfcrv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags (list "-DCMAKE_POSITION_INDEPENDENT_CODE=ON")))
+ (home-page "https://wias-berlin.de/software/tetgen/")
+ (synopsis
+ "Quality Tetrahedral Mesh Generator and 3D Delaunay Triangulator")
+ (description
+ "TetGen is a program to generate tetrahedral meshes of any 3D
+polyhedral domains. TetGen generates exact constrained Delaunay
+tetrahedralizations, boundary conforming Delaunay meshes, and Voronoi
+partitions.")
+ (license license:agpl3)))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Lars Bilke wrote 2 months ago
[PATCH v2] gnu: Add tclap.
(address . 75282@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
1de3992822240e39d29eafa42700f67941ac7535.1735888688.git.lars.bilke@ufz.de
* gnu/packages/cpp.scm (tclap): New variable.

Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
---
gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..c9afb60c16 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,35 @@ (define-public cpp-ada-url-parser
"Ada is a fast and spec-compliant URL parser written in C++.
Specification for URL parser can be found from the WHATWG website.")
(license license:gpl3+)))
+
+(define-public tclap
+ (package
+ (name "tclap")
+ (version "1.4.0-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/tclap/code")
+ (commit "81b3d2a0c47895c22e9bb8c577f5ab521f76e5d2")))
+ (sha256
+ (base32 "0w06phgcjjnskxl9f0vmy5lgx5y2irbx14j9c2k8fis8a9sdiq51"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ (invoke "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list python))
+ (home-page "https://sourceforge.net/p/tclap/discussion/")
+ (synopsis "Templatized Command Line Argument Parser")
+ (description
+ "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+ (license license:expat)))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Liliana Marie Prikler wrote 2 months ago
00eb0ba7c5b241e6cd65079112d889d5523f00a3.camel@gmail.com
Am Freitag, dem 03.01.2025 um 08:18 +0100 schrieb Lars Bilke:
Toggle quote (4 lines)
> * gnu/packages/cpp.scm (tclap): New variable.
>
> Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
> ---
Note: when revising patches, don't forget to CC your reviewer :)

Toggle quote (22 lines)
>  gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index d3a8223a9c..c9afb60c16 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -3531,3 +3531,35 @@ (define-public cpp-ada-url-parser
>       "Ada is a fast and spec-compliant URL parser written in C++.
>  Specification for URL parser can be found from the WHATWG website.")
>      (license license:gpl3+)))
> +
> +(define-public tclap
> +  (package
> +    (name "tclap")
> +    (version "1.4.0-1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.code.sf.net/p/tclap/code")
> +             (commit "81b3d2a0c47895c22e9bb8c577f5ab521f76e5d2")))
We have a mirror://sourceforge syntax for url-fetch. I assume you want
to package 1.4.0-rc1?
Toggle quote (17 lines)
> +       (sha256
> +        (base32
> "0w06phgcjjnskxl9f0vmy5lgx5y2irbx14j9c2k8fis8a9sdiq51"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     (list
> +      #:phases #~(modify-phases %standard-phases
> +                   (replace 'check
> +                     (lambda* (#:key tests? parallel-tests? #:allow-
> other-keys)
> +                       (if tests?
> +                           (invoke "ctest" "-j"
> +                                   (if parallel-tests?
> +                                       (number->string (parallel-
> job-count))
> +                                       "1"))
> +                           (format #t "test suite not run~%")))))))
Shouldn't cmake default to using ctest for testing?
Toggle quote (8 lines)
> +    (native-inputs (list python))
> +    (home-page "https://sourceforge.net/p/tclap/discussion/")
> +    (synopsis "Templatized Command Line Argument Parser")
> +    (description
> +     "This is a simple C++ library that facilitates parsing command
> line
> +arguments in a type independent manner.")
> +    (license license:expat)))
Cheers
Lars Bilke wrote 2 months ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 75282@debbugs.gnu.org)
567B024C-E505-47DE-992B-5FD583726E03@ufz.de
Thanks for your review! Patch v3 is following..

On 13 Jan 2025, at 18:40, Liliana Marie Prikler wrote:

Toggle quote (4 lines)
> We have a mirror://sourceforge syntax for url-fetch. I assume you
> want
> to package 1.4.0-rc1?

I have changed to your proposed mirror-syntax and adapted to us
1.4.0-rc1.

Toggle quote (2 lines)
> Shouldn't cmake default to using ctest for testing?

No, it defaults to building the `test`-target. In the tclap-case there
is no such target defined.

Sincerely,
Lars
Attachment: file
Lars Bilke wrote 2 months ago
[PATCH v3] gnu: Add tclap.
(name . Lars Bilke)(address . lars.bilke@ufz.de)
0c8d12516607d9ddfdd955632cfc619ab66751c0.1736849096.git.lars.bilke@ufz.de
* gnu/packages/cpp.scm (tclap): New variable.

Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00
---
gnu/packages/cpp.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..3146cfea64 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,34 @@ (define-public cpp-ada-url-parser
"Ada is a fast and spec-compliant URL parser written in C++.
Specification for URL parser can be found from the WHATWG website.")
(license license:gpl3+)))
+
+(define-public tclap
+ (package
+ (name "tclap")
+ (version "1.4.0-rc1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "-" version
+ ".tar.bz2"))
+ (sha256
+ (base32 "1ii0gs965xagqfdwln9hd61y68352msybbq059grwspp51w8rq9k"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ (invoke "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list python))
+ (home-page "https://sourceforge.net/p/tclap/discussion/")
+ (synopsis "Templatized Command Line Argument Parser")
+ (description
+ "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+ (license license:expat)))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
Ludovic Courtès wrote 2 months ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)
8734hfu87s.fsf@gnu.org
Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (4 lines)
> * gnu/packages/cpp.scm (tclap): New variable.
>
> Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00

Applied, thanks!

Note that normally we don’t package release candidates (RC) so please be
sure to upgrade this one as soon as the new version is out.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75282@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75282
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help