[PATCH] gnu: Add font-spline-sans.

  • Open
  • quality assurance status badge
Details
One participant
  • Divya Ranjan
Owner
unassigned
Submitted by
Divya Ranjan
Severity
normal
D
D
Divya Ranjan wrote on 1 Jan 19:51 +0100
(address . guix-patches@gnu.org)(name . Divya Ranjan)(address . divya@subvertising.org)
20250101185109.4928-1-divya@subvertising.org
* gnu/packages/fonts.scm (font-spline-sans): New variable.
---
gnu/packages/fonts.scm | 42 ++++++++++++++++++++++++++++++++++--------
1 file changed, 34 insertions(+), 8 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 69d7d039aa..3c60f5e4a1 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -299,13 +299,13 @@ (define-public font-bitstream-vera
(name "font-bitstream-vera")
(version "1.10")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
- version "/ttf-bitstream-vera-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
+ version "/ttf-bitstream-vera-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
(build-system font-build-system)
(home-page "https://www.gnome.org/fonts/")
(synopsis "Bitstream Vera sans-serif typeface")
@@ -3648,6 +3648,32 @@ (define-public font-spleen
Spleen also has support for Powerline symbols out of the box.")
(license license:bsd-2)))
+(define-public font-spline-sans
+ (let ((commit "5196436e0714c188c70f30a93b4759e8ed8afb69")
+ (revision "0"))
+ (package
+ (name "font-spline-sans")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SorkinType/SplineSans")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hs0215fhas9vc6pn1vjizv746lifwwdwjf04lclyz93raqza1id"))))
+ (build-system font-build-system)
+ (home-page "https://fonts.google.com/specimen/Spline+Sans")
+ (synopsis
+ "Grotesque sans serif typeface family, purpose-built for UI interfaces")
+ (description
+ "Spline Sans is a Grotesque purpose-built for UI interfaces, checkout processes,
+and paragraphs of text. Space efficiency is accomplished by condensing traditional
+grotesque proportions. The cool and restrained tone is accented with strategic \"thorn\"
+traps, which blossom into view when set at larger sizes.")
+ (license license:silofl1.1))))
+
(define-public font-scientifica
(package
(name "font-scientifica")
@@ -3661,7 +3687,7 @@ (define-public font-scientifica
(base32
"0zwa3s75lvbky2vn73i1fmxa37hi3zfm7f6wfpqwcip8l1lpi1gh"))))
(build-system font-build-system)
- (outputs '("out" ;OTB
+ (outputs '("out" ;OTB
"bdf" "ttf"))
(home-page "https://github.com/nerdypepper/scientifica")
(synopsis "Tall and condensed bitmap font for geeks")
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75247@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75247
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch