Packaging ghostty terminal

  • Open
  • quality assurance status badge
Details
3 participants
  • boogs
  • Tobias Geerinckx-Rice
  • Murilo
Owner
unassigned
Submitted by
boogs
Severity
normal
Merged with
B
B
boogs wrote 7 days ago
(address . bug-guix@gnu.org)
8734i3nsea.fsf@venatores.group
Hi,
I'm looking to package the ghostty terminal (https://ghostty.org/docs/install/build)but I ran into an issue with the zig build system pertaining to the dependencies?

I've attached the package definition including the error output below. I would appreciate some pointers here please.
(define-module (boogs packages) #:use-module (guix build-system zig) #:use-module (guix download) #:use-module (guix git-download) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (gnu packages glib) #:use-module (gnu packages zig-xyz) #:use-module (gnu packages gnome) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages zig) #:use-module (srfi srfi-1)) (define-public ghostty (let* ((version "1.0.0") (commit (string-append "v" version))) (package (name "ghostty") (version version) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/ghostty-org/ghostty.git") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "0cs1n7qddy2487hbw72v0h23ybdmp25cag00q46pk0czi5kkawh0")))) (build-system zig-build-system) (arguments (list #:zig zig-0.13 #:install-source? #f)) (native-inputs (list gtk libadwaita pkg-config zig)) (home-page "https://www.ghossty.org/") (synopsis "Fast, feature-rich, and cross-platform terminal emulator that uses platform-native UI and GPU acceleration.") (description "Ghostty is a terminal emulator that differentiates itself by being fast, feature-rich, and native. While there are many excellent terminal emulators available, they all force you to choose between speed, features, or native UIs. Ghostty provides all three.") (license expat)))) ghostty
--
boogs
T
T
Tobias Geerinckx-Rice wrote 6 days ago
(address . control@debbugs.gnu.org)
BB095A0B-3CF7-4F27-9803-F4B4996B9B2E@tobias.gr
merge 75236 75237
M
M
Murilo wrote 6 days ago
D6QS5AANIVYZ.3E3F2IKG2OJ1B@disroot.org
Hi, sadly its not an easy task as you might be expecting it to be.

It vendors a lot of dependencies in the repository and recursive dependency
replacing with zig fetch isn't quite there yet so we have to do some more work,
create a cache and vendor it with --system. I don't know if this is the best
approach since I never touched anything zig, but it seems to be the easiest from
my research.

Fortunately I've already went through the trouble and packaged it on my channel
a couple days ago so you can use it right away :)

Feel free to take a look at my package definition [0] or use my channel [1]. I
plan to upstream it here once holidays are over and I have some free time, whats
left to do is looking at the vendored sources one by one to ensure everything is
free and there are no nasty pre-built stuff inside the sources, and see if any
of it can be made into a proper guix package so we can use it as normal inputs.
Feel free to help with those too if you want to, the more help the merrier :)

B
B
boogs wrote 6 days ago
(name . Murilo)(address . murilo@disroot.org)(address . 75237@debbugs.gnu.org)
c7f38038-35f1-4837-b9ee-5ea36591ebd6@email.android.com
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75237@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75237
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch