(address . bug-guix@gnu.org)
Hi,
I'm looking to package the ghostty terminal (https://ghostty.org/docs/install/build)but I ran into an issue with the zig build system pertaining to the dependencies?
I've attached the package definition including the error output below. I would appreciate some pointers here please.
(define-module (boogs packages)
#:use-module (guix build-system zig)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (gnu packages glib)
#:use-module (gnu packages zig-xyz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages zig)
#:use-module (srfi srfi-1))
(define-public ghostty
(let* ((version "1.0.0")
(commit (string-append "v" version)))
(package
(name "ghostty")
(version version)
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ghostty-org/ghostty.git")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
"0cs1n7qddy2487hbw72v0h23ybdmp25cag00q46pk0czi5kkawh0"))))
(build-system zig-build-system)
(arguments
(list #:zig zig-0.13
#:install-source? #f))
(native-inputs
(list gtk
libadwaita
pkg-config
zig))
(home-page "https://www.ghossty.org/")
(synopsis "Fast, feature-rich, and cross-platform terminal
emulator that uses platform-native UI and GPU acceleration.")
(description
"Ghostty is a terminal emulator that differentiates itself by
being fast, feature-rich, and native. While there are many excellent
terminal emulators available, they all force you to choose between
speed, features, or native UIs. Ghostty provides all three.")
(license expat))))
ghostty
--
boogs