[PATCH] gnu: cantata: Update to 3.3.0, change repo

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Andrew Wong
Owner
unassigned
Submitted by
Andrew Wong
Severity
normal

Debbugs page

Andrew Wong wrote 2 months ago
(address . guix-patches@gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
20241231110946.31480-1-wongandj@icloud.com
Change-Id: Ie789d0f046716ac8e2631bb6d24fb9fe7119b280
---
gnu/packages/mpd.scm | 20 +++++++++++---------
1 file changed, 11 insertions(+), 9 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index fb679065de..d5325bce5c 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -504,15 +504,15 @@ (define-public mpdris2
(define-public cantata
(package
(name "cantata")
- (version "2.5.0")
+ (version "3.3.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/CDrummond/"
- "cantata/releases/download/v" version "/"
- "cantata-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nullobsi/cantata")
+ (commit (string-append "v" version))))
(sha256
(base32
- "090ph8kb2vicjaajn64kmfppb90ix0pnxj525shglyjn7ymh0zpb"))))
+ "09nskgw9c6jhr647yv9irzjb2zibv1w8bwbpfgz0viibqn81f7bp"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No test suite
@@ -520,16 +520,18 @@ (define-public cantata
(list pkg-config))
(inputs
(list avahi
+ ;; cdparanoia ;replaced by libcdio-paranoia
eudev
ffmpeg
+ libcddb
libcdio-paranoia
libmusicbrainz
libebur128
libmtp
mpg123
- qtbase-5
- qtmultimedia-5
- qtsvg-5
+ qtbase
+ qtmultimedia
+ qtsvg
taglib
zlib))
(synopsis "Graphical MPD Client")
--
2.47.1
Andrew Wong wrote 2 months ago
[PATCH v2] gnu: cantata: Update to 3.3.0.
(address . 75223@debbugs.gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
ebe02586f4e2e4fe8810e354b1618a26c4681787.1736068147.git.wongandj@icloud.com
* gnu/packages/mpd.scm (cantata): Update to 3.3.0.
[origin]: Change upstream repository.
[native-inputs]: Add libcddb. Update Qt libraries to Qt6.
[description]: Update description. This is a Qt6 app now.
[home-page]: Change upstream repository.

Change-Id: I85589f010154270c4a9a6e89f9376769c7efe170
---
Fixed several errors in the previous patch version.
gnu/packages/mpd.scm | 63 ++++++++++++++++++++++----------------------
1 file changed, 32 insertions(+), 31 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index fb679065de..7e9bf730e6 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -504,41 +504,42 @@ (define-public mpdris2
(define-public cantata
(package
(name "cantata")
- (version "2.5.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/CDrummond/"
- "cantata/releases/download/v" version "/"
- "cantata-" version ".tar.bz2"))
- (sha256
- (base32
- "090ph8kb2vicjaajn64kmfppb90ix0pnxj525shglyjn7ymh0zpb"))))
+ (version "3.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nullobsi/cantata")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09nskgw9c6jhr647yv9irzjb2zibv1w8bwbpfgz0viibqn81f7bp"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f)) ; No test suite
- (native-inputs
- (list pkg-config))
- (inputs
- (list avahi
- eudev
- ffmpeg
- libcdio-paranoia
- libmusicbrainz
- libebur128
- libmtp
- mpg123
- qtbase-5
- qtmultimedia-5
- qtsvg-5
- taglib
- zlib))
+ `(#:tests? #f)) ;No test suite
+ (native-inputs (list pkg-config))
+ (inputs (list avahi
+ eudev
+ ffmpeg
+ libcddb
+ libcdio-paranoia
+ libmusicbrainz
+ libebur128
+ libmtp
+ mpg123
+ qtbase
+ qtmultimedia
+ qtsvg
+ taglib
+ zlib))
(synopsis "Graphical MPD Client")
- (description "Cantata is a graphical client for the Music Player Daemon
-(MPD), using the Qt5 toolkit. Its user interface is highly customizable,
-supporting multiple collections, ratings, and dynamic playlists. A local cache
-of the music library will be created to provide a hierarchy of albums and
+ (description
+ "Cantata is a graphical client for the Music Player Daemon (MPD). Its
+user interface is highly customizable, supporting multiple
+collections, ratings, and dynamic playlists. A local cache of the
+music library will be created to provide a hierarchy of albums and
artists along with albumart.")
- (home-page "https://github.com/cdrummond/cantata")
+ (home-page "https://github.com/nullobsi/cantata")
(license license:gpl3+)))
(define-public mcg

base-commit: e383e8e34097b064d4baa4207673c6ba30617347
--
2.47.1
Andrew Wong wrote 2 months ago
[PATCH v2] gnu: cantata: Update to 3.3.0.(bump)
(address . 75223@debbugs.gnu.org)
3369d0e3-6a7d-4f55-ba7b-a6a7e941d0b8@icloud.com
Bumping this in case it was missed. Is there anything more that should
be done for a change like this?
宋文武 wrote 4 weeks ago
Re: [bug#75223] [PATCH v2] gnu: cantata: Update to 3.3.0.
(name . Andrew Wong)(address . wongandj@icloud.com)(address . 75223-done@debbugs.gnu.org)
87cyfj9zzo.fsf@envs.net
Andrew Wong <wongandj@icloud.com> writes:

Toggle quote (6 lines)
> * gnu/packages/mpd.scm (cantata): Update to 3.3.0.
> [origin]: Change upstream repository.
> [native-inputs]: Add libcddb. Update Qt libraries to Qt6.
> [description]: Update description. This is a Qt6 app now.
> [home-page]: Change upstream repository.

Applied, keep the original format and with slightly adjust commit message,
thank you!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75223@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75223
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help