[PATCH rust-team 1/7] gnu: Add rust-alloc-counter-macro-0.0.2.

  • Open
  • quality assurance status badge
Details
One participant
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 30 Dec 2024 20:39
(address . guix-patches@gnu.org)
6375e73e5e07bfb5322601a5d61dd851979201c4.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-alloc-counter-macro-0.0.2): Add
variable.

Change-Id: I4459b8ed29afb4a0091eb7fce07e45f663cb7642
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0b38709201d..112276fe191 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1258,6 +1258,29 @@ (define-public rust-aligned-vec-0.5
(description "This package provides an aligned vector and box containers.")
(license license:expat)))
+(define-public rust-alloc-counter-macro-0.0.2
+ (package
+ (name "rust-alloc-counter-macro")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "alloc_counter_macro" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0nifqalryavmrdlkyv7cznp8yfjj16x0bjqzvjndw0fxk8gzhlhs"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://gitlab.com/sio4/code/alloc-counter")
+ (synopsis "#[no_alloc] macro for alloc_counter")
+ (description
+ "This package provides the #[no_alloc] macro for the alloc_counter
+crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-alloc-no-stdlib-2
(package
(name "rust-alloc-no-stdlib")

base-commit: 4d478f0b404a86a0849722536f11fde0b1857bb8
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 2/7] gnu: Add rust-alloc-counter-0.0.4.
(address . 75212@debbugs.gnu.org)
36f8bd6f76ca60957b3f574543c22e6caca27f4c.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-alloc-counter-0.0.4): Add variable.

Change-Id: I4459b8ed29afb4a0091eb7fce07e45f663cb7642
---
gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 112276fe191..6ee05ca09a6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1258,6 +1258,33 @@ (define-public rust-aligned-vec-0.5
(description "This package provides an aligned vector and box containers.")
(license license:expat)))
+(define-public rust-alloc-counter-0.0.4
+ (package
+ (name "rust-alloc-counter")
+ (version "0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "alloc_counter" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1agxzprqi37bcy9hh3clbsl3n0awbb34vrlv4rp5afib8w53m31s"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags '("--" "--skip=count_3" "--skip=count_alloc")
+ #:cargo-inputs
+ (("rust-alloc-counter-macro" ,rust-alloc-counter-macro-0.0.2)
+ ("rust-pin-utils" ,rust-pin-utils-0.1))
+ #:cargo-development-inputs
+ (("rust-futures-executor" ,rust-futures-executor-0.3))))
+ (home-page "https://gitlab.com/sio4/code/alloc-counter")
+ (synopsis "Count allocations, reallocations, deallocations")
+ (description
+ "This package provides a counter for allocations, reallocations,
+deallocations. It can also allow, deny, or forbid allocations on an
+expression or function basis.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-alloc-counter-macro-0.0.2
(package
(name "rust-alloc-counter-macro")
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 3/7] gnu: Add rust-libc-0.1.
(address . 75212@debbugs.gnu.org)
4f7f0fb8e8ba323c2732368da32f02f1d4f58526.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-libc-0.1): Add variable.

Change-Id: Ifc4effb272f200deb61a04e583db7850ef585dd1
---
gnu/packages/crates-io.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6ee05ca09a6..88a3f9fde2f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40250,6 +40250,25 @@ (define-public rust-libc-0.2
(license (list license:expat
license:asl2.0))))
+(define-public rust-libc-0.1
+ (package
+ (inherit rust-libc-0.2)
+ (name "rust-libc")
+ (version "0.1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "libc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08k14zb7bw25avmaj227calcdglb4ac394kklr9nv175fp7p0ap3"))
+ (modules '((guix build utils)))
+ (snippet #~(;with-output-to-file "README.md" (const "")
+ substitute* "Cargo.toml"
+ (("readme =.*") "edition = \"2015\"\n")))))
+ ;; There is a windows test, and one that needs patching.
+ (arguments '(#:tests? #f))))
+
(define-public rust-libc-print-0.1
(package
(name "rust-libc-print")
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 4/7] gnu: Add rust-mmap-0.1.
(address . 75212@debbugs.gnu.org)
e974e986b6e30ab106ee12e51bc60f35c5866ad1.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-mmap-0.1): Add variable.

Change-Id: I7bad2fb45b87d64295061c1154a9823f6b88bbc7
---
gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 88a3f9fde2f..2ccdd24ea4e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45517,6 +45517,27 @@ (define-public rust-mktemp-0.4
(description "This package provides mktemp files and directories.")
(license license:mpl2.0)))
+(define-public rust-mmap-0.1
+ (package
+ (name "rust-mmap")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mmap" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08xqhvr4l3rf1fkz2w4cwz3z5wd0m1jab1d34sxd4v80lr459j0b"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.1)
+ ("rust-tempdir" ,rust-tempdir-0.3))))
+ (home-page "https://github.com/rbranson/rust-mmap")
+ (synopsis "library for dealing with memory-mapped I/O")
+ (description
+ "This package provides a library for dealing with memory-mapped I/O.")
+ (license license:expat)))
+
(define-public rust-mmap-fixed-0.1
(package
(name "rust-mmap-fixed")
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 6/7] gnu: Add rust-perfcnt-0.8.
(address . 75212@debbugs.gnu.org)
b936b531af21527ea2fabe1baa370bfaefd8d401.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-perfcnt-0.8): Add variable.

Change-Id: I1e80dde3b8ca0ce5c938fb48d65ea0a397e8a9ff
---
gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e7dc54340fe..093243279b2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55429,6 +55429,32 @@ (define-public rust-peresil-0.3
"This package provides a simple and simplistic string parsing library.")
(license license:expat)))
+(define-public rust-perfcnt-0.8
+ (package
+ (name "rust-perfcnt")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "perfcnt" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "008mrdd8zjk54qg8xh8crk9is98sxv2c0kk2v25nzjkhaaazv8ab"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-mmap" ,rust-mmap-0.1)
+ ("rust-nom" ,rust-nom-4)
+ ("rust-x86" ,rust-x86-0.47))))
+ (home-page "https://github.com/gz/rust-perfcnt")
+ (synopsis "Configure and read hardware performance counters")
+ (description
+ "This package provides a library to configure and read hardware
+performance counters in rust.")
+ (license license:expat)))
+
(define-public rust-perf-event-0.4
(package
(name "rust-perf-event")
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 5/7] gnu: Add rust-x86-0.47.
(address . 75212@debbugs.gnu.org)
3eb9219f5c655aaae470926691aff4056b4d9b96.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-x86-0.47): Add variable.

Change-Id: I2ad82d4504d14757050537da7c742feb8f673e62
---
gnu/packages/crates-io.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2ccdd24ea4e..e7dc54340fe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -96042,6 +96042,20 @@ (define-public rust-x86-0.52
languages.")
(license license:expat)))
+(define-public rust-x86-0.47
+ (package
+ ;; This uses klogger 0.0.9 instead of 0.0.14.
+ (inherit rust-x86-0.52)
+ (name "rust-x86")
+ (version "0.47.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "x86" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1jlddyczw168mcy4a6m3nbl203rxli2vr5gcmf57s0adqf6bxdam"))))))
+
(define-public rust-x86-0.33
(package
(inherit rust-x86-0.52)
--
2.45.2
H
H
Herman Rimm wrote on 30 Dec 2024 20:47
[PATCH rust-team 7/7] gnu: rust-simd-json-0.13: Remove snippet.
(address . 75212@debbugs.gnu.org)
06ced2940325c112ec65a06bc86f2e6fb882157f.1735587580.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-simd-json-0.13): Remove snippet.
[arguments]: Uncomment optional dependencies.

Change-Id: I5c776a89df8383463a9f57dcb22c7f706ed0e256
---
gnu/packages/crates-io.scm | 19 +++++--------------
1 file changed, 5 insertions(+), 14 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 093243279b2..5b09e98cd61 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -75457,29 +75457,20 @@ (define-public rust-simd-json-0.13
(uri (crate-uri "simd-json" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0xmzpzklnxxnwspf7abhzgr3khbnrw4h8svag8rq9i4v3c88zbrg"))
- (snippet
- #~(begin (use-modules (guix build utils))
- ;; Remove some of the optional dependencies:
- (substitute* "Cargo.toml.orig"
- ((".*alloc_counter.*") "")
- ((".*colored.*") "")
- ((".*jemallocator.*") "")
- ((".*perfcnt.*") ""))
- (rename-file "Cargo.toml.orig" "Cargo.toml")))))
+ (base32 "0xmzpzklnxxnwspf7abhzgr3khbnrw4h8svag8rq9i4v3c88zbrg"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-ahash" ,rust-ahash-0.8)
- ;("rust-alloc-counter" ,rust-alloc-counter-0.0.4)
+ ("rust-alloc-counter" ,rust-alloc-counter-0.0.4)
("rust-beef" ,rust-beef-0.5)
- ;("rust-colored" ,rust-colored-2)
+ ("rust-colored" ,rust-colored-2)
("rust-getopts" ,rust-getopts-0.2)
("rust-getrandom" ,rust-getrandom-0.2)
("rust-halfbrown" ,rust-halfbrown-0.2)
- ;("rust-jemallocator" ,rust-jemallocator-0.5)
+ ("rust-jemallocator" ,rust-jemallocator-0.5)
("rust-lexical-core" ,rust-lexical-core-0.8)
("rust-once-cell" ,rust-once-cell-1)
- ;("rust-perfcnt" ,rust-perfcnt-0.8)
+ ("rust-perfcnt" ,rust-perfcnt-0.8)
("rust-ref-cast" ,rust-ref-cast-1)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75212@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75212
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch