[PATCH] gnu: Allow Plasma 6 to access bluetooth devices in "System Settings"

  • Open
  • quality assurance status badge
Details
One participant
  • Karl Hallsby
Owner
unassigned
Submitted by
Karl Hallsby
Severity
normal
K
K
Karl Hallsby wrote 5 days ago
(address . guix-patches@gnu.org)(name . Raven Hallsby)(address . karl@hallsby.com)
63319d819602dbf11d467649ca8fa9be432dd915.1735423702.git.karl@hallsby.com
From: Raven Hallsby <karl@hallsby.com>

* gnu/packages/kde-plasma.scm (bluedevil): Propagate bluez-qt.
* gnu/packages/kde-plasma.scm (plasma): Add bluedevil as input.
* gnu/services/desktop.scm (plasma-dbus-service): Add bluedevil as dbus-based
application.

This adds the Bluetooth section back to KDE Plasma 6's System Settings menu.

Change-Id: If6a740c88e81bac4ccc220e918c17045eaa8e597
---
gnu/packages/kde-plasma.scm | 6 +++++-
gnu/services/desktop.scm | 2 ++
2 files changed, 7 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 817126f3e1..241d953e9a 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020, 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2024 Raven Hallsby <karl@hallsby.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -123,9 +124,11 @@ (define-public bluedevil
ki18n
kio
kdeclarative
- bluez-qt
shared-mime-info
qtdeclarative))
+ (propagated-inputs
+ (list
+ bluez-qt))
(synopsis "Manage the Bluetooth settings from Plasma")
(description
"This package provides Bluetooth manager for Plasma Shell.")
@@ -1755,6 +1758,7 @@ (define-public plasma
plasma-nm
plasma-pa
plasma-systemmonitor
+ bluedevil
;; plasma-thunderbolt ;; waiting for bolt
kglobalaccel
kglobalacceld
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index 4f679485bc..d99082e3f9 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021, 2022 muradm <mail@muradm.net>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Raven Hallsby <karl@hallsby.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1807,6 +1808,7 @@ (define (plasma-dbus-service config)
"libksysguard"
"ktexteditor"
"powerdevil"
+ "bluedevil"
"kwallet"
"plasma-firewall"))))

base-commit: 5b8c19c2089c18a98eed87a10a303d24ea9666db
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75169@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75169
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch