[PATCH] gnu: acpilight: install udev rules correctly

  • Open
  • quality assurance status badge
Details
One participant
  • 45mg
Owner
unassigned
Submitted by
45mg
Severity
normal
4
(address . guix-patches@gnu.org)(name . 45mg)(address . 45mg.writes@gmail.com)
c35070409228adac64bd135f174d04ed496c5c37.1735413858.git.45mg.writes@gmail.com
udev rules need to go into the lib/udev/rules.d/ output directory for
`udev-rules-service` to pick them up.

* gnu/packages/linux.scm (acpilight): sysconfdir=/lib.

Change-Id: I9fa2ce3ccebd87303efc3fa58b7233d8b8905a97
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78d3d737b5..81757613ca 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7987,7 +7987,7 @@ (define-public acpilight
(list #:tests? #f ; no tests
#:make-flags
#~(list (string-append "prefix=" #$output)
- (string-append "sysconfdir=" #$output "/etc"))
+ (string-append "sysconfdir=" #$output "/lib")) ;udev rule
#:phases
#~(modify-phases %standard-phases
(delete 'configure)

base-commit: 5b8c19c2089c18a98eed87a10a303d24ea9666db
--
2.47.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75165@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75165
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch