[PATCH 0/3] Update labwc to 0.8.2 and some related changes

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Zheng Junjie
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 months ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1735365259.git.a.r.draidi@redscript.org
Hello Guix,

Labwc 0.8.2 mandates wlroots 0.18.1, so we update to latest. We also add
libsfdo, which is a new dependency.

Ahmad Draidi (3):
gnu: wlroots: Update to 0.18.2.
gnu: Add libsfdo.
gnu: labwc: Update to 0.8.2.

gnu/packages/freedesktop.scm | 20 ++++++++++++++++++++
gnu/packages/wm.scm | 12 +++++++-----
2 files changed, 27 insertions(+), 5 deletions(-)


base-commit: 3a8c20408f0078a580d27f74bc69b5a1069a003b
--
2.47.1
Ahmad Draidi wrote 2 months ago
[PATCH 1/3] gnu: wlroots: Update to 0.18.2.
(address . 75155@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
4efeebbe68116e7fc1b72b189de30a0c52dd9e20.1735365259.git.a.r.draidi@redscript.org
* gnu/packages/wm.scm (wlroots): Update to 0.18.2.

Change-Id: I3383c6be410e3a18b0a4ac18abd9e9d8210520f2
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 580b33f4be..8da82e6411 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1858,7 +1858,7 @@ (define-public polybar
(define-public wlroots
(package
(name "wlroots")
- (version "0.18.0")
+ (version "0.18.2")
(source
(origin
(method git-fetch)
@@ -1867,7 +1867,7 @@ (define-public wlroots
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))))
+ (base32 "1l1c4m8m1h8rl00y9yi6qjma5m3lhai9hqv5578q69yg2dcwraxw"))))
(build-system meson-build-system)
(arguments
`(#:phases
--
2.47.1
Ahmad Draidi wrote 2 months ago
[PATCH 2/3] gnu: Add libsfdo.
(address . 75155@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
5050cce66928cc2b758e636a8923189f05668500.1735365259.git.a.r.draidi@redscript.org
* gnu/packages/freedesktop.scm (libsfdo): New variable.

Change-Id: I458dc579294326cf9e867b8d9e8f307212ae358e
---
gnu/packages/freedesktop.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 721a0d4c38..1ee9f3cc6d 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -361,6 +361,26 @@ (define-public libglib-testing
(home-page "https://gitlab.gnome.org/pwithnall/libglib-testing")
(license license:lgpl2.1+)))
+(define-public libsfdo
+ (package
+ (name "libsfdo")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/vyivel/libsfdo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fi9hlg9ms8sszb0ylx4v0q49265vbsix455x64nkvklh049yc7n"))))
+ (build-system meson-build-system)
+ (home-page "https://gitlab.freedesktop.org/vyivel/libsfdo")
+ (synopsis "Implementation of some of the freedesktop.org specifications")
+ (description "libsfdo is a collection of libraries which implement
+some of the freedesktop.org specifications.")
+ (license license:bsd-2)))
+
(define-public libliftoff
(package
(name "libliftoff")
--
2.47.1
Ahmad Draidi wrote 2 months ago
[PATCH 3/3] gnu: labwc: Update to 0.8.2.
(address . 75155@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
8ea15b4bf1a04ff5f49296fbea697d3ad1a73bdc.1735365259.git.a.r.draidi@redscript.org
* gnu/packages/wm.scm (labwc): Update to 0.8.2.
[inputs]: Replace wlroots-0.17 with wlroots, add libliftoff and libsfdo.

Change-Id: I72905d5a9e4252dc709ae0f0bcacdb129d754840
---
gnu/packages/wm.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8da82e6411..9814b4e2c7 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3456,7 +3456,7 @@ (define-public libucl
(define-public labwc
(package
(name "labwc")
- (version "0.7.4")
+ (version "0.8.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3465,7 +3465,7 @@ (define-public labwc
(file-name (git-file-name name version))
(sha256
(base32
- "0xwgbqv0ablcjaq77c98m4rpgfylr1mja081ay9lccpjqycgbhgc"))))
+ "1j2fv64yz77rfa003b89q0gfri7pbqvjp27wg8ri7x3hfkxrbxvn"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config gettext-minimal scdoc))
@@ -3473,10 +3473,12 @@ (define-public labwc
(list cairo
glib
(librsvg-for-system)
+ libliftoff
+ libsfdo
libxcb
libxml2
pango
- wlroots-0.17))
+ wlroots))
(home-page "https://labwc.github.io")
(synopsis "Window-stacking compositor for Wayland")
(description
--
2.47.1
Zheng Junjie wrote 2 months ago
Re: [bug#75155] [PATCH 0/3] Update labwc to 0.8.2 and some related changes
(name . Ahmad Draidi via Guix-patches via)(address . guix-patches@gnu.org)
87wmfdl69i.fsf@iscas.ac.cn
Ahmad Draidi via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (16 lines)
> Hello Guix,
>
> Labwc 0.8.2 mandates wlroots 0.18.1, so we update to latest. We also add
> libsfdo, which is a new dependency.
>
> Ahmad Draidi (3):
> gnu: wlroots: Update to 0.18.2.
> gnu: Add libsfdo.
> gnu: labwc: Update to 0.8.2.
>
> gnu/packages/freedesktop.scm | 20 ++++++++++++++++++++
> gnu/packages/wm.scm | 12 +++++++-----
> 2 files changed, 27 insertions(+), 5 deletions(-)
>
>
> base-commit: 3a8c20408f0078a580d27f74bc69b5a1069a003b
pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmd2jgkACgkQO1qpk+Gi
3/BzzhAAg993cKxHMgpP9O29rhIfXGV76x2+0UM1QH+MB2NRiE2xtKFzlxSykfox
8xhj45M+n6ArwgDP6U+5boFIJFVjBoA3fsVvLi5fxiTrQmnUR81pnDv5BgSOQOrX
lioqsNXd+mCXthr2FEHvHUjIGDCUmEeoucTXea8WejSIWNCyH9sMJepURQvlKk+9
8RHx3h0U/zXVZ7dg7ZhLSmZZpunkgCmZ924uc4L0CFZE1Sy0LQTSzg6Rm/FeOXdm
jA14cIey1s1Kux1YgrY9bBF8ensav4QvpKD7ub8Yc8z9cDNGkLv45JvFv6rV2MIt
5W+wBEfYomDaxlellnzyBqibq1qz/r851FiMxB62g/fzpjd5lSx/N9PXbQztm2KP
XMiXaNerZKKJC/vdLy0+rixrfJ5Ry2VhIlLOz+vBBwviZpEFVgX22Uma7HLt1cMV
YzApgdo4mYYH78uoGB2NM98vRxMCf3NbmvK1gDiQsCuuFmYO0uKkeems/SqMVRSl
slqBIHENS7m5FwKkPqrlukINEUJMLxnKLQzQMOh3i4yoY/CqHcGNdkC/zy7+oqw3
IuvB6G4xYOkzUz6id4MmqVS18tERJV4IjKXQdo9omU6bZCZm7dE8y2EXcffIoNH5
9ZjcM8bPrT/1LlhzWKwyIUuMGvgMUquCtU1OhFny8ZZP2KGwcYE=
=TEcy
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 75155@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75155
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help