[PATCH] fix guile-dbi and guile-dbd-* to use guile 3

  • Open
  • quality assurance status badge
Details
One participant
  • Josep Bigorra
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal
J
J
Josep Bigorra wrote on 27 Dec 2024 13:15
(address . guix-patches@gnu.org)
CAM_04A3xU08xjyGChT=aFtBmJj1-HZgt2PqZC4=nNKiYCSn6Ew@mail.gmail.com
Hey so I was busy with Guile and connecting to databases. I noticed
that guile-dbi and guile-dbd-* are depending on Guile-2 without a
reason for that. Changing to 3 did cause some warnings/errors in the
test phase, which I address in this patch.
I noticed that 2.1.9 has some problems with autoconf and configure, so
I suggest we stay at 2.1.8 while we figure it out.

Thanks in advance,
From 1cb65c8960b1c738d26eca0800602e6118b74e0e Mon Sep 17 00:00:00 2001
Message-ID: <1cb65c8960b1c738d26eca0800602e6118b74e0e.1735301677.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Fri, 27 Dec 2024 13:13:55 +0100
Subject: [PATCH] upgrade guile-dbi (and guile-dbd-*) to Guile 3.0

---
gnu/packages/guile-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 06667c09..ca43c281 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2024 Artyom Bologov <mail@aartaka.me>
;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Alec Barreto <mrh57@posteo.net>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1983,6 +1984,7 @@ (define-public guile-dbi
,@%default-gnu-modules)
#:imported-modules ((guix build guile-build-system)
,@%default-gnu-imported-modules)
+ #:make-flags '("LDFLAGS=\"-Wl,-allow-multiple-definition\"")
#:configure-flags
(list (string-append
"--with-guile-site-dir=" %output "/share/guile/site/"
@@ -2004,9 +2006,9 @@ (define-public guile-dbi
(ext (string-append out "/lib/libguile-dbi")))
(substitute* dbi.scm (("libguile-dbi") ext))))))))
(native-inputs
- (list autoconf automake libtool perl texinfo))
+ (list autoconf automake libtool perl texinfo libltdl))
(propagated-inputs
- (list guile-2.2))
+ (list guile-3.0))
(synopsis "Guile database abstraction layer")
(home-page "https://github.com/opencog/guile-dbi")
(description
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75139@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75139
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch