[PATCH rust-team 0/2] Use override-jemalloc.

  • Open
  • quality assurance status badge
Details
One participant
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 25 Dec 2024 21:34
(address . guix-patches@gnu.org)
cover.1735158599.git.herman@rimm.ee
Hello,

Follow-up to [bug#75097], two packages with relevant phases got added
since I created the override-jemalloc variable.

Cheers,
Herman

Herman Rimm (2):
gnu: rust-tikv-jemalloc-sys-0.6: Use override-jemalloc phases.
gnu: rust-tikv-jemallocator-0.6: Use override-jemalloc phases.

gnu/packages/crates-io.scm | 22 ++--------------------
1 file changed, 2 insertions(+), 20 deletions(-)


base-commit: b3ce03d55ea7b538280d2b7bd53b2ed9f01150b2
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:35
[PATCH rust-team 1/2] gnu: rust-tikv-jemalloc-sys-0.6: Use override-jemalloc phases.
(address . 75098@debbugs.gnu.org)
3b9879c4b8ba7850b0d39cd03f110bffccdacfb3.1735158599.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-tikv-jemalloc-sys-0.6): Adjust.

Change-Id: I579e7ac913f5b5123ee29ebd0889fea2ab18e363
---
gnu/packages/crates-io.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 13d222c5de..58cfd7f1c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -88910,16 +88910,7 @@ (define-public rust-tikv-jemalloc-sys-0.6
(arguments
`(#:cargo-inputs (("rust-cc" ,rust-cc-1)
("rust-libc" ,rust-libc-0.2))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- ;; This flag is needed when not using the bundled jemalloc.
- ;; https://github.com/tikv/jemallocator/issues/19
- (setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))
+ #:phases ,override-jemalloc))
(inputs (list jemalloc))
(home-page "https://github.com/tikv/jemallocator")
(synopsis "Rust FFI bindings to jemalloc")
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:35
[PATCH rust-team 2/2] gnu: rust-tikv-jemallocator-0.6: Use override-jemalloc phases.
(address . 75098@debbugs.gnu.org)
36572fce5dc3d4b8313fba390a923079a8d97ccc.1735158600.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-tikv-jemallocator-0.6): Adjust.

Change-Id: I149192a509e9175d7951129ecd1a7319f449912a
---
gnu/packages/crates-io.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 58cfd7f1c8..b55c2e66b2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -88957,16 +88957,7 @@ (define-public rust-tikv-jemallocator-0.6
#:cargo-inputs (("rust-libc" ,rust-libc-0.2)
("rust-tikv-jemalloc-sys" ,rust-tikv-jemalloc-sys-0.6))
#:cargo-development-inputs (("rust-paste" ,rust-paste-1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- ;; This flag is needed when not using the bundled jemalloc.
- ;; https://github.com/tikv/jemallocator/issues/19
- (setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))
+ #:phases ,override-jemalloc))
(inputs (list jemalloc))
(home-page "https://github.com/tikv/jemallocator")
(synopsis "Rust allocator backed by jemalloc")
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75098@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75098
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch