[PATCH rust-team 1/8] gnu: override-jemalloc: Add variable.

  • Open
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 25 Dec 2024 21:20
(address . guix-patches@gnu.org)
25cd151219b68e3f67148dbba6e3674249faee91.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (override-jemalloc): Add variable.

Change-Id: I3e1666306c9f005072f9ed230f03386b2f78b0b2
---
gnu/packages/crates-io.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b3d9bcd783..fb7710c5a9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39209,6 +39209,19 @@ (define-public rust-javascriptcore-rs-sys-0.2
"Sys functions for the Rust bindings of the javacriptcore library.")
(license license:expat)))
+(define override-jemalloc
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'override-jemalloc
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This flag is needed when not using the bundled jemalloc.
+ ;; https://github.com/tikv/jemallocator/issues/19
+ (setenv
+ "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS"
+ "1")
+ (setenv "JEMALLOC_OVERRIDE"
+ (string-append (assoc-ref inputs "jemalloc")
+ "/lib/libjemalloc_pic.a"))))))
+
(define-public rust-jemalloc-ctl-0.5
(package
(name "rust-jemalloc-ctl")

base-commit: 32ab343e03e998ada27c063ef7d8a00aa88436dd
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 2/8] gnu: rust-jemalloc-ctl-0.5: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
7092c5f8b869ed9f15ecce513069cec2095223bf.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-jemalloc-ctl-0.5)[arguments]: Disable
parallel tests. Use override-jemalloc.

Change-Id: I23718f05ffd3deeb0ea0f9b32412ae6b6f0692db
---
gnu/packages/crates-io.scm | 12 ++----------
1 file changed, 2 insertions(+), 10 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fb7710c5a9..5945fd0a72 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39239,16 +39239,8 @@ (define-public rust-jemalloc-ctl-0.5
("rust-libc" ,rust-libc-0.2)
("rust-paste" ,rust-paste-1))
#:cargo-development-inputs (("rust-jemallocator" ,rust-jemallocator-0.5))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- ;; This flag is needed when not using the bundled jemalloc.
- ;; https://github.com/tikv/jemallocator/issues/19
- (setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))
+ #:parallel-tests? #f ; Tests fail non-deterministically.
+ #:phases ,override-jemalloc))
(native-inputs (list jemalloc))
(home-page "https://github.com/tikv/jemallocator")
(synopsis "Wrapper over jemalloc's control and introspection APIs")
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 3/8] gnu: rust-jemalloc-sys-0.5: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
3ba7e85a54f44f3cb9a01c74024b15b35a377992.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-jemalloc-sys-0.5)[arguments]: Adjust.

Change-Id: Ib7c45999b55c95a3db0944d92985d64e4dadfc3a
---
gnu/packages/crates-io.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5945fd0a72..0a499a6400 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39267,16 +39267,7 @@ (define-public rust-jemalloc-sys-0.5
`(#:cargo-inputs
(("rust-cc" ,rust-cc-1)
("rust-libc" ,rust-libc-0.2))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- ;; This flag is needed when not using the bundled jemalloc.
- ;; https://github.com/tikv/jemallocator/issues/19
- (setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))
+ #:phases ,override-jemalloc))
(native-inputs
(list jemalloc))
(home-page "https://github.com/tikv/jemallocator")
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 4/8] gnu: rust-jemalloc-sys-0.3: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
33a21eda2eed7bf3f912f382b6936eaebdb7b208.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-jemalloc-sys-0.3)[arguments]: Adjust.

Change-Id: Ifc1f2ad115054f7c7db2447e8680cc070273c6f3
---
gnu/packages/crates-io.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0a499a6400..05d61f4209 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39297,14 +39297,7 @@ (define-public rust-jemalloc-sys-0.3
;; Build dependencies:
("rust-cc" ,rust-cc-1)
("rust-fs-extra" ,rust-fs-extra-1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a")))
- #t)))))))
+ #:phases ,override-jemalloc))))
(define-public rust-jemalloc-sys-0.1
(package
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 5/8] gnu: rust-jemallocator-0.5: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
c30aeef79ebe2419690ab63aa0cc0cfb69b1a09c.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-jemallocator-0.5)[arguments]: Adjust.

Change-Id: I329aaa334575c0c89e60e4011ba1274f91098ff0
---
gnu/packages/crates-io.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 05d61f4209..afc90512c2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39338,16 +39338,7 @@ (define-public rust-jemallocator-0.5
#:cargo-development-inputs
(("rust-jemalloc-ctl" ,rust-jemalloc-ctl-0.5)
("rust-paste" ,rust-paste-1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- ;; This flag is needed when not using the bundled jemalloc.
- ;; https://github.com/tikv/jemallocator/issues/19
- (setenv "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS" "1")
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))
+ #:phases ,override-jemalloc))
(native-inputs
(list jemalloc))
(home-page "https://github.com/tikv/jemallocator")
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 6/8] gnu: rust-jemallocator-0.1: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
168efe2ea80756ba9fd560411fcf7b1c6e2bd8cf.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-jemallocator-0.1)[arguments]: Adjust.

Change-Id: Ida6507dff8624d22dc1c6dd77e11426179edb512
---
gnu/packages/crates-io.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index afc90512c2..1216e85226 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39388,14 +39388,7 @@ (define-public rust-jemallocator-0.1
`(#:cargo-inputs
(("rust-jemalloc-sys" ,rust-jemalloc-sys-0.1)
("rust-libc" ,rust-libc-0.2))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a")))
- #t)))))
+ #:phases ,override-jemalloc))
(native-inputs
(list jemalloc))))
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 7/8] gnu: rust-nom-6: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
a0a7163d1cd84d4e4d48cf41108527e85fd666e5.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-nom-6)[arguments]: Adjust.

Change-Id: Iddfad33f6a53aff6faa85d0a3a72b95ffa29ac10
---
gnu/packages/crates-io.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1216e85226..aa73b59a9e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51486,14 +51486,7 @@ (define-public rust-nom-6
(("rust-criterion" ,rust-criterion-0.3)
("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-jemallocator" ,rust-jemallocator-0.3))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a")))
- #t)))))
+ #:phases ,override-jemalloc))
(native-inputs (list jemalloc))))
(define-public rust-nom-5
--
2.45.2
H
H
Herman Rimm wrote on 25 Dec 2024 21:21
[PATCH rust-team 8/8] gnu: rust-nom-5: Use override-jemalloc phases.
(address . 75097@debbugs.gnu.org)
b3ce03d55ea7b538280d2b7bd53b2ed9f01150b2.1735157957.git.herman@rimm.ee
* gnu/packages/crates-io.scm (rust-nom-5)[arguments]: Adjust.

Change-Id: Iddfad33f6a53aff6faa85d0a3a72b95ffa29ac10
---
gnu/packages/crates-io.scm | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aa73b59a9e..13d222c5de 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51513,13 +51513,7 @@ (define-public rust-nom-5
(("rust-criterion" ,rust-criterion-0.2)
("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-jemallocator" ,rust-jemallocator-0.1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'override-jemalloc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((jemalloc (assoc-ref inputs "jemalloc")))
- (setenv "JEMALLOC_OVERRIDE"
- (string-append jemalloc "/lib/libjemalloc_pic.a"))))))))))
+ #:phases ,override-jemalloc))))
(define-public rust-nom-4
(package
--
2.45.2
E
E
Efraim Flashner wrote on 26 Dec 2024 14:44
Re: [bug#75097] [PATCH rust-team 1/8] gnu: override-jemalloc: Add variable.
(name . Herman Rimm)(address . herman@rimm.ee)(address . 75097@debbugs.gnu.org)
Z21dvOrma1li0WPe@3900XT
This one I'm unconvinced about. I could see adding CARGO_FEATURE... to
the cargo-build-system, but this seems like a temporary problem that I
hope gets fixed upstream. If we move this out to a separate location
I'm worried we'll forget about it when it's no longer needed.

Plus we're using libjemalloc_pic.a here and libjemalloc.so in
rust-apps.scm, and I'd prefer to not hard-code one or the other.

On Wed, Dec 25, 2024 at 09:20:20PM +0100, Herman Rimm wrote:
Toggle quote (39 lines)
> * gnu/packages/crates-io.scm (override-jemalloc): Add variable.
>
> Change-Id: I3e1666306c9f005072f9ed230f03386b2f78b0b2
> ---
> gnu/packages/crates-io.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index b3d9bcd783..fb7710c5a9 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -39209,6 +39209,19 @@ (define-public rust-javascriptcore-rs-sys-0.2
> "Sys functions for the Rust bindings of the javacriptcore library.")
> (license license:expat)))
>
> +(define override-jemalloc
> + #~(modify-phases %standard-phases
> + (add-after 'configure 'override-jemalloc
> + (lambda* (#:key inputs #:allow-other-keys)
> + ;; This flag is needed when not using the bundled jemalloc.
> + ;; https://github.com/tikv/jemallocator/issues/19
> + (setenv
> + "CARGO_FEATURE_UNPREFIXED_MALLOC_ON_SUPPORTED_PLATFORMS"
> + "1")
> + (setenv "JEMALLOC_OVERRIDE"
> + (string-append (assoc-ref inputs "jemalloc")
> + "/lib/libjemalloc_pic.a"))))))
> +
> (define-public rust-jemalloc-ctl-0.5
> (package
> (name "rust-jemalloc-ctl")
>
> base-commit: 32ab343e03e998ada27c063ef7d8a00aa88436dd
> --
> 2.45.2
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmdtXbwACgkQQarn3Mo9
g1G8+w//akYmsSa+jTDh/MiDPMLwQueiDAbMyIWokGNmk7Me7i9E8zd7oPY9kBcR
/Kzllc+TS/a69Xak8nSinjFh8+jLkCuETx7ydt9jPLvdqHwOBShjWq63mAJeppUH
GUhCubCHsf5jXIf0oEBHANyRYQYLWdvVWvDgJOtcsCDOoLOYq8DRLuis1fIFxLG0
Ds+RJdkV0yJ2T+k7h9NaoOVtr510Y2HRMPLLAgTJg3L7yTXV9Q1AK5T5650wkkz7
VCy+2Yr+Gf6PGijdYEGTqoiVtvbfvKu33iYzRbuc9Ly9Gs5EFZtxC3BfY2IyTlmW
bL3RSyDrty6PQbVwk7HRsmCGIUjVun7G5X0Eq1nkIh7q6Hc1bSCQHd3KAWnFtJqm
UXs4WekCMDZT520L5GBJrEnuFM3UGUcqti8LdfQbphqlUJLNcCh1XLbTId3u8BXK
SZKwsWu3jsmmJ/WuAvO/+3QTeZt+lxUlBS98fwSBMWTZmDu5EU6oIE20219YB8GR
G/Y4x5XFtr2HfMJ6OSnlIiH1jyVZ6ADah7G0eOSerc9ntl4QsGrvWSnchFNX9VIp
CzDNy2UGqQxxgDQ1Bz7XP0rgkhOnqL4FnGtHQyqim8j+U0Sx9ej4svzv7WfdPgh+
IYdkQx2BrMcIy3RkJMDkvvjYJRrgrA9uGHos9L4YHNwzu0MIKi4=
=B+Y0
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75097@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75097
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch