[PATCH 0/7] Fix beancount and fava builds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sergey Trofimov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 3 months ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cover.1735134163.git.sarg@sarg.org.ru
This series fixes beancount and its dependencies builds and also bumps fava to a matching version.

Sergey Trofimov (7):
gnu: python-babel: Update to 2.16.0.
gnu: python-flask-babel: Update to 4.0.0.
gnu: python-markdown2: Fix build.
gnu: python-pdfminer-six: Update to 20240706.
gnu: Add python-types-simplejson.
gnu: beancount: Fix build.
gnu: fava: Update to 1.27.

gnu/packages/finance.scm | 39 ++++++++++++++++---------------------
gnu/packages/python-web.scm | 26 ++++++++++++++++---------
gnu/packages/python-xyz.scm | 37 ++++++++++++++++++++++++-----------
3 files changed, 60 insertions(+), 42 deletions(-)


base-commit: eb6d784852dfcade2f5052c4d6fc1bd469f3cdb6
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 1/7] gnu: python-babel: Update to 2.16.0.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
76d8de0b3f80fd05f754a5870ada2724d4accbf6.1735134164.git.sarg@sarg.org.ru
* gnu/packages/python-xyz.scm (python-babel): Update to 2.16.0.
---
gnu/packages/python-xyz.scm | 14 ++++++--------
1 file changed, 6 insertions(+), 8 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36e9b38b50..ede99889e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2962,19 +2962,17 @@ (define-public python-clyent
(define-public python-babel
(package
(name "python-babel")
- (version "2.10.3")
+ (version "2.16.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Babel" version))
(sha256
(base32
- "0l9cvfmsz0hlvcinxaf6xf2f02ldgw3xq9i1fc7lk5zf24vma53n"))))
+ "05p3k0i5h8v4vqsg36s94kwl4nhgfmgwdq1x7wbzw1b6l965bwyi"))))
(build-system python-build-system)
(native-inputs
- (list python-freezegun python-pytest tzdata-for-tests))
- (propagated-inputs
- (list python-pytz))
+ (list python-freezegun python-pytest python-pytest-cov tzdata-for-tests))
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
@@ -15823,7 +15821,7 @@ (define-public python-markdown
(define-public python-markdown2
(package
(name "python-markdown2")
- (version "2.4.13")
+ (version "2.5.2")
(source
(origin
(method git-fetch) ; no tests data in PyPi package
@@ -15832,7 +15830,7 @@ (define-public python-markdown2
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0m1wy8i4xmna5b97dvks8cfjmc1wid8pxmd2h82869d0ajva3r6a"))))
+ (base32 "01ll612yq7kjmj5p2zi9sf4l2wg6rm1ldcr6h0m2d9j180j7ggs8"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -15844,7 +15842,7 @@ (define-public python-markdown2
(with-directory-excursion "test"
(invoke "python" "testall.py"))))))))
(native-inputs
- (list python-pygments))
+ (list python-setuptools python-pygments))
(home-page "https://github.com/trentm/python-markdown2")
(synopsis "Fast and complete Python implementation of Markdown")
(description
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 2/7] gnu: python-flask-babel: Update to 4.0.0.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
a99fd446d76afc5b13386f1f2c7b6419fac99915.1735134164.git.sarg@sarg.org.ru
* gnu/packages/python-web.scm (python-flask-babel): Update to 4.0.0.
[source]: Fetch from git as pypi release doesn't include tests.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Adjust.
[propagated-inputs]: Sort.
---
gnu/packages/python-web.scm | 26 +++++++++++++++++---------
1 file changed, 17 insertions(+), 9 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d0695e39f3..c2960964d3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1891,17 +1891,25 @@ (define-public python-flask-assets
(define-public python-flask-babel
(package
(name "python-flask-babel")
- (version "2.0.0")
+ (version "4.0.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-Babel" version))
- (sha256
- (base32
- "0z95v77vib5il8hphyh16n7i15a2gmc06i615vm346ifvdfg9ypr"))))
- (build-system python-build-system)
+ (origin
+ (method git-fetch) ;no tests in pypi release
+ (uri (git-reference
+ (url "https://github.com/python-babel/flask-babel")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "19yq3f5rixbwhv7wxdarvi9hdj98a9dq8y76in9c1q3jxaigw104"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-black
+ python-coverage
+ python-poetry-core
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock))
(propagated-inputs
- (list python-flask python-babel python-jinja2 python-pytz))
+ (list python-babel python-flask python-jinja2 python-pytz))
(home-page "https://github.com/python-babel/flask-babel")
(synopsis "Add i18n/l10n support to Flask applications")
(description "This package implements internationalization and localization
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 3/7] gnu: python-markdown2: Fix build.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20cf6b4aebaaece781e6bd65aed2c46191c4e61f.1735134164.git.sarg@sarg.org.ru
* gnu/packages/python-xyz.scm (python-markdown2)
[native-inputs]: Add python-wheel.
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ede99889e5..fb3f91f458 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15842,7 +15842,7 @@ (define-public python-markdown2
(with-directory-excursion "test"
(invoke "python" "testall.py"))))))))
(native-inputs
- (list python-setuptools python-pygments))
+ (list python-setuptools python-pygments python-wheel))
(home-page "https://github.com/trentm/python-markdown2")
(synopsis "Fast and complete Python implementation of Markdown")
(description
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 4/7] gnu: python-pdfminer-six: Update to 20240706.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
5739929a032ae99d0a5e525164a0f36334ad5b02.1735134164.git.sarg@sarg.org.ru
* gnu/packages/python-xyz.scm (python-pdfminer-six): Update to 20240706.
---
gnu/packages/python-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fb3f91f458..d5a5dcb878 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21076,7 +21076,7 @@ (define-public python-jellyfish
(define-public python-pdfminer-six
(package
(name "python-pdfminer-six")
- (version "20231228")
+ (version "20240706")
;; There are no tests in the PyPI tarball.
(source
(origin
@@ -21086,7 +21086,7 @@ (define-public python-pdfminer-six
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1anyr0gm7amwls8qifflql1viz5rq6q95lfwcg43v3180h4w8wrd"))))
+ (base32 "0vdwps38q2414lwjz266rabxrcw2a5s1pgxyjsffiifi010cd3k9"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
@@ -21098,7 +21098,7 @@ (define-public python-pdfminer-six
(propagated-inputs
(list python-charset-normalizer python-cryptography))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/pdfminer/pdfminer.six")
(synopsis "PDF parser and analyzer")
(description "@code{pdfminer.six} is a community maintained fork of
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 5/7] gnu: Add python-types-simplejson.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cb10c818ce8a1cf403c995fb3f7c341672b53d69.1735134164.git.sarg@sarg.org.ru
* gnu/packages/python-xyz.scm (python-types-simplejson): New variable.
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5a5dcb878..a75a1992f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -37212,6 +37212,23 @@ (define-public python-types-requests
(description "This package provides typing stubs for requests.")
(license license:asl2.0)))
+(define-public python-types-simplejson
+ (package
+ (name "python-types-simplejson")
+ (version "3.17.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-simplejson" version))
+ (sha256
+ (base32 "1a3gphpjkb315i7l48l6g1rch3nr43k1f7rgalfsdr7897fyv8pz"))))
+ (build-system python-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for simplejson")
+ (description "Typing stubs for simplejson.")
+ (license license:asl2.0)))
+
(define-public python-types-setuptools
(package
(name "python-types-setuptools")
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 7/7] gnu: fava: Update to 1.27.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
62285a5219fd0bc32d9554f1fe857a559d4121e4.1735134164.git.sarg@sarg.org.ru
* gnu/packages/finance.scm (fava): Update to 1.27.
[arguments]: Remove obsolete tweaks.
[native-inputs]: Refresh dependencies.
---
gnu/packages/finance.scm | 36 +++++++++++++++---------------------
1 file changed, 15 insertions(+), 21 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 8284ac545d..7662d33e0f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -124,6 +124,7 @@ (define-module (gnu packages finance)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
@@ -2033,29 +2034,14 @@ (define-public beancount
(define-public fava
(package
(name "fava")
- ;; XXX: A newer version requires Flask > 2.2, which is not available in
- ;; Guix yet.
- (version "1.24.4")
+ (version "1.27")
(source
(origin
(method url-fetch)
(uri (pypi-uri "fava" version))
(sha256
- (base32 "1iwha9vx223iiyjqbixpz1lp8q766ikhi7xcap3pscjhldxlym4j"))))
+ (base32 "0cw3pmyrknsw0h4w3v9vyk6wrii68zwkywsyyvjzyl2qz3xq8srk"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.cfg"
- ((">=8,<10") ">8"))))
- ;; Tests write to $HOME.
- ;; FileNotFoundError: [Errno 2] No such file or directory
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list beancount
python-babel
@@ -2069,10 +2055,18 @@ (define-public fava
python-simplejson
python-werkzeug))
(native-inputs
- (list python-pytest
- python-chardet
- python-dateutil
- python-setuptools-scm))
+ (list python-babel
+ python-mypy
+ python-pylint
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-setuptools-scm
+ python-tox
+ python-twine
+ python-types-setuptools
+ python-types-simplejson
+ python-wheel))
(home-page "https://beancount.github.io/fava/")
(synopsis "Web interface for the accounting tool Beancount")
(description "Fava is a web interface for the double-entry bookkeeping
--
2.46.0
Sergey Trofimov wrote 3 months ago
[PATCH 6/7] gnu: beancount: Fix build.
(address . 75088@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
6cbb1f188ca6627bb0a8d5967e77cef68985a358.1735134164.git.sarg@sarg.org.ru
* gnu/packages/finance.scm (beancount)
[native-inputs]: Add python-wheel and python-setuptools.
---
gnu/packages/finance.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 149bebfa2f..8284ac545d 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2020,7 +2020,8 @@ (define-public beancount
python-ply
python-requests))
(native-inputs
- (list gnupg python-pdfminer-six python-pytest))
+ (list gnupg python-pdfminer-six python-pytest
+ python-setuptools python-wheel))
(home-page "https://beancount.github.io/")
(synopsis "Command-line double-entry accounting tool")
(description
--
2.46.0
Sharlatan Hellseher wrote 2 months ago
[PATCH 0/7] Fix beancount and fava builds.
(address . 75088-done@debbugs.gnu.org)
87frm9jxtw.fsf@gmail.com
Hi,

Thanks for the patches.

Pushed to python-team because of the reason.

Toggle quote (3 lines)
> Building the following 2066 packages would ensure 4563 dependent
> packages are rebuilt

I've adjust some patches to reduce amount of not required inputs (e.g.
python-black, python-covarage etc), migrate to pyproject-build-system
and use the latest PyPI versions.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdubvsACgkQdtcnv/Ys
0rW6mA//afodPAIOLr+GAmbc9CEQle0R9+9+fKpwan0ogiJNf7knSGaOgeu7aOcJ
+mFf1hIt2K457U2U4RlVItOQ4tm68z4Uc5HWI8K9676XHX5KqYeEn4cPKIuAajZI
5mbEpUGA/JnQaLP0BOCy3e5HUpJcRL136YcX6x2koX/cTXPTyoIREwqvI41AV8cZ
QwzA1T996ieJw/jx/E18/lIw7XdURMUbGXORyKm/XGP9pc19i/rhJqsaXWEoa8nf
UbOFscxZ3eYMZ5QU7dGivyM+ZJvwatjqAM+G3gA4VWXigXranl+4C8TMnLkF6r1O
8NUel8dNg0U5Qs1g3vHP9sf1BzrJ+5kLLkY1RnyxvU+SZXneAaG3PP6vDUiOR3bh
e0nUJUIdDTGy/014X5qOuPj5YgYUKH6755BqhpVj3U6N7G3PFZcxmXmJOCkS92r6
RT7TFSpG8DmrFy/+6OVjPfojpHY+/vChBawlWN0hAFE96LJsOCsXOn1UZQWIuwZx
YZuGmnFCy3Qe7lXa6W7/boGwqKYExsDXAz6DH7JHBK2t7EC3CdGib5rc1rkqa5ib
yTCH8kV1a50DnJJTekW/g2MliBi5+9m1qPSIukyKRVUHWtoLppCiDQx3V7pJcIMH
wJY3ps2kfE9i+h7Syo6JaIyolfVwgKfA4Ygpay9mvBj9ncRCOxg=
=ENMW
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 75088@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75088
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help