[PATCH] gnu: Add python-terminaltexteffects.

  • Open
  • quality assurance status badge
Details
One participant
  • Andrew Wong
Owner
unassigned
Submitted by
Andrew Wong
Severity
normal
A
A
Andrew Wong wrote on 25 Dec 2024 09:26
(address . guix-patches@gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
20241225082614.11711-1-wongandj@icloud.com
Change-Id: I6ef522fe5c59b4da4e604fe6473e42e5d2b476d0
---
gnu/packages/toys.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 359cdbcbe1..6da211046f 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -42,6 +42,9 @@ (define-module (gnu packages toys)
#:use-module (guix build-system gnu)
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
+ #:use-module (gnu packages python-xyz)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -49,6 +52,36 @@ (define-module (gnu packages toys)
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public python-terminaltexteffects
+ (package
+ (name "python-terminaltexteffects")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "terminaltexteffects" version))
+ (sha256
+ (base32 "1cnw2f0pwsbvva9pbiwjxc8aygvsnfjlpbhrdflh8fh0p9rwnc0l"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check))))
+ (inputs (list poetry))
+ (home-page "https://github.com/ChrisBuilds/terminaltexteffects")
+ (synopsis "Terminal visual effects engine and demo toy")
+ (description
+ "TerminalTextEffects (TTE) is a terminal visual effects engine. TTE can
+be installed as a system application to produce effects in your
+terminal, or as a Python library to enable effects within your Python
+scripts/applications. TTE includes a growing library of built-in
+effects which showcase the engine's features, including complex
+character movement via Paths, Waypoints, and motion easing, with
+support for quadratic/cubic bezier curves, complex animations via
+Scenes with symbol/color changes, layers, easing, and Path synced
+progression, and variable stop/step color gradient generation. Runs
+inline, preserving terminal state and workflow.")
+ (license license:expat)))
+
(define-public daikichi
(package
(name "daikichi")
--
2.46.0
A
A
Andrew Wong wrote on 5 Jan 10:33 +0100
[PATCH v2] gnu: Add terminaltexteffects.
(address . 75082@debbugs.gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
4357c7b7dc338db67ecfdea97eb63342b55271da.1736069629.git.wongandj@icloud.com
* gnu/packages/toys.scm (terminaltexteffects): New variable.

Change-Id: I3b8ec681445c2d787c275788b90ce29c2f5053cf
---
gnu/packages/toys.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 359cdbcbe1..b8c77490d5 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -37,11 +37,14 @@ (define-module (gnu packages toys)
#:use-module (gnu packages perl)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
#:use-module (guix build-system copy)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -49,6 +52,35 @@ (define-module (gnu packages toys)
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public terminaltexteffects
+ (package
+ (name "terminaltexteffects")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "terminaltexteffects" version))
+ (sha256
+ (base32 "1cnw2f0pwsbvva9pbiwjxc8aygvsnfjlpbhrdflh8fh0p9rwnc0l"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs (list poetry))
+ (home-page "https://github.com/ChrisBuilds/terminaltexteffects")
+ (synopsis "Terminal visual effects engine and demo toy")
+ (description
+ "TerminalTextEffects (TTE) is a terminal visual effects engine. TTE can
+be installed as a system application to produce effects in your
+terminal, or as a Python library to enable effects within your Python
+scripts/applications. TTE includes a growing library of built-in
+effects which showcase the engine's features, including complex
+character movement via Paths, Waypoints, and motion easing, with
+support for quadratic/cubic bezier curves, complex animations via
+Scenes with symbol/color changes, layers, easing, and Path synced
+progression, and variable stop/step color gradient generation. Runs
+inline, preserving terminal state and workflow.")
+ (license license:expat)))
+
(define-public daikichi
(package
(name "daikichi")

base-commit: e383e8e34097b064d4baa4207673c6ba30617347
--
2.47.1
A
A
Andrew Wong wrote on 26 Jan 13:41 +0100
[PATCH] gnu: Add python-terminaltexteffects. (bump)
(address . 75082@debbugs.gnu.org)
bef48d1e-3655-41a6-9730-1c9c46322e6b@icloud.com
Hi, has this been seen yet? I know it's not an important package but
it's still nice to have it upstreamed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75082@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75082
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch