[PATCH 0/2] Easy configuration of FreeDict into dicod-service-type

  • Open
  • quality assurance status badge
Details
One participant
  • Runciter
Owner
unassigned
Submitted by
Runciter
Severity
normal
R
R
Runciter wrote 20 hours ago
(address . guix-patches@gnu.org)(name . Runciter)(address . runciter@whispers-vpn.org)
cover.1735043982.git.runciter@whispers-vpn.org
A few weeks my patch for FreeDict multilingual dictionaries for Guix was
integrated to the master branch (bug #74411).

These patches are simple updates to the (gnu services dict) module and to the
Guix info manual to help users configure FreeDict dictionaries into their
local dicod server.

Regards,
Runciter

Runciter (2):
gnu: dict: Add symbols to help users configure FreeDict with dicod.
doc: add FreeDict dictionaries to dicod configuration example.

doc/guix.texi | 8 ++--
gnu/services/dict.scm | 107 +++++++++++++++++++++++++++++++++++++++++-
2 files changed, 111 insertions(+), 4 deletions(-)


base-commit: 9dc91360fd2e41fb783ab4af341ac60aee2f5d31
--
2.46.0
R
R
Runciter wrote 20 hours ago
[PATCH 1/2] gnu: dict: Add symbols to help users configure FreeDict with dicod.
(address . 75063@debbugs.gnu.org)(name . Runciter)(address . runciter@whispers-vpn.org)
37d349728afe8f4403d7a652e02b33fc895bc02b.1735043983.git.runciter@whispers-vpn.org
* gnu/services/dict.scm: (%dictorg-handler): New variable;
(freedict-dictorg-database): new procedure;
(%freedict-dictorg-databases): new variable.

Signed-off-by: Runciter <runciter@whispers-vpn.org>
---
gnu/services/dict.scm | 107 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 106 insertions(+), 1 deletion(-)

Toggle diff (134 lines)
diff --git a/gnu/services/dict.scm b/gnu/services/dict.scm
index a4e25f5302..39fb38c9c3 100644
--- a/gnu/services/dict.scm
+++ b/gnu/services/dict.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2020, 2022, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
+;;; Copyright © 2024 Runciter <runciter@whispers-vpn.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,7 +41,10 @@ (define-module (gnu services dict)
dicod-configuration
dicod-handler
dicod-database
- %dicod-database:gcide))
+ %dicod-database:gcide
+ %dictorg-handler
+ freedict-dictorg-database
+ %freedict-dictorg-databases))
;;;
@@ -94,6 +98,107 @@ (define %dicod-database:gcide
(options (list #~(string-append "dbdir=" #$gcide "/share/gcide")
#~(string-append "idxdir=" #$%dicod-gcide-index)))))
+(define %dictorg-handler
+ (dicod-handler (name "dictorg")
+ (module "dictorg")
+ (options (list #~(string-append "dbdir=/")))))
+
+(define (freedict-dictorg-database dict-name)
+ "Return a record of type @code{<dicod-database>} that configures a
+database for the freedict multilingual dictionary named by the string
+DICT-NAME."
+ (dicod-database (name (string-append "freedict-"
+ dict-name))
+ (complex? #t)
+ (handler "dictorg")
+ (options (list #~(string-append "database="
+ #$freedict-dictionaries
+ "/share/dictd/"
+ #$dict-name)))))
+
+(define %freedict-dictorg-databases
+ (map freedict-dictorg-database (list "afr-deu"
+ "afr-eng"
+ "ara-eng"
+ "bre-fra"
+ "ces-eng"
+ "ckb-kmr"
+ "cym-eng"
+ "dan-eng"
+ "deu-ita"
+ "deu-kur"
+ "deu-nld"
+ "deu-por"
+ "deu-tur"
+ "eng-afr"
+ "eng-ara"
+ "eng-ces"
+ "eng-cym"
+ "eng-dan"
+ "eng-ell"
+ "eng-fra"
+ "eng-gle"
+ "eng-hin"
+ "eng-hrv"
+ "eng-hun"
+ "eng-ita"
+ "eng-lat"
+ "eng-lit"
+ "eng-nld"
+ "eng-pol"
+ "eng-por"
+ "eng-rom"
+ "eng-rus"
+ "eng-spa"
+ "eng-srp"
+ "eng-swh"
+ "eng-tur"
+ "fra-bre"
+ "fra-eng"
+ "fra-nld"
+ "gla-deu"
+ "gle-eng"
+ "gle-pol"
+ "hrv-eng"
+ "hun-eng"
+ "isl-eng"
+ "ita-deu"
+ "ita-eng"
+ "jpn-deu"
+ "jpn-eng"
+ "jpn-fra"
+ "jpn-rus"
+ "kha-deu"
+ "kha-eng"
+ "kur-deu"
+ "kur-eng"
+ "kur-tur"
+ "lat-deu"
+ "lat-eng"
+ "lit-eng"
+ "mkd-bul"
+ "nld-deu"
+ "nld-eng"
+ "nld-fra"
+ "nno-nob"
+ "oci-cat"
+ "pol-gle"
+ "por-deu"
+ "por-eng"
+ "san-deu"
+ "slk-eng"
+ "slv-eng"
+ "spa-ast"
+ "spa-eng"
+ "spa-por"
+ "srp-eng"
+ "swe-eng"
+ "swh-eng"
+ "swh-pol"
+ "tur-deu"
+ "tur-eng"
+ "wol-fra")))
+
(define %dicod-accounts
(list (user-group
(name "dicod")
--
2.46.0
R
R
Runciter wrote 20 hours ago
[PATCH 2/2] doc: add FreeDict dictionaries to dicod configuration example.
(address . 75063@debbugs.gnu.org)(name . Runciter)(address . runciter@whispers-vpn.org)
885d30d51d2cca429aedff4270f18a5bde4b95f1.1735043983.git.runciter@whispers-vpn.org
* doc/guix.texi: (Dictionary Service): Update configuration example.

Signed-off-by: Runciter <runciter@whispers-vpn.org>
---
doc/guix.texi | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 08ffbc36d7..1a394b91b2 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -41158,13 +41158,15 @@ Miscellaneous Services
(name "wordnet")
(module "wordnet")
(options
- (list #~(string-append "wnhome=" #$wordnet))))))
- (databases (list
+ (list #~(string-append "wnhome=" #$wordnet))))
+ %dictorg-handler))
+ (databases (cons*
(dicod-database
(name "wordnet")
(complex? #t)
(handler "wordnet"))
- %dicod-database:gcide))))
+ %dicod-database:gcide
+ %freedict-dictorg-databases))))
@end lisp
@cindex Docker
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75063@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75063
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch