[PATCH rust-team 1/5] gnu: rust-x11-clipboard-0.9: Order alphabetically.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote 23 hours ago
(address . guix-patches@gnu.org)
af73e72da18d71c8a07b15bffa4252638e062ea3.1735034375.git.herman@rimm.ee
* gnu/packages/crates-graphics.scm (rust-x11-clipboard-0.9): Order.

Change-Id: I07a80145fd6c2b7cea983a2c6b083ea0d1f9e800
---
gnu/packages/crates-graphics.scm | 66 ++++++++++++++++----------------
1 file changed, 33 insertions(+), 33 deletions(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index e521750e73..d1626a2b4b 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6446,6 +6446,39 @@ (define-public rust-x11-2
(description "This crate provides X11 library bindings for Rust.")
(license license:expat)))
+(define-public rust-x11-clipboard-0.9
+ (package
+ (name "rust-x11-clipboard")
+ (version "0.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "x11-clipboard" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "18rmsm0lrcc4hy2wqs7gn90czv59sv5bj07bbf76nfbysyrp8bb6"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags '("--release" "--"
+ "--skip=tests::should_work_but_does_not")
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+ ("rust-x11rb" ,rust-x11rb-0.13))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ ;; Most tests require an X server.
+ (let ((xvfb (search-input-file (or native-inputs inputs)
+ "bin/Xvfb"))
+ (display ":1"))
+ (setenv "DISPLAY" display)
+ (system (string-append xvfb " " display " &"))))))))
+ (native-inputs (list xorg-server-for-tests))
+ (home-page "https://github.com/quininer/x11-clipboard")
+ (synopsis "X11 clipboard support for Rust")
+ (description "This package provides x11 clipboard support for Rust.")
+ (license license:expat)))
+
(define-public rust-x11rb-0.13
(package
(name "rust-x11rb")
@@ -6644,39 +6677,6 @@ (define-public rust-x11rb-protocol-0.10
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
-(define-public rust-x11-clipboard-0.9
- (package
- (name "rust-x11-clipboard")
- (version "0.9.3")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "x11-clipboard" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "18rmsm0lrcc4hy2wqs7gn90czv59sv5bj07bbf76nfbysyrp8bb6"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-test-flags '("--release" "--"
- "--skip=tests::should_work_but_does_not")
- #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
- ("rust-x11rb" ,rust-x11rb-0.13))
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- ;; Most tests require an X server.
- (let ((xvfb (search-input-file (or native-inputs inputs)
- "bin/Xvfb"))
- (display ":1"))
- (setenv "DISPLAY" display)
- (system (string-append xvfb " " display " &"))))))))
- (native-inputs (list xorg-server-for-tests))
- (home-page "https://github.com/quininer/x11-clipboard")
- (synopsis "X11 clipboard support for Rust")
- (description "This package provides x11 clipboard support for Rust.")
- (license license:expat)))
-
(define-public rust-x11-clipboard-0.8
(package
(inherit rust-x11-clipboard-0.9)

base-commit: e793fbbd5282713fe5c9aad512c5784b0afff175
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 2/5] gnu: rust-x11-clipboard-0.8: Order alphabetically.
(address . 75060@debbugs.gnu.org)
0813ea56a40a3cbbb14e3762cf116c1a22f4fc40.1735034375.git.herman@rimm.ee
* gnu/packages/crates-graphics.scm (rust-x11-clipboard-0.8): Order.

Change-Id: I808c9257b4528b4e569d8a92112aac590f914007
---
gnu/packages/crates-graphics.scm | 50 ++++++++++++++++----------------
1 file changed, 25 insertions(+), 25 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d1626a2b4b..191fbefb5b 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6479,6 +6479,31 @@ (define-public rust-x11-clipboard-0.9
(description "This package provides x11 clipboard support for Rust.")
(license license:expat)))
+(define-public rust-x11-clipboard-0.8
+ (package
+ (inherit rust-x11-clipboard-0.9)
+ (name "rust-x11-clipboard")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "x11-clipboard" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ps0fk1912vzy382fc8l926q8w1l8bxmw72l3kr9bwdi2l8wl6ml"))))
+ (arguments
+ `(#:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.12))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ ;; Most tests require an X server.
+ (let ((xvfb (search-input-file (or native-inputs inputs)
+ "bin/Xvfb"))
+ (display ":1"))
+ (setenv "DISPLAY" display)
+ (system (string-append xvfb " " display " &"))))))))))
+
(define-public rust-x11rb-0.13
(package
(name "rust-x11rb")
@@ -6677,31 +6702,6 @@ (define-public rust-x11rb-protocol-0.10
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
-(define-public rust-x11-clipboard-0.8
- (package
- (inherit rust-x11-clipboard-0.9)
- (name "rust-x11-clipboard")
- (version "0.8.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "x11-clipboard" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1ps0fk1912vzy382fc8l926q8w1l8bxmw72l3kr9bwdi2l8wl6ml"))))
- (arguments
- `(#:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.12))
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- ;; Most tests require an X server.
- (let ((xvfb (search-input-file (or native-inputs inputs)
- "bin/Xvfb"))
- (display ":1"))
- (setenv "DISPLAY" display)
- (system (string-append xvfb " " display " &"))))))))))
-
(define-public rust-x11-clipboard-0.7
(package
(inherit rust-x11-clipboard-0.8)
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 3/5] gnu: rust-x11-clipboard-0.7: Order alphabetically.
(address . 75060@debbugs.gnu.org)
4a7475cb78503cf00c3ad2a0a7563c5a1a12c8db.1735034375.git.herman@rimm.ee
* gnu/packages/crates-graphics.scm (rust-x11-clipboard-0.7): Order.

Change-Id: Ib6acb4592a5a9915572d4a89212cb3db24a597a6
---
gnu/packages/crates-graphics.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 191fbefb5b..92d5e10036 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6504,6 +6504,22 @@ (define-public rust-x11-clipboard-0.8
(setenv "DISPLAY" display)
(system (string-append xvfb " " display " &"))))))))))
+(define-public rust-x11-clipboard-0.7
+ (package
+ (inherit rust-x11-clipboard-0.8)
+ (name "rust-x11-clipboard")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "x11-clipboard" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r3lgslbbdf0mb914n0f9q2pqci407r1pcddwbl7sfvc4alrl2wq"))))
+ (arguments
+ `(#:tests? #f ; Wants a running X server.
+ #:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.10))))))
+
(define-public rust-x11rb-0.13
(package
(name "rust-x11rb")
@@ -6702,22 +6718,6 @@ (define-public rust-x11rb-protocol-0.10
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
-(define-public rust-x11-clipboard-0.7
- (package
- (inherit rust-x11-clipboard-0.8)
- (name "rust-x11-clipboard")
- (version "0.7.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "x11-clipboard" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0r3lgslbbdf0mb914n0f9q2pqci407r1pcddwbl7sfvc4alrl2wq"))))
- (arguments
- `(#:tests? #f ; Wants a running X server.
- #:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.10))))))
-
(define-public rust-x11-dl-2
(package
(name "rust-x11-dl")
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 4/5] gnu: rust-x11-dl-2: Order alphabetically.
(address . 75060@debbugs.gnu.org)
09f33213aa50c7f62377a578daa4fae86c3e40be.1735034375.git.herman@rimm.ee
* gnu/packages/crates-graphics.scm (rust-x11-dl-2): Order.

Change-Id: Ia2f163c5518243bea4147f2ea7d4e8c4186e91e8
---
gnu/packages/crates-graphics.scm | 46 ++++++++++++++++----------------
1 file changed, 23 insertions(+), 23 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 92d5e10036..a10a511b41 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6520,6 +6520,29 @@ (define-public rust-x11-clipboard-0.7
`(#:tests? #f ; Wants a running X server.
#:cargo-inputs (("rust-x11rb" ,rust-x11rb-0.10))))))
+(define-public rust-x11-dl-2
+ (package
+ (name "rust-x11-dl")
+ (version "2.21.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "x11-dl" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0vsiq62xpcfm0kn9zjw5c9iycvccxl22jya8wnk18lyxzqj5jwrq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://github.com/erlepereira/x11-rs.git")
+ (synopsis "X11 library bindings for Rust")
+ (description "This package provides X11 library bindings for Rust.")
+ (license license:expat)))
+
(define-public rust-x11rb-0.13
(package
(name "rust-x11rb")
@@ -6718,29 +6741,6 @@ (define-public rust-x11rb-protocol-0.10
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
-(define-public rust-x11-dl-2
- (package
- (name "rust-x11-dl")
- (version "2.21.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "x11-dl" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0vsiq62xpcfm0kn9zjw5c9iycvccxl22jya8wnk18lyxzqj5jwrq"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-libc" ,rust-libc-0.2)
- ("rust-once-cell" ,rust-once-cell-1)
- ("rust-pkg-config" ,rust-pkg-config-0.3))))
- (home-page "https://github.com/erlepereira/x11-rs.git")
- (synopsis "X11 library bindings for Rust")
- (description "This package provides X11 library bindings for Rust.")
- (license license:expat)))
-
(define-public rust-xkbcommon-0.7
(package
(name "rust-xkbcommon")
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 5/5] gnu: rust-xkb-0.3: Order alphabetically.
(address . 75060@debbugs.gnu.org)
02c5f3376d715346834ba5927b3a93d3db56fdbb.1735034375.git.herman@rimm.ee
* gnu/packages/crates-graphics.scm (rust-xkb-0.3): Order.

Change-Id: Id856a8fe8d72e019039bba04c2775f6e5920d977
---
gnu/packages/crates-graphics.scm | 52 ++++++++++++++++----------------
1 file changed, 26 insertions(+), 26 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index a10a511b41..942f0602a3 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6741,6 +6741,32 @@ (define-public rust-x11rb-protocol-0.10
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3))))))
+(define-public rust-xkb-0.3
+ (package
+ (name "rust-xkb")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "xkb" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03rfx8n3pajc95riksnshh3aqm8dqij2iis5icl88pa6ylk9x0gj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-xcb" ,rust-xcb-1)
+ ("rust-xkbcommon-sys" ,rust-xkbcommon-sys-1))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list clang libxkbcommon-1.5 mesa))
+ (home-page "https://github.com/meh/rust-xkb")
+ (synopsis "Rusty wrapper around libxkbcommon")
+ (description "This package provides Rusty wrapper around libxkbcommon.")
+ (license license:wtfpl2)))
+
(define-public rust-xkbcommon-0.7
(package
(name "rust-xkbcommon")
@@ -6848,32 +6874,6 @@ (define-public rust-xkbcommon-sys-1
(description "This package provides bindings to libxkbcommon.")
(license license:wtfpl2)))
-(define-public rust-xkb-0.3
- (package
- (name "rust-xkb")
- (version "0.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "xkb" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "03rfx8n3pajc95riksnshh3aqm8dqij2iis5icl88pa6ylk9x0gj"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-xcb" ,rust-xcb-1)
- ("rust-xkbcommon-sys" ,rust-xkbcommon-sys-1))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list clang libxkbcommon-1.5 mesa))
- (home-page "https://github.com/meh/rust-xkb")
- (synopsis "Rusty wrapper around libxkbcommon")
- (description "This package provides Rusty wrapper around libxkbcommon.")
- (license license:wtfpl2)))
-
(define-public rust-xkeysym-0.2
(package
(name "rust-xkeysym")
--
2.45.2
E
E
Efraim Flashner wrote 21 hours ago
Re: [bug#75060] [PATCH rust-team 1/5] gnu: rust-x11-clipboard-0.9: Order alphabetically.
(name . Herman Rimm)(address . herman@rimm.ee)(address . 75060-done@debbugs.gnu.org)
Z2qij3S2mZDDKwpt@3900XT
Thanks. Patches pushed to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmdqoo8ACgkQQarn3Mo9
g1GMTA//crVqnglf6v9RLTRyqZjmD7GPSY3G6/ewH1pgrFUP1QugoFoFV4rpqFRc
7HpzlNK62Ovq4R/rTsbQkbwzBlSOnyKu/75khm5VYdS62ghN9GVnb7hLPt9A/f/C
Cnw5WexGq8t17YKJHqERK7bs/54ZvxIg1zA016wUDjIXWCXQ2aBCkXBOrs31/+1N
MvB3pcbPSwnuPWxxHc0zXNZ49hsTkuYRTG/20K/m5Z8zkX9JoPde0dcdKEzwW3hT
MNu3n9ZlO8/qm65G53luzPtuGvhlyCiTFna04eKsw1OMVQaRGVr9V73HywZVxCwY
lM52ilYhb8Aig0LwS3oGtAM1DqiKCqsipiOkKkDsnJBvUQrYhHAXC83rII4fMG5+
qmv2uwfRBKg7fna/+NVmeWANQP+P+a5Rk85v5WWSY9yb5/dMZ2NsWIPmKO/UflK9
IBzhNoeo9kH6tsE2irmRAmoz9fO/X8Niv7vG5aXu8zpTfhi4Gk+c9LKVg8h0Y+2W
XxU79RaRGM5LbVnGRlCU02JNoSISeH69cX+FAB/RwWdUfMBs+4wlgFW4JgeGY+Bi
s87OZOrUB0sTt75iA9BNnRMTcFnZ2LunjX8Nzvk0uTYhQlBau2U45tBUMxNWk1N/
zvJCyysN/Q5WRvX1ndVmLWu+t4cU8PXdWfMWgBubF1XtWGT1Was=
=6vEe
-----END PGP SIGNATURE-----


Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75060@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75060
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch