[PATCH rust-team 1/8] gnu: rust-botan-sys-0.8: Order alphabetically.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Herman Rimm
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote 23 hours ago
(address . guix-patches@gnu.org)
e0506531f3e0bba254f6695c2ea5c51d1a172a0f.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-botan-sys-0.8): Order.

Change-Id: Iefd5f215a140433a85932c1b95a470c8fc2547c8
---
gnu/packages/crates-crypto.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 51c24d3de6..02607ed51a 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1040,22 +1040,6 @@ (define-public rust-botan-sys-0.10
(description "FFI wrapper for Botan cryptography library")
(license license:expat)))
-(define-public rust-botan-sys-0.8
- (package
- (inherit rust-botan-sys-0.10)
- (name "rust-botan-sys")
- (version "0.8.1")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-sys" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1m11zblxfanrhl97j7z3ap7n17rr8j0rg91sr7f9j6y2bsniaz1x"))))
- (arguments
- `(#:cargo-inputs
- (("rust-botan-src" ,rust-botan-src-0.21703)
- ("rust-cty" ,rust-cty-0.2))))))
-
(define-public rust-botan-src-0.30101
(package
(name "rust-botan-src")
@@ -1093,6 +1077,22 @@ (define-public rust-botan-src-0.21703
(snippet
'(begin (delete-file-recursively "botan")))))))
+(define-public rust-botan-sys-0.8
+ (package
+ (inherit rust-botan-sys-0.10)
+ (name "rust-botan-sys")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "botan-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1m11zblxfanrhl97j7z3ap7n17rr8j0rg91sr7f9j6y2bsniaz1x"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-botan-src" ,rust-botan-src-0.21703)
+ ("rust-cty" ,rust-cty-0.2))))))
+
(define-public rust-c2-chacha-0.2
(package
(name "rust-c2-chacha")

base-commit: e793fbbd5282713fe5c9aad512c5784b0afff175
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 2/8] gnu: rust-botan-sys-0.10: Order alphabetically.
(address . 75059@debbugs.gnu.org)
938742526337e2d0b7a6cd738c213c10dfa3999b.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-botan-sys-0.10): Order.

Change-Id: I4b20c3e961dfc51182467580aeca7e10bda843bc
---
gnu/packages/crates-crypto.scm | 40 +++++++++++++++++-----------------
1 file changed, 20 insertions(+), 20 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 02607ed51a..09efb5df08 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1020,26 +1020,6 @@ (define-public rust-botan-0.8
("rust-cstr-core" ,rust-cstr-core-0.2)
("rust-cty" ,rust-cty-0.2))))))
-(define-public rust-botan-sys-0.10
- (package
- (name "rust-botan-sys")
- (version "0.10.5")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "botan-sys" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1ji12rxvi4h7pap772cd2hw4xdgqdsgw6m8wqin9klpbp3hxsjcz"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-botan-src" ,rust-botan-src-0.30101))))
- (inputs (list botan))
- (home-page "https://botan.randombit.net/")
- (synopsis "FFI wrapper for Botan cryptography library")
- (description "FFI wrapper for Botan cryptography library")
- (license license:expat)))
-
(define-public rust-botan-src-0.30101
(package
(name "rust-botan-src")
@@ -1077,6 +1057,26 @@ (define-public rust-botan-src-0.21703
(snippet
'(begin (delete-file-recursively "botan")))))))
+(define-public rust-botan-sys-0.10
+ (package
+ (name "rust-botan-sys")
+ (version "0.10.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "botan-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ji12rxvi4h7pap772cd2hw4xdgqdsgw6m8wqin9klpbp3hxsjcz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-botan-src" ,rust-botan-src-0.30101))))
+ (inputs (list botan))
+ (home-page "https://botan.randombit.net/")
+ (synopsis "FFI wrapper for Botan cryptography library")
+ (description "FFI wrapper for Botan cryptography library")
+ (license license:expat)))
+
(define-public rust-botan-sys-0.8
(package
(inherit rust-botan-sys-0.10)
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 3/8] gnu: rust-crypto-secretbox-0.1: Order alphabetically.
(address . 75059@debbugs.gnu.org)
08ee56a00599a80954bccbc259040bd1016ba26e.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-crypto-secretbox-0.1): Order.

Change-Id: I0db40723d730fbbec6402c63fde62bb2eec11571
---
gnu/packages/crates-crypto.scm | 63 +++++++++++++++++-----------------
1 file changed, 31 insertions(+), 32 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 09efb5df08..ba172fb268 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1462,38 +1462,6 @@ (define-public rust-cmac-0.7
Cipher-based Message Authentication Code.")
(license (list license:expat license:asl2.0))))
-(define-public rust-crypto-secretbox-0.1
- (package
- (name "rust-crypto-secretbox")
- (version "0.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "crypto_secretbox" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1qa1w5s8dbyb88269zrmvbnillqahz394pl07bsds6gpmn3wzmmr"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-aead" ,rust-aead-0.5)
- ("rust-chacha20" ,rust-chacha20-0.9)
- ("rust-cipher" ,rust-cipher-0.4)
- ("rust-generic-array" ,rust-generic-array-0.14)
- ("rust-poly1305" ,rust-poly1305-0.8)
- ("rust-salsa20" ,rust-salsa20-0.10)
- ("rust-subtle" ,rust-subtle-2)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.4))))
- (home-page
- "https://github.com/RustCrypto/nacl-compat/tree/master/crypto_secretbox")
- (synopsis
- "Pure Rust implementation of the XSalsa20Poly1305")
- (description
- "Pure Rust implementation of the XSalsa20Poly1305 (a.k.a. @code{NaCl}
-crypto_secretbox) authenticated encryption cipher as well as the libsodium
-variant of X@code{ChaCha20Poly1305}.")
- (license (list license:asl2.0 license:expat))))
-
(define-public rust-crypto-bigint-0.5
(package
(name "rust-crypto-bigint")
@@ -1745,6 +1713,37 @@ (define-public rust-crypto-mac-0.4
;; There are no non-yanked versions of this semver.
(deprecated-package "rust-crypto-mac" rust-crypto-mac-0.4.0-yanked))
+(define-public rust-crypto-secretbox-0.1
+ (package
+ (name "rust-crypto-secretbox")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto_secretbox" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qa1w5s8dbyb88269zrmvbnillqahz394pl07bsds6gpmn3wzmmr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-aead" ,rust-aead-0.5)
+ ("rust-chacha20" ,rust-chacha20-0.9)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-poly1305" ,rust-poly1305-0.8)
+ ("rust-salsa20" ,rust-salsa20-0.10)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.4))))
+ (home-page
+ "https://github.com/RustCrypto/nacl-compat/tree/master/crypto_secretbox")
+ (synopsis
+ "Pure Rust implementation of the XSalsa20Poly1305")
+ (description
+ "Pure Rust implementation of the XSalsa20Poly1305 (a.k.a. @code{NaCl}
+crypto_secretbox) authenticated encryption cipher as well as the libsodium
+variant of X@code{ChaCha20Poly1305}.")
+ (license (list license:asl2.0 license:expat))))
(define-public rust-crypto-tests-0.5
(package
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 4/8] gnu: rust-crypto-hash-0.3: Order alphabetically.
(address . 75059@debbugs.gnu.org)
5ae33cd6d6f0e7ceb6a041115231ccf774385f58.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-crypto-hash-0.3): Order.

Change-Id: I3d897f8fa9462e4b9d4150349181a03d0952151a
---
gnu/packages/crates-crypto.scm | 56 +++++++++++++++++-----------------
1 file changed, 28 insertions(+), 28 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index ba172fb268..960a8b40bb 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1601,6 +1601,34 @@ (define-public rust-crypto-common-0.1
;; The user can choose either license.
(license (list license:expat license:asl2.0))))
+(define-public rust-crypto-hash-0.3
+ (package
+ (name "rust-crypto-hash")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-hash" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jnxgpk0j29hzcv42viq5dckyfjnxdjsar55366j95zx80i1cxwa"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-commoncrypto" ,rust-commoncrypto-0.2)
+ ("rust-hex" ,rust-hex-0.3)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (inputs
+ (list openssl))
+ (home-page "https://github.com/malept/crypto-hash")
+ (synopsis "Wrapper for OS-level cryptographic hash functions")
+ (description "This package provides a wrapper for OS-level cryptographic
+hash functions.")
+ (license license:expat)))
+
(define-public rust-crypto-mac-0.11
(package
(name "rust-crypto-mac")
@@ -1770,34 +1798,6 @@ (define-public rust-crypto-tests-0.5
algorithms.")
(license (list license:expat license:asl2.0))))
-(define-public rust-crypto-hash-0.3
- (package
- (name "rust-crypto-hash")
- (version "0.3.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "crypto-hash" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1jnxgpk0j29hzcv42viq5dckyfjnxdjsar55366j95zx80i1cxwa"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-commoncrypto" ,rust-commoncrypto-0.2)
- ("rust-hex" ,rust-hex-0.3)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-winapi" ,rust-winapi-0.3))))
- (inputs
- (list openssl))
- (home-page "https://github.com/malept/crypto-hash")
- (synopsis "Wrapper for OS-level cryptographic hash functions")
- (description "This package provides a wrapper for OS-level cryptographic
-hash functions.")
- (license license:expat)))
-
(define-public rust-csrf-0.4
(package
(name "rust-csrf")
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 5/8] gnu: rust-pem-rfc7468-0.7: Order alphabetically.
(address . 75059@debbugs.gnu.org)
f6ba6a6d9b560a4f3d96b86d785caaaecdc7caea.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-pem-rfc7468-0.7): Order.

Change-Id: I62fd0ed20333fff63fbd77be1e56a2e265720efd
---
gnu/packages/crates-crypto.scm | 50 +++++++++++++++++-----------------
1 file changed, 25 insertions(+), 25 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 960a8b40bb..623a6d993c 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3587,6 +3587,31 @@ (define-public rust-pbkdf2-0.8
("rust-sha-1" ,rust-sha-1-0.9)
("rust-sha2" ,rust-sha2-0.9))))))
+(define-public rust-pem-rfc7468-0.7
+ (package
+ (name "rust-pem-rfc7468")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "pem-rfc7468" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04l4852scl4zdva31c1z6jafbak0ni5pi0j38ml108zwzjdrrcw8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))
+ (home-page "https://github.com/RustCrypto/formats/tree/master/pem-rfc7468")
+ (synopsis
+ "PEM Encoding implementing a subset of Privacy-Enhanced Mail encoding")
+ (description
+ "This package provides PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS
+Structures, implementing a strict subset of the original Privacy-Enhanced Mail
+encoding intended specifically for use with cryptographic keys, certificates,
+and other messages. It provides a no_std-friendly, constant-time
+implementation suitable for use with cryptographic private keys.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-pkcs1-0.7
(package
(name "rust-pkcs1")
@@ -3889,31 +3914,6 @@ (define-public rust-pkcs8-0.7
("rust-spki" ,rust-spki-0.4)
("rust-zeroize" ,rust-zeroize-1))))))
-(define-public rust-pem-rfc7468-0.7
- (package
- (name "rust-pem-rfc7468")
- (version "0.7.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "pem-rfc7468" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "04l4852scl4zdva31c1z6jafbak0ni5pi0j38ml108zwzjdrrcw8"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))
- (home-page "https://github.com/RustCrypto/formats/tree/master/pem-rfc7468")
- (synopsis
- "PEM Encoding implementing a subset of Privacy-Enhanced Mail encoding")
- (description
- "This package provides PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS
-Structures, implementing a strict subset of the original Privacy-Enhanced Mail
-encoding intended specifically for use with cryptographic keys, certificates,
-and other messages. It provides a no_std-friendly, constant-time
-implementation suitable for use with cryptographic private keys.")
- (license (list license:asl2.0 license:expat))))
-
(define-public rust-pem-rfc7468-0.6
(package
(inherit rust-pem-rfc7468-0.7)
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 6/8] gnu: rust-pem-rfc7468-0.6: Order alphabetically.
(address . 75059@debbugs.gnu.org)
5ca67ba4b94fdba48cd71dae841e078178d8deee.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-pem-rfc7468-0.6): Order.

Change-Id: I0707ae0912aa5a92b5943fcc1ef8dec2037592ec
---
gnu/packages/crates-crypto.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 623a6d993c..ae76a3248e 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3612,6 +3612,21 @@ (define-public rust-pem-rfc7468-0.7
implementation suitable for use with cryptographic private keys.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-pem-rfc7468-0.6
+ (package
+ (inherit rust-pem-rfc7468-0.7)
+ (name "rust-pem-rfc7468")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "pem-rfc7468" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b5d8rvc4lgwxhs72m99fnrg0wq7bqh4x4wq0c7501ci7a1mkl94"))))
+ (arguments
+ `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+
(define-public rust-pkcs1-0.7
(package
(name "rust-pkcs1")
@@ -3914,21 +3929,6 @@ (define-public rust-pkcs8-0.7
("rust-spki" ,rust-spki-0.4)
("rust-zeroize" ,rust-zeroize-1))))))
-(define-public rust-pem-rfc7468-0.6
- (package
- (inherit rust-pem-rfc7468-0.7)
- (name "rust-pem-rfc7468")
- (version "0.6.0")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "pem-rfc7468" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1b5d8rvc4lgwxhs72m99fnrg0wq7bqh4x4wq0c7501ci7a1mkl94"))))
- (arguments
- `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
-
(define-public rust-pem-rfc7468-0.3
(package
(inherit rust-pem-rfc7468-0.7)
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 7/8] gnu: rust-pem-rfc7468-0.3: Order alphabetically.
(address . 75059@debbugs.gnu.org)
a8895cdd21b13c59a439b55bd08c4622671f49f6.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-pem-rfc7468-0.3): Order.

Change-Id: I22fce2d5304ff5eee1d1a0899b4f4e48eedb8d8a
---
gnu/packages/crates-crypto.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index ae76a3248e..4e8509ea76 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3627,6 +3627,21 @@ (define-public rust-pem-rfc7468-0.6
(arguments
`(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+(define-public rust-pem-rfc7468-0.3
+ (package
+ (inherit rust-pem-rfc7468-0.7)
+ (name "rust-pem-rfc7468")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pem-rfc7468" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0c7vrrksg8fqzxb7q4clzl14f0qnqky7jqspjqi4pailiybmvph1"))))
+ (arguments
+ `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+
(define-public rust-pkcs1-0.7
(package
(name "rust-pkcs1")
@@ -3929,21 +3944,6 @@ (define-public rust-pkcs8-0.7
("rust-spki" ,rust-spki-0.4)
("rust-zeroize" ,rust-zeroize-1))))))
-(define-public rust-pem-rfc7468-0.3
- (package
- (inherit rust-pem-rfc7468-0.7)
- (name "rust-pem-rfc7468")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "pem-rfc7468" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0c7vrrksg8fqzxb7q4clzl14f0qnqky7jqspjqi4pailiybmvph1"))))
- (arguments
- `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
-
(define-public rust-pem-rfc7468-0.2
(package
(inherit rust-pem-rfc7468-0.7)
--
2.45.2
H
H
Herman Rimm wrote 23 hours ago
[PATCH rust-team 8/8] gnu: rust-pem-rfc7468-0.2: Order alphabetically.
(address . 75059@debbugs.gnu.org)
112829b31334df376f2bdb80bcdcf27538dc487b.1735033899.git.herman@rimm.ee
* gnu/packages/crates-crypto.scm (rust-pem-rfc7468-0.2): Order.

Change-Id: Ic132f5d3c482c504c1570f4118855269811d6c4d
---
gnu/packages/crates-crypto.scm | 44 +++++++++++++++++-----------------
1 file changed, 22 insertions(+), 22 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 4e8509ea76..ef9f295486 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3642,6 +3642,28 @@ (define-public rust-pem-rfc7468-0.3
(arguments
`(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+(define-public rust-pem-rfc7468-0.2
+ (package
+ (inherit rust-pem-rfc7468-0.7)
+ (name "rust-pem-rfc7468")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pem-rfc7468" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1m1c9jypydzabg4yscplmvff7pdcc8gg4cqg081hnlf03hxkmsc4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "Cargo.toml"
+ (((string-append ">=([[:digit:]]+(\\.[[:digit:]]+)*),"
+ " <([[:digit:]]+(\\.[[:digit:]]+)*)")
+ _ version _)
+ (string-append ">=" version)))))))
+ (arguments
+ `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
+
(define-public rust-pkcs1-0.7
(package
(name "rust-pkcs1")
@@ -3944,28 +3966,6 @@ (define-public rust-pkcs8-0.7
("rust-spki" ,rust-spki-0.4)
("rust-zeroize" ,rust-zeroize-1))))))
-(define-public rust-pem-rfc7468-0.2
- (package
- (inherit rust-pem-rfc7468-0.7)
- (name "rust-pem-rfc7468")
- (version "0.2.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "pem-rfc7468" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1m1c9jypydzabg4yscplmvff7pdcc8gg4cqg081hnlf03hxkmsc4"))
- (modules '((guix build utils)))
- (snippet
- '(begin (substitute* "Cargo.toml"
- (((string-append ">=([[:digit:]]+(\\.[[:digit:]]+)*),"
- " <([[:digit:]]+(\\.[[:digit:]]+)*)")
- _ version _)
- (string-append ">=" version)))))))
- (arguments
- `(#:cargo-inputs (("rust-base64ct" ,rust-base64ct-1))))))
-
(define-public rust-poly1305-0.8
(package
(name "rust-poly1305")
--
2.45.2
E
E
Efraim Flashner wrote 21 hours ago
Re: [bug#75059] [PATCH rust-team 1/8] gnu: rust-botan-sys-0.8: Order alphabetically.
(name . Herman Rimm)(address . herman@rimm.ee)(address . 75059-done@debbugs.gnu.org)
Z2qiiX4hvS_GS_eG@3900XT
Thanks. Patches pushed to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmdqoogACgkQQarn3Mo9
g1EIdQ/+PJ5Y0XbOSRK3BuTIjW1/5abB0V5XdAT8ciz3xqMB5mnYkICBJdK4ug1E
t/RMjADmG2hqUQ+FBwRTZAVf9BUvU1W0Mp/kCg+ijnFjfZUN6Wp1AQr5MhEoO6cJ
NqPc7Kg+xDF2wtmTwU+zo9w3TntOZn2KvDAIil8JgYJeyyCRHB5PvDZbru9BBzNx
hUBxIKjABU33K3wMRRzzlH+ppcycz9qNNy2c37Xl6WHMQGATrYfVmGGwy27ItcP4
D+sixQAf5fQ+6gLQLesNyn/fTMAXayyBADJChwLHQDkMSLKAP7yyJ62NXCnWIuxd
TDWf12gcyKa1ZnVpQai/+zOO6bZF05X15hvRPHuSX7/pnowFoQBZrQQ7CRDee9mg
jjjhlfb0mp87xwzz40s/ddl9CR6tPCgw4IPkTV4O293UTWrT6w7+t68Morwb4rU5
/ergtcFv9y/it9+ljQb5It3gVHPRDSmtaPuwcGiGv+zIfZB5c9au/vJb5BG1x9mH
Dl5ZntOIuJV6UQUuMFfpRu4jnBsa8DC5RmNWOY/IQgk2WVTYI427cj2iaDKZ0BVo
vBpPD8y42oNU7PWVW0+OW9/L3csNcPIh3tJ2thHliElrZLbF54XaiIuZVsE1NEHF
bmoOhTAtVC/uNS3RIlkygivcDI7i1pkd/lOGgADUncO/NZLymB4=
=nXfw
-----END PGP SIGNATURE-----


Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75059@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75059
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch