[PATCH] gnu: capypdf: Update to 0.14.0.

  • Open
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote 37 hours ago
(address . guix-patches@gnu.org)
bb940ab31dd7d29c1829f7fa2c0ae61bac1ebfbd.1734986120.git.liliana.prikler@gmail.com
* gnu/packages/pdf.scm (capypdf): Update to 0.14.0.
[#:phases]: Remove ‘fix-glib-application-flags’.
[inputs]: Remove fmt.
[native-inputs]: Replace gcc-12 with gcc-14.
---
gnu/packages/pdf.scm | 19 +++++--------------
1 file changed, 5 insertions(+), 14 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index f7cd19b974..f4c7dce81a 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -124,7 +124,7 @@ (define-module (gnu packages pdf)
(define-public capypdf
(package
(name "capypdf")
- (version "0.8.0")
+ (version "0.14.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -132,28 +132,19 @@ (define-public capypdf
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0kp1dcww5zl04wnbqbi8vjzpc5qgr8gr8rcx0s6s4xbjnzvqqw8d"))))
+ (base32 "05rpicxw76z4q48ax0dx5rm1k4lhp4lbdr2aw58kly402w8kjdwb"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags #~(list "-Dcpp_std=c++23")
- #:test-options '(list "plainc")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-glib-application-flags
- (lambda _
- ;; XXX: remove when bumping glib
- (substitute* "src/pdfviewer.cpp"
- (("G_APPLICATION_DEFAULT_FLAGS")
- "G_APPLICATION_FLAGS_NONE")))))))
- (inputs (list fmt
- freetype
+ #:test-options '(list "plainc")))
+ (inputs (list freetype
gtk
lcms
libjpeg-turbo
libpng
zlib))
(native-inputs (list font-google-noto
- gcc-12
+ gcc-14 ; for std::format
ghostscript
pkg-config
python

base-commit: 1ca065fe68d68a2fa9c3d747f23fd11c8ecfd85b
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75054@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75054
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch