[PATCH 00/13] Add more SageMath packages

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote 11 hours ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1734887844.git.monego@posteo.net
Some of the patches have been rebased and updated from https://issues.guix.gnu.org/56729


After this series is merged, these will be the missing non-optional packages from the above page:

- elliptic-curves
- gnumake-tokenpool (v0.0.7+ needs Python 3.11+)
- jmol
- jupyter-jsmol
- jupyter-lsp (depends on newer webcolors package)
- jupyterlab (depends on newer webcolors package)
- jupyterlab-mathjax2 (depends on jupyterlab)
- pari-seadata-small
- pplpy-doc
- sage-conf
- sage-docbuild
- sage-setup
- sagenb-export
- sagetex
- threejs

I think we can start to package sagelib after elliptic-curves and pari-seadata-small are packaged.

Vinicius Monego (6):
gnu: Add sagemath-data-conway-polynomials.
gnu: Add python-pytz-deprecation-shim.
gnu: Add python-lrcalc.
gnu: Add sympow.
gnu: Add gfan.
gnu: Add python-sphinx-inline-tabs.

vicvbcun (7):
gnu: Add sagemath-data-polytopes-db.
gnu: Add sagemath-data-graphs.
gnu: Add sagemath-data-combinatorial-designs.
gnu: Add palp.
gnu: Add tachyon.
gnu: pari-gp: Use G-Expressions.
gnu: pari-gp: Install galdata.

gnu/packages/algebra.scm | 63 ++++++++++++++++++-----
gnu/packages/graphics.scm | 59 +++++++++++++++++++++
gnu/packages/maths.scm | 105 +++++++++++++++++++++++++++++++++++++-
gnu/packages/sagemath.scm | 95 ++++++++++++++++++++++++++++++++++
gnu/packages/sphinx.scm | 23 ++++++++-
gnu/packages/time.scm | 26 ++++++++++
6 files changed, 356 insertions(+), 15 deletions(-)


base-commit: da94cd1ea69559a80d291c6a574b0f23e30c64f2
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 01/13] gnu: Add sagemath-data-conway-polynomials.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
f9a1601770443c87357b859e6d3a37f6d614974b.1734887844.git.monego@posteo.net
* gnu/packages/sagemath.scm (sagemath-data-conway-polynomials): New variable.

Change-Id: Ia3a087b19a0ade5d927422bd365283d209df0863
---
gnu/packages/sagemath.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 008f54a5e7..734aabf739 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -381,3 +381,24 @@ (define-public zn-poly
coefficients of which are modular integers.")
(license (list license:gpl2 license:gpl3)) ; dual licensed
(home-page "https://gitlab.com/sagemath/zn_poly")))
+
+(define-public sagemath-data-conway-polynomials
+ (package
+ (name "sagemath-data-conway-polynomials")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "conway_polynomials" version))
+ (sha256
+ (base32 "1wz03a08kwlswx1pcr5d99ppmhpfzs2a5i969rnb2ghsz1j9yqag"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://github.com/sagemath/conway-polynomials")
+ (synopsis "Python interface to Frank Lübeck's Conway polynomial database")
+ (description "This package provides a Python interface to Frank Lübeck's
+Conway polynomial database. These are used in several computer algebra
+systems such as GAP and SageMath to provide quick access to those Conway
+polynomials. The aim of this package is to make them available through a
+generic Python interface.")
+ (license license:gpl3+)))
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 02/13] gnu: Add sagemath-data-polytopes-db.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
ff38822d5d2c0e62deb24dc867753e1359d4b183.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/sagemath.scm (sagemath-data-polytopes-db): New variable.

Change-Id: I8dd6cbd0b71a01d817486882bec8f126dece7e36
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: Iada71a7939e5deadf6888af6c21621e5458622d1
---
gnu/packages/sagemath.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 734aabf739..1fefb26e36 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -23,6 +23,7 @@
(define-module (gnu packages sagemath)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
@@ -402,3 +403,25 @@ (define-public sagemath-data-conway-polynomials
polynomials. The aim of this package is to make them available through a
generic Python interface.")
(license license:gpl3+)))
+
+(define-public sagemath-data-polytopes-db
+ (package
+ (name "sagemath-data-polytopes-db")
+ (version "20170220")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://mirrors.mit.edu/sage/spkg/upstream/polytopes_db"
+ "/polytopes_db-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1q0cd811ilhax4dsj9y5p7z8prlalqr7k9mzq178c03frbgqny6b"))))
+ (build-system copy-build-system)
+ (arguments '(#:install-plan '(("." "share/reflexive_polytopes"))))
+ (home-page "https://www.sagemath.org")
+ (synopsis "Lists of 2- and 3-dimensional reflexive polytopes")
+ (description
+ "This package contains data for 2- and 3-dimensional reflexive polytopes
+to be used by SageMath.")
+ ;; Debian says GPLv2+.
+ (license license:gpl2+)))
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 03/13] gnu: Add sagemath-data-graphs.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
9cef798a5b06557a35346e56185871c27559d5db.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/sagemath.scm (sagemath-data-graphs): New variable.

Change-Id: I7c537aac21f43a8712fd6d542551f78c3ebaec68
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I88f35ccf94cfe0d866ef57cb893844c8285d5138
---
gnu/packages/sagemath.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 1fefb26e36..514af19da8 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -425,3 +425,27 @@ (define-public sagemath-data-polytopes-db
to be used by SageMath.")
;; Debian says GPLv2+.
(license license:gpl2+)))
+
+(define-public sagemath-data-graphs
+ (package
+ (name "sagemath-data-graphs")
+ (version "20210214")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://mirrors.mit.edu/sage/spkg/upstream/"
+ "graphs/graphs-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0h9p5wrxips51x6vpfiiaqzp9j004nwppzc9qc2iaqakk06pq8q7"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("." "share/graphs"))))
+ (home-page "https://www.sagemath.org")
+ (synopsis "Database of graphs")
+ (description
+ "This package contains databases of graphs. It also includes the
+@acronym{ISGCI, Information System on Graph Classes and their Inclusions}
+database.")
+ ;; Debian says GPLv2+.
+ (license license:gpl2+)))
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 04/13] gnu: Add sagemath-data-combinatorial-designs.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
6ad05b5f086fc069f6d1a36ee99e92f9f080297b.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/sagemath.scm (sagemath-data-combinatorial-designs): New
variable.

Change-Id: Ib1ad3675256be1958427cd37a76bb5bdbf16fd12
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I758e22fabcc11ca0583ab899acc0c653a35c7f43
---
gnu/packages/sagemath.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 514af19da8..d1cba8dcdb 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -449,3 +449,30 @@ (define-public sagemath-data-graphs
database.")
;; Debian says GPLv2+.
(license license:gpl2+)))
+
+(define-public sagemath-data-combinatorial-designs
+ (package
+ (name "sagemath-data-combinatorial-designs")
+ (version "20140630")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://mirrors.mit.edu/sage/spkg/upstream/"
+ "combinatorial_designs/combinatorial_designs-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0bj8ngiq59hipa6izi6g5ph5akmy4cbk0vlsb0wa67f7grnnqj69"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("." "share/combinatorial_designs/"))))
+ (home-page "https://www.sagemath.org")
+ (synopsis "Data for Combinatorial Designs")
+ (description
+ "This package data for combinatorial designs. It currently contains:
+
+@itemize
+@item The table of @acronym{MOLS, Mutually orthogonal Latin squares} from the
+Handbook of Combinatorial Designs, 2ed.
+@end itemize")
+ (license license:public-domain)))
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 05/13] gnu: Add python-pytz-deprecation-shim.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
e47a4a7c0445f5755d801871c8bb74c0686f20ec.1734887844.git.monego@posteo.net
* gnu/packages/time.scm (python-pytz-deprecation-shim): New variable.

Change-Id: I481ea9818444d9a14efcf7b11d44c68a5f2fec3f
---
gnu/packages/time.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index f1aeae7340..0d84dee178 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,6 +170,31 @@ (define-public python-tzdata
(description "This package provides a thin Python wrapper around tzdata.")
(license asl2.0)))
+(define-public python-pytz-deprecation-shim
+ (package
+ (name "python-pytz-deprecation-shim")
+ (version "0.1.0.post0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytz_deprecation_shim" version))
+ (sha256
+ (base32 "17d58msbi18dc4lk29hcrgylvrv9vhniwi24axfdwvb13fp7n2dg"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-dateutil python-tzdata))
+ (native-inputs (list python-pytest
+ python-pytz
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/pganssle/pytz-deprecation-shim")
+ (synopsis "Shims to make deprecation of pytz easier")
+ (description
+ "This package aims to make the transition away from @code{pytz} easier.
+It is intended for temporary usage only, and should allow you to drop your
+dependency on @code{pytz} while also giving your users notice that eventually
+you will remove support for the pytz-specific interface.")
+ (license asl2.0)))
+
(define-public python-pytz
(package
(name "python-pytz")
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 07/13] gnu: Add sympow.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
e4c2c1ee3245e81d55c1e820460f8e318424ed74.1734887844.git.monego@posteo.net
* gnu/packages/maths.scm (sympow): New variable.

Change-Id: Iaeaea352f0a3a65a877b2845ecdc18856ded6d3c
---
gnu/packages/maths.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f3265423b4..1ca0144bfd 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -158,6 +158,7 @@ (define-module (gnu packages maths)
#:use-module (gnu packages gl)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages m4)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -898,6 +899,40 @@ (define-public 4ti2
integer programming problems and computes Markov bases for statistics.")
(license license:gpl2+)))
+(define-public sympow
+ (package
+ (name "sympow")
+ (version "2.023.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/rezozer/forks/sympow")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ilnxygkj4g5arjiyd16k00cvnjlqs0cpc8hk64kbqhl877mm5i9"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Configure"
+ (("/bin/sh") (search-input-file inputs "/bin/bash")))
+ (setenv "PREFIX" #$output)
+ (setenv "VARPREFIX" #$output)
+ (invoke "bash" "./Configure"))))))
+ (native-inputs (list bash-minimal coreutils help2man pari-gp which))
+ (home-page "https://gitlab.com/rezozer/forks/sympow")
+ (synopsis "Symmetric power elliptic curve L-functions")
+ (description "SYMPOW is a mathematical program to compute special values
+of symmetric power elliptic curve L-functions; it can compute up to about 64
+digits of precision.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public cddlib
(package
(name "cddlib")
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 06/13] gnu: Add python-lrcalc.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
21fe7f7b84fe92284eee4d3c2ab282e425d15b64.1734887844.git.monego@posteo.net
* gnu/packages/algebra.scm (python-lrcalc): New variable.

Change-Id: Id174ecfa092786ca16fbde2be68e12af0b2d9af3
---
gnu/packages/algebra.scm | 28 ++++++++++++++++++++++++++--
1 file changed, 26 insertions(+), 2 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3f73d9295d..4d7b4001cd 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -59,6 +59,7 @@ (define-module (gnu packages algebra)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
@@ -72,6 +73,7 @@ (define-module (gnu packages algebra)
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system r)
#:use-module (guix download)
@@ -1623,6 +1625,28 @@ (define-public lrcalc
(license license:gpl2+)
(home-page "https://sites.math.rutgers.edu/~asbuch/lrcalc/")))
+(define-public python-lrcalc
+ (package
+ (name "python-lrcalc")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lrcalc" version))
+ (sha256
+ (base32 "1adassfjalsdsngy01c37835qsx3gj0jx9cinc9b91x4xnd51873"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (native-inputs (list python-cython python-setuptools python-wheel))
+ (inputs (list lrcalc))
+ (home-page "https://math.rutgers.edu/~asbuch/lrcalc")
+ (synopsis "Python bindings for the Littlewood-Richardson Calculator")
+ (description
+ "This package provides Python bindings for the Littlewood-Richardson
+Calculator.")
+ (license license:gpl3+)))
+
(define-public iml
(package
(name "iml")
@@ -1638,8 +1662,8 @@ (define-public iml
(build-system gnu-build-system)
(inputs
`(("gmp" ,gmp)
- ("cblas" ,openblas))) ; or any other BLAS library; the documentation
- ; mentions ATLAS in particular
+ ("cblas" ,openblas))) ; or any other BLAS library; the documentation
+ ; mentions ATLAS in particular
(arguments
`(#:configure-flags
(list
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 08/13] gnu: Add gfan.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
2b0d2dfda499f32262d84298cea872ea62ab0b4c.1734887844.git.monego@posteo.net
* gnu/packages/maths.scm (gfan): New variable.

Change-Id: I3b4952ddfcaecac17ab29bb3cd2f56fc125ab763
---
gnu/packages/maths.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1ca0144bfd..35de236ba2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -871,6 +871,41 @@ (define-public linasm
and much more.")
(license license:lgpl3+)))
+(define-public gfan
+ (package
+ (name "gfan")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://users-math.au.dk/jensen/software"
+ "/gfan/gfan" version ".tar.gz"))
+ (sha256
+ (base32 "17lqripnsdb5hn7nnhgn4siajgh1jh9nkaplca3akm74w5bkg0xb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "CXX=" #$(cxx-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ ;; cddlib is distributed with the 'cddlib' header name,
+ ;; but gfan expects it to be named 'cdd'. Substitute
+ ;; the include headers to make gfan find it.
+ (add-after 'unpack 'fix-cdd-reference
+ (lambda _
+ (substitute* '("src/lp_cdd.cpp"
+ "src/gfanlib_zcone.cpp"
+ "src/app_librarytest.cpp")
+ (("#include \"cdd") "#include \"cddlib")))))))
+ (inputs (list cddlib gmp))
+ (home-page "https://users-math.au.dk/jensen/software/gfan/gfan.html")
+ (synopsis "Compute Gröbner fans and tropical varieties")
+ (description "Gfan is a software package for computing Gröbner fans and
+tropical varieties.")
+ (license license:gpl2)))
+
(define-public 4ti2
(package
(name "4ti2")
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 09/13] gnu: Add palp.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
e6a978a83ce83868be007b35288065e9458b20af.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/maths.scm (palp): New variable.

Change-Id: I37ee870858fef505999dfdc02d1955673366d718
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I853cbccca5c34355d9df74a3cbbd5f818a21ebb5
---
gnu/packages/maths.scm | 35 +++++++++++++++++++++++++++++++++--
1 file changed, 33 insertions(+), 2 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 35de236ba2..e89c17a2c0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5573,6 +5573,37 @@ (define-public libblastrampoline
library.")
(license license:expat)))
+(define-public palp
+ (package
+ (name "palp")
+ (version "2.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hep.itp.tuwien.ac.at/~kreuzer/CY/palp/palp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1myxjv0jxgr9acchwnjh9g5l61wxwiva3q6c1d6892lr37r7njky"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ; no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (for-each
+ (lambda (name)
+ (install-file name (string-append #$output "/bin")))
+ '("class.x" "cws.x" "mori.x" "nef.x" "poly.x")))))))
+ (home-page "http://hep.itp.tuwien.ac.at/~kreuzer/CY/CYpalp.html")
+ (synopsis "Package for Analyzing Lattice Polytopes")
+ (description
+ "PALP is a set of programs for calculations with lattice polytopes and
+applications to toric geometry.")
+ (license license:gpl3)))
+
(define-public blis
(package
(name "blis")
@@ -5600,9 +5631,9 @@ (define-public blis
#~(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs target system (configure-flags '())
- #:allow-other-keys)
+ #:allow-other-keys)
;; This is a home-made 'configure' script.
- (let* (;; Guix-specific support for choosing the configuration
+ (let* ( ;; Guix-specific support for choosing the configuration
;; via #:configure-flags: see below for details.
(config-flag-prefix "--blis-config=")
(maybe-config-flag (find
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 10/13] gnu: Add tachyon.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
00ea4f795d06bb82c31feec0d4ee8d31a606a287.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/graphics.scm (tachyon): New variable.

Change-Id: I57780c08c6b496e40459789d693b9b24fb4a9da8
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I5914afad8d293787b9898a229084e6c79fbe8911
---
gnu/packages/graphics.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f17511dc94..a0c22bfa35 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -789,6 +789,65 @@ (define-public openshadinglanguage
materials, lights, displacement, and pattern generation.")
(license license:bsd-3)))
+(define-public tachyon
+ (package
+ (name "tachyon")
+ (version "0.99.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://jedi.ks.uiuc.edu/~johns/raytracer/files/"
+ version "/tachyon-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xd6h5d4v6dsnm6w46bdcr15fwkcz44p8dncymfry50i4c83q809"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; no tests
+ #:make-flags #~(list "linux-thr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'prepare-src
+ (lambda _
+ (substitute* "unix/Make-arch"
+ (("CC = cc")
+ (string-append "CC = " #$(cc-for-target))))
+ (chdir "unix")))
+ (add-before 'build 'enable-png-jpeg-support
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Make-config"
+ (("USEJPEG=")
+ "USEJPEG = -DUSEJPEG")
+ (("JPEGLIB=")
+ "JPEGLIB = -ljpeg")
+ (("USEPNG=")
+ "USEPNG = -DUSEPNG")
+ (("PNGLIB=")
+ "PNGLIB = -lpng -lz"))))
+ (add-before 'build 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Make-config"
+ (("SHELL=/bin/sh")
+ (string-append "SHELL=" (which "sh"))))))
+ (replace 'install
+ (lambda _
+ (install-file "../compile/linux-thr/tachyon"
+ (string-append #$output "/bin"))
+ (install-file "../compile/linux-thr/libtachyon.a"
+ (string-append #$output "/lib")))))))
+ (inputs (list libjpeg-turbo libpng))
+ ;; The server does not seem to be reliably accessible
+ (home-page "http://jedi.ks.uiuc.edu/~johns/raytracer/")
+ (synopsis "Multithreaded ray tracing software")
+ (description
+ "This package contains the Tachyon raytracer. It supports the typical
+ray tracer features, most of the common geometric primitives, shading and
+texturing modes, etc. It also supports less common features such as HDR image
+output, ambient occlusion lighting, and support for various triangle mesh and
+volumetric texture formats beneficial for molecular visualization.")
+ (license license:bsd-3)))
+
(define-public cgal
(package
(name "cgal")
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 11/13] gnu: pari-gp: Use G-Expressions.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
b0093d7c45c83fa67852b13778b2ba5f4ca3736c.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/algebra.scm (pari-gp)[arguments]: Use G-Expressions. Unset
make-flags.

Change-Id: Id2be46acd67b474d6fdb8935070ffb243e87f920
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I7be07998e9e2d1fe9194d4af6a57537467f5e097
---
gnu/packages/algebra.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4d7b4001cd..32834f1c15 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -245,16 +245,15 @@ (define-public pari-gp
(native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
(arguments
- '(#:make-flags '("all")
- #:test-target "dobench"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "./Configure"
- "--mt=pthread"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))))
+ (list
+ #:test-target "dobench"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./Configure"
+ "--mt=pthread"
+ (string-append "--prefix=" #$output)))))))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 12/13] gnu: pari-gp: Install galdata.
(address . 75032@debbugs.gnu.org)(name . vicvbcun)(address . guix@ikherbers.com)
72ca572d7c15f31fef544aa83399c3dcdd50bc67.1734887844.git.monego@posteo.net
From: vicvbcun <guix@ikherbers.com>

* gnu/packages/algebra.scm (pari-galdata): New variable.
(pari-gp)[arguments]<#:phases>: Add phase "install-galdata".

Change-Id: Iaec77b0ab60d8ff59c8a36e7e0a7878b58742751
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: Id74aa6ce315df48a2d917baf1a436ba54b1b5185
---
gnu/packages/algebra.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 32834f1c15..5da77b6318 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -229,6 +229,16 @@ (define-public python-fpylll
(description "fpylll is a Python wrapper for fplll.")
(license license:gpl2+)))
+(define pari-galdata
+ ;; version from 2008-04-12
+ (origin
+ (method url-fetch)
+ ;; no versioning, old files seem to be moved to `old/...' on update
+ (uri "https://pari.math.u-bordeaux.fr/pub/pari/packages/galdata.tgz")
+ (sha256
+ (base32
+ "1pch6bk76f1i6cwwgm7hhxi5h71m52lqayp4mnyj0jmjk406bhdp"))))
+
(define-public pari-gp
(package
(name "pari-gp")
@@ -253,7 +263,13 @@ (define-public pari-gp
(lambda _
(invoke "./Configure"
"--mt=pthread"
- (string-append "--prefix=" #$output)))))))
+ (string-append "--prefix=" #$output))))
+ (add-after 'install 'install-galdata
+ (lambda _
+ (invoke "tar" "-xvf" #$pari-galdata)
+ (copy-recursively "data/" (string-append
+ #$output
+ "/share/pari")))))))
(synopsis "PARI/GP, a computer algebra system for number theory")
(description
"PARI/GP is a widely used computer algebra system designed for fast
--
2.39.5
V
V
Vinicius Monego wrote 11 hours ago
[PATCH 13/13] gnu: Add python-sphinx-inline-tabs.
(address . 75032@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cbd02788d39274739f293594f29a2e01a1dd630c.1734887844.git.monego@posteo.net
* gnu/packages/sphinx.scm (python-sphinx-inline-tabs): New variable.

Change-Id: I92516cdc404cdcaee74cb8cf19f255c049c43021
---
gnu/packages/sphinx.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 72f1513f34..f7f3286b7b 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
-;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021, 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
@@ -519,6 +519,27 @@ (define-public python-sphinxcontrib-newsfeed
(home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
(license license:bsd-2)))
+(define-public python-sphinx-inline-tabs
+ (package
+ (name "python-sphinx-inline-tabs")
+ (version "2023.4.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx_inline_tabs" version))
+ (sha256
+ (base32 "1g5yhdk208i8maippnbnijd1knpai809wl3cbwzqy59cc0zz3wjx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests in the release, only in the main branch
+ (native-inputs (list python-flit-core
+ python-sphinx))
+ (home-page "https://github.com/pradyunsg/sphinx-inline-tabs")
+ (synopsis "Add inline tabbed content to your Sphinx documentation")
+ (description "This package provides a Sphinx plugin to add inline tabbed
+content to your Sphinx documentation.")
+ (license license:expat)))
+
(define-public python-sphinx-issues
(package
(name "python-sphinx-issues")
--
2.39.5
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 75032@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 75032
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch