[PATCH 1/5] import: utils: Rename guix-name to downstream-package-name.

  • Done
  • quality assurance status badge
Details
3 participants
  • Herman Rimm
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal

Debbugs page

Herman Rimm wrote 3 months ago
(address . guix-patches@gnu.org)
e8e619647cf325c69d274e0ff0b49ed9115327ac.1734715617.git.herman@rimm.ee
* guix/import/cran.scm (cran-guix-name): Adjust.
* guix/import/crate.scm (crate-name->package-name): Adjust.
* guix/import/elpa.scm (elpa-guix-name): Adjust.
* guix/import/npm-binary.scm (npm-name->name): Adjust.
* guix/import/utils.scm (downstream-package-name): Add procedure.
[description]: Use definite article, uppercase 'name' argument.
(guix-name): Deprecate.

Change-Id: I374892be18fbeaae1bc051b8d0c79ca4c33ed8c4
---
guix/import/cran.scm | 2 +-
guix/import/crate.scm | 2 +-
guix/import/elpa.scm | 2 +-
guix/import/npm-binary.scm | 2 +-
guix/import/utils.scm | 8 ++++++--
5 files changed, 10 insertions(+), 6 deletions(-)

Toggle diff (95 lines)
diff --git a/guix/import/cran.scm b/guix/import/cran.scm
index fe69cb87f7..3bea9439e1 100644
--- a/guix/import/cran.scm
+++ b/guix/import/cran.scm
@@ -478,7 +478,7 @@ (define (transform-sysname sysname)
("zlib1g-dev" "zlib")
(_ sysname)))
-(define cran-guix-name (cut guix-name "r-" <>))
+(define cran-guix-name (cut downstream-package-name "r-" <>))
(define (directory-needs-fortran? dir)
"Check if the directory DIR contains Fortran source files."
diff --git a/guix/import/crate.scm b/guix/import/crate.scm
index 5996571cda..c50f0a8415 100644
--- a/guix/import/crate.scm
+++ b/guix/import/crate.scm
@@ -467,7 +467,7 @@ (define (guix-package->crate-name package)
((name _ ...) name))))
(define (crate-name->package-name name)
- (guix-name "rust-" name))
+ (downstream-package-name "rust-" name))
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index 46b6dc98a2..b86a6a546b 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -481,7 +481,7 @@ (define %elpa-updater
(pred package-from-elpa-repository?)
(import latest-release)))
-(define elpa-guix-name (cut guix-name "emacs-" <>))
+(define elpa-guix-name (cut downstream-package-name "emacs-" <>))
(define* (elpa-recursive-import package-name #:optional (repo 'gnu))
(recursive-import package-name
diff --git a/guix/import/npm-binary.scm b/guix/import/npm-binary.scm
index 6dfedc4910..92ac7d338e 100644
--- a/guix/import/npm-binary.scm
+++ b/guix/import/npm-binary.scm
@@ -178,7 +178,7 @@ (define (npm-name->name npm-name)
(define (clean name)
(string-map (lambda (chr) (if (char=? chr #\/) #\- chr))
(string-filter (negate (cut char=? <> #\@)) name)))
- (guix-name "node-" (clean npm-name)))
+ (downstream-package-name "node-" (clean npm-name)))
(define (name+version->symbol name version)
(string->symbol (string-append name "-" version)))
diff --git a/guix/import/utils.scm b/guix/import/utils.scm
index e45c8dfb20..0b1b3b3298 100644
--- a/guix/import/utils.scm
+++ b/guix/import/utils.scm
@@ -37,6 +37,7 @@ (define-module (guix import utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix discovery)
#:use-module (guix build-system)
#:use-module ((guix i18n) #:select (G_))
@@ -82,6 +83,7 @@ (define-module (guix import utils)
read-lines
chunk-lines
+ downstream-package-name
guix-name
recursive-import))
@@ -612,14 +614,16 @@ (define* (chunk-lines lines #:optional (pred string-null?))
(reverse res)
(loop (cdr after) res))))))
-(define (guix-name prefix name)
- "Return a Guix package name for a given package name."
+(define (downstream-package-name prefix name)
+ "Return the Guix package name for a given package NAME."
(string-append prefix (string-map (match-lambda
(#\_ #\-)
(#\. #\-)
(chr (char-downcase chr)))
name)))
+(define-deprecated/alias guix-name downstream-package-name)
+
(define (topological-sort nodes
node-dependencies
node-name)

base-commit: 7f91b12fe31baa0838ae2e942d4515911e71b137
--
2.45.2
Herman Rimm wrote 3 months ago
[PATCH 2/5] import: texlive: Remove guix-name.
(address . 74997@debbugs.gnu.org)
637157ea86bca3acf0dc63f243b9b0c642e4ec75.1734715617.git.herman@rimm.ee
* guix/import/texlive.scm (guix-name): Remove.
(list-upstream-inputs, tlpdb->package): Use downstream-package-name.

Change-Id: I8f04d27a42f762c5604cb8874042fabbbe1e9873
---
guix/import/texlive.scm | 14 +++-----------
1 file changed, 3 insertions(+), 11 deletions(-)

Toggle diff (41 lines)
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index 6d04cc25ee..8ce22a1d59 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -334,15 +334,6 @@ (define string->license
((lst ...) `(list ,@(map string->license lst)))
(x `(error unknown-license ,x))))
-(define (guix-name name)
- "Return a Guix package name for a given Texlive package NAME."
- (string-append "texlive-"
- (string-map (match-lambda
- (#\_ #\-)
- (#\. #\-)
- (chr (char-downcase chr)))
- name)))
-
(define* (filter-depends depends #:optional texlive-only)
"Filter upstream package names DEPENDS to include only their equivalent Guix
package names, without \"texlive-\" prefix. When TEXLIVE-ONLY is true, ignore
@@ -578,7 +569,8 @@ (define (list-upstream-inputs upstream-name version database)
(map (lambda (input-name)
(upstream-input
(name input-name)
- (downstream-name (guix-name input-name))
+ (downstream-name (downstream-package-name "texlive-"
+ input-name))
(type 'propagated)))
(sort (append
(filter-depends (or (assoc-ref package-data 'depend) '()))
@@ -655,7 +647,7 @@ (define (texlive->svn-multi-reference upstream-name version database)
(define (tlpdb->package upstream-name version database)
(and-let* ((data (assoc-ref database upstream-name))
- (name (guix-name upstream-name))
+ (name (downstream-package-name "texlive-" upstream-name))
(reference
(texlive->svn-multi-reference upstream-name version database))
(source (with-store store
--
2.45.2
Herman Rimm wrote 3 months ago
[PATCH 3/5] import: utils: Move downstream-package-name to (guix utils).
(address . 74997@debbugs.gnu.org)
22e9c6d15adb7a3dca3afb76ba2407c076b94af2.1734715617.git.herman@rimm.ee
* guix/import/elpa.scm: Import (guix utils).
* guix/import/texlive.scm: Import (guix utils).
* guix/import/utils.scm (downstream-package-name): Move to ...
* guix/utils.scm (downstream-package-name): ... here.

Change-Id: If56a452f64ed06c8bb06a96a283a5067cb54d602
---
guix/import/elpa.scm | 1 +
guix/import/texlive.scm | 1 +
guix/import/utils.scm | 9 ---------
guix/utils.scm | 9 +++++++++
4 files changed, 11 insertions(+), 9 deletions(-)

Toggle diff (80 lines)
diff --git a/guix/import/elpa.scm b/guix/import/elpa.scm
index b86a6a546b..62b1d645ac 100644
--- a/guix/import/elpa.scm
+++ b/guix/import/elpa.scm
@@ -44,6 +44,7 @@ (define-module (guix import elpa)
#:use-module (guix git)
#:use-module (guix hash)
#:use-module (guix store)
+ #:use-module ((guix utils) #:select (downstream-package-name))
#:use-module (guix base32)
#:use-module (guix upstream)
#:use-module (guix packages)
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index 8ce22a1d59..8e67d11c69 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -35,6 +35,7 @@ (define-module (guix import texlive)
#:use-module (guix store)
#:use-module (guix svn-download)
#:use-module (guix upstream)
+ #:use-module ((guix utils) #:select (downstream-package-name))
#:use-module (ice-9 ftw)
#:use-module (ice-9 match)
#:use-module (ice-9 popen)
diff --git a/guix/import/utils.scm b/guix/import/utils.scm
index 0b1b3b3298..6f5efa790e 100644
--- a/guix/import/utils.scm
+++ b/guix/import/utils.scm
@@ -83,7 +83,6 @@ (define-module (guix import utils)
read-lines
chunk-lines
- downstream-package-name
guix-name
recursive-import))
@@ -614,14 +613,6 @@ (define* (chunk-lines lines #:optional (pred string-null?))
(reverse res)
(loop (cdr after) res))))))
-(define (downstream-package-name prefix name)
- "Return the Guix package name for a given package NAME."
- (string-append prefix (string-map (match-lambda
- (#\_ #\-)
- (#\. #\-)
- (chr (char-downcase chr)))
- name)))
-
(define-deprecated/alias guix-name downstream-package-name)
(define (topological-sort nodes
diff --git a/guix/utils.scm b/guix/utils.scm
index 537d0490e0..2d82329cb7 100644
--- a/guix/utils.scm
+++ b/guix/utils.scm
@@ -91,6 +91,7 @@ (define-module (guix utils)
%current-system
%current-target-system
package-name->name+version
+ downstream-package-name
target-linux?
target-hurd?
system-hurd?
@@ -706,6 +707,14 @@ (define* (package-name->name+version spec
(idx (values (substring spec 0 idx)
(substring spec (1+ idx))))))
+(define (downstream-package-name prefix name)
+ "Return the Guix package name for a given package NAME."
+ (string-append prefix (string-map (match-lambda
+ (#\_ #\-)
+ (#\. #\-)
+ (chr (char-downcase chr)))
+ name)))
+
(define* (target-linux? #:optional (target (or (%current-target-system)
(%current-system))))
"Does the operating system of TARGET use the Linux kernel?"
--
2.45.2
Herman Rimm wrote 3 months ago
[PATCH 4/5] gnu: make-arm-trusted-firmware: Use downstream-package-name.
(address . 74997@debbugs.gnu.org)
e494e0e477473230de3ca7fbac90e1527dd081c2.1734715617.git.herman@rimm.ee
* gnu/packages/firmware.scm (make-arm-trusted-firmware): Use
downstream-package-name.
[arguments]: Remove configure phase, use fix-cross-build phase instead.
(arm-trusted-firmware-sun50i-a64): Return base package directly.

Change-Id: I23f05ac5e8e897037cd8d8afc4e747b05e56e32d
---
gnu/packages/firmware.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 89d29b8add..04f138f22c 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1108,7 +1108,7 @@ (define* (make-arm-trusted-firmware platform #:key
;;%current-system is a *triplet*, unlike its name would suggest.
(string=? (%current-system) (gnu-triplet->nix-system triplet))))
(package
- (name (string-append "arm-trusted-firmware-" platform))
+ (name (downstream-package-name "arm-trusted-firmware-" platform))
(version "2.12")
(source
(origin
@@ -1131,7 +1131,7 @@ (define* (make-arm-trusted-firmware platform #:key
#:target (and (not (native-build?)) triplet)
#:phases
#~(modify-phases %standard-phases
- (replace 'configure ;no configure script
+ (add-after 'unpack 'fix-cross-build
;; Fix ATF commit ffb7742125def3e0acca4c7e4d3215af5ce25a31
(lambda _
(unless #$(native-build?)
@@ -1140,6 +1140,7 @@ (define* (make-arm-trusted-firmware platform #:key
(substitute* "make_helpers/build_macros.mk"
(("-oc") "-oc-default")
(("-od") "-od-default")))))
+ (delete 'configure) ;no configure script
(replace 'install
(lambda _
(for-each (lambda (file)
@@ -1171,10 +1172,7 @@ (define* (make-arm-trusted-firmware platform #:key
license:bsd-2)))) ; libfdt
(define-public arm-trusted-firmware-sun50i-a64
- (let ((base (make-arm-trusted-firmware "sun50i_a64")))
- (package
- (inherit base)
- (name "arm-trusted-firmware-sun50i-a64"))))
+ (make-arm-trusted-firmware "sun50i_a64"))
(define-public arm-trusted-firmware-rk3328
(make-arm-trusted-firmware "rk3328"))
--
2.45.2
Herman Rimm wrote 3 months ago
[PATCH 5/5] gnu: u-boot: Use downstream-package-name.
(address . 74997@debbugs.gnu.org)
ba0c8099fbe7f577a7d5a6c8bc60aa5ce11a74c8.1734715617.git.herman@rimm.ee
* gnu/packages/bootloaders.scm (u-boot): Use downstream-package-name.

Change-Id: I7226519a676ba201be3a95078112b6514a201731
---
gnu/packages/bootloaders.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 3122a185dd..b5cfacca4b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1041,9 +1041,7 @@ (define*-public (make-u-boot-package board triplet
(gnu-triplet->nix-system triplet))))))
(package
(inherit u-boot)
- (name (string-append "u-boot-"
- (string-replace-substring (string-downcase board)
- "_" "-")
+ (name (string-append (downstream-package-name "u-boot-" board)
(or name-suffix "")))
(description (if append-description
(string-append (package-description u-boot)
--
2.45.2
Ludovic Courtès wrote 2 months ago
Re: [bug#74997] [PATCH 1/5] import: utils: Rename guix-name to downstream-package-name.
(name . Herman Rimm)(address . herman@rimm.ee)
87pll9s5kj.fsf@gnu.org
Applied, thanks!
Closed
Ludovic Courtès wrote 2 months ago
[PATCH 1/4] services: shepherd: Add ‘tran sient’ and ‘timer’.
(address . 74997@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
cb5e08911572a5b7a845e8120f3e7593bf8f0bab.1737152077.git.ludo@gnu.org
* gnu/services/shepherd.scm (shepherd-timer-service-type)
(shepherd-transient-service-type): New variables.
* doc/guix.texi (Shepherd Services): Document them.

Change-Id: I9b622e7e947e7a6384c2701a313d0c7080a0a5f6
---
doc/guix.texi | 33 ++++++++++++++++++++++++
gnu/services/shepherd.scm | 54 +++++++++++++++++++++++++++++++++++++--
2 files changed, 85 insertions(+), 2 deletions(-)

Toggle diff (120 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 0015d739bb..3e377ca9f4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -45684,6 +45684,39 @@ Shepherd Services
(shepherd my-shepherd))))))
@end lisp
+@cindex @code{transient} service, Shepherd
+@defvar shepherd-transient-service-type
+This service type represents the Shepherd's @code{transient} service,
+which lets you spawn commands in the background and interact with them
+as regular Shepherd service; it is similar to @command{systemd-run}.
+
+For example, the command below spawns @command{rsync} in the background,
+in an environment where the @env{SSH_AUTH_SOCK} environment variable has
+the given value:
+
+@example
+herd spawn transient -E SSH_AUTH_SOCK=$SSH_AUTH_SOCK -- \
+ rsync -e ssh -vur . backup.example.org:
+@end example
+
+@xref{Transient Service Maker,,, shepherd, The GNU Shepherd Manual}, for
+more info on the @code{transient} service.
+@end defvar
+
+@cindex @code{timer} service, Shepherd
+@defvar shepherd-timer-service-type
+This is the service type representing the Shepherd's @code{timer}
+service, which lets you schedule the execution of commands, similar to
+the venerable @command{at} command. Here is an example:
+
+@example
+herd schedule timer at 07:00 -- mpg123 Music/alarm.mp3
+@end example
+
+@xref{Timer Service,,, shepherd, The GNU Shepherd Manual}, for more info
+on the @code{timer} service.
+@end defvar
+
@defvar %shepherd-root-service
This service represents PID@tie{}1.
@end defvar
diff --git a/gnu/services/shepherd.scm b/gnu/services/shepherd.scm
index 0de3c9c55c..5f2625ac20 100644
--- a/gnu/services/shepherd.scm
+++ b/gnu/services/shepherd.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013-2016, 2018-2024 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2016, 2018-2025 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -81,6 +81,8 @@ (define-module (gnu services shepherd)
shepherd-service-upgrade
user-processes-service-type
+ shepherd-timer-service-type
+ shepherd-transient-service-type
assert-valid-graph))
@@ -668,4 +670,52 @@ (define user-processes-service-type
seconds after @code{SIGTERM} has been sent are terminated with
@code{SIGKILL}.")))
-;;; shepherd.scm ends here
+
+;;;
+;;; Timer and transient service maker.
+;;;
+
+(define shepherd-timer-service-type
+ (shepherd-service-type
+ 'shepherd-timer
+ (const (shepherd-service
+ (provision '(timer))
+ (requirement '(user-processes))
+ (modules '((shepherd service timer)))
+ (free-form #~(timer-service
+ '#$provision
+ #:requirement '#$requirement))))
+ #t ;ignored
+ (description "The Shepherd @code{timer} service lets you schedule commands
+dynamically, similar to the @code{at} command that your grandparents would use
+on that Slackware they got on a floppy disk. For example, consider this
+command:
+
+@example
+herd schedule timer at 07:00 -- mpg123 Music/alarm.mp3
+@end example
+
+It does exactly what you would expect.")))
+
+(define shepherd-transient-service-type
+ (shepherd-service-type
+ 'shepherd-transient
+ (const (shepherd-service
+ (provision '(transient))
+ (requirement '(user-processes))
+ (modules '((shepherd service transient)))
+ (free-form #~(transient-service
+ '#$provision
+ #:requirement '#$requirement))))
+ #t ;ignored
+ (description "The Shepherd @code{transient} service lets you run commands
+asynchronously, in the background, similar to @command{systemd-run}, as in
+this example:
+
+@example
+herd spawn transient -E SSH_AUTH_SOCK=$SSH_AUTH_SOCK -- \\
+ rsync -e ssh -vur . backup.example.org:
+@end example
+
+This runs @command{rsync} in the background, as a service that you can inspect
+with @command{herd status} and stop with @command{herd stop}.")))
--
2.47.1
Ludovic Courtès wrote 2 months ago
[PATCH 0/4] Adding the 'timer' and 'transient' Shepherd services
(address . 74997@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
cover.1737152077.git.ludo@gnu.org
Hello!

Shepherd party! 🐑🎉

This patch series adds the famous ‘transient’ and ‘timer’ services
from Shepherd 1.0 that everyone has been waiting for.

Thoughts?

Ludo’.

Ludovic Courtès (4):
services: shepherd: Add ‘transient’ and ‘timer’.
services: Add the Shepherd’s ‘transient’ and ‘timer’ to
‘%base-services’.
home: services: shepherd: Add ‘transient’ and ‘timer’ services.
home: services: Add ‘transient’ and ‘timer’ to ‘%base-home-services’.

doc/guix.texi | 45 +++++++++++++++++++++++++++
gnu/home.scm | 7 +++--
gnu/home/services/shepherd.scm | 21 +++++++++++--
gnu/services/base.scm | 4 +++
gnu/services/shepherd.scm | 56 ++++++++++++++++++++++++++++++++--
5 files changed, 127 insertions(+), 6 deletions(-)


base-commit: a42d57a935009e4dd9b9e9464458540def2cb576
--
2.47.1
Ludovic Courtès wrote 2 months ago
[PATCH 2/4] services: Add the Shepherd’s ‘transient’ and ‘timer’ to ‘%base-services’.
(address . 74997@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
c73d1431aac07bb2a570484089b524895eb98595.1737152077.git.ludo@gnu.org
* gnu/services/base.scm (%base-services): Add instances of
‘shepherd-timer-service-type’ and ‘shepherd-transient-service-type’.

Change-Id: I28a35d0dce40b142ee71b330b1cf7a3d222ef6bd
---
gnu/services/base.scm | 4 ++++
gnu/services/shepherd.scm | 34 ++++++++++++++++++----------------
2 files changed, 22 insertions(+), 16 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 5967457002..7331c030d7 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -3750,6 +3750,10 @@ (define %base-services
(service log-rotation-service-type)
+ ;; Convenient services brought by the Shepherd.
+ (service shepherd-timer-service-type)
+ (service shepherd-transient-service-type)
+
;; Periodically delete old build logs.
(service log-cleanup-service-type
(log-cleanup-configuration
diff --git a/gnu/services/shepherd.scm b/gnu/services/shepherd.scm
index 5f2625ac20..328bfbedff 100644
--- a/gnu/services/shepherd.scm
+++ b/gnu/services/shepherd.scm
@@ -678,14 +678,15 @@ (define user-processes-service-type
(define shepherd-timer-service-type
(shepherd-service-type
'shepherd-timer
- (const (shepherd-service
- (provision '(timer))
- (requirement '(user-processes))
- (modules '((shepherd service timer)))
- (free-form #~(timer-service
- '#$provision
- #:requirement '#$requirement))))
- #t ;ignored
+ (lambda (requirement)
+ (shepherd-service
+ (provision '(timer))
+ (requirement requirement)
+ (modules '((shepherd service timer)))
+ (free-form #~(timer-service
+ '#$provision
+ #:requirement '#$requirement))))
+ '(user-processes)
(description "The Shepherd @code{timer} service lets you schedule commands
dynamically, similar to the @code{at} command that your grandparents would use
on that Slackware they got on a floppy disk. For example, consider this
@@ -700,14 +701,15 @@ (define shepherd-timer-service-type
(define shepherd-transient-service-type
(shepherd-service-type
'shepherd-transient
- (const (shepherd-service
- (provision '(transient))
- (requirement '(user-processes))
- (modules '((shepherd service transient)))
- (free-form #~(transient-service
- '#$provision
- #:requirement '#$requirement))))
- #t ;ignored
+ (lambda (requirement)
+ (shepherd-service
+ (provision '(transient))
+ (requirement requirement)
+ (modules '((shepherd service transient)))
+ (free-form #~(transient-service
+ '#$provision
+ #:requirement '#$requirement))))
+ '(user-processes)
(description "The Shepherd @code{transient} service lets you run commands
asynchronously, in the background, similar to @command{systemd-run}, as in
this example:
--
2.47.1
Ludovic Courtès wrote 2 months ago
[PATCH 3/4] home: services: shepherd: Add ‘transient’ and ‘timer’ s ervices.
(address . 74997@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
c784469b98168a15bd551aa1b8bbf320cf452f4d.1737152077.git.ludo@gnu.org
* gnu/home/services/shepherd.scm (home-shepherd-timer-service-type)
(home-shepherd-transient-service-type): New variables.
* doc/guix.texi (Shepherd Home Service): Document them.
(Shepherd Services): Add anchor.

Change-Id: Ia4eb7cf043f4661c64f5ca81b8989a451532aa18
---
doc/guix.texi | 12 ++++++++++++
gnu/home/services/shepherd.scm | 21 +++++++++++++++++++--
2 files changed, 31 insertions(+), 2 deletions(-)

Toggle diff (75 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 3e377ca9f4..a33f2f3083 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -45684,6 +45684,7 @@ Shepherd Services
(shepherd my-shepherd))))))
@end lisp
+@anchor{shepherd-transient-timer-services}
@cindex @code{transient} service, Shepherd
@defvar shepherd-transient-service-type
This service type represents the Shepherd's @code{transient} service,
@@ -47347,6 +47348,17 @@ Shepherd Home Service
This service is part of @code{%base-home-services}.
@end defvar
+@defvar home-shepherd-transient-service-type
+@defvarx home-shepherd-timer-service-type
+These are the @code{timer} and @code{transient} Shepherd services. The
+former lets you schedule command execution for later, while the latter
+can run commands in the background as a regular service.
+
+@xref{shepherd-transient-timer-services, the system @code{timer} and
+@code{transient} services}, which are their Guix System counterparts,
+for more info.
+@end defvar
+
@node Secure Shell
@subsection Secure Shell
diff --git a/gnu/home/services/shepherd.scm b/gnu/home/services/shepherd.scm
index 37ad1489d6..b2b141d4de 100644
--- a/gnu/home/services/shepherd.scm
+++ b/gnu/home/services/shepherd.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021, 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
-;;; Copyright © 2024 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2024-2025 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +34,10 @@ (define-module (gnu home services shepherd)
home-shepherd-configuration-auto-start?
home-shepherd-configuration-daemonize?
home-shepherd-configuration-silent?
- home-shepherd-configuration-services)
+ home-shepherd-configuration-services
+
+ home-shepherd-transient-service-type
+ home-shepherd-timer-service-type)
#:re-export (shepherd-service
shepherd-service?
shepherd-service-documentation
@@ -181,3 +184,17 @@ (define home-shepherd-service-type
(define-service-type-mapping
shepherd-root-service-type => home-shepherd-service-type)
+
+;;;
+;;; Timer and transient service maker.
+;;;
+
+(define home-shepherd-timer-service-type
+ (service-type
+ (inherit (system->home-service-type shepherd-timer-service-type))
+ (default-value '()))) ;requirement
+
+(define home-shepherd-transient-service-type
+ (service-type
+ (inherit (system->home-service-type shepherd-transient-service-type))
+ (default-value '()))) ;requirement
--
2.47.1
Ludovic Courtès wrote 2 months ago
[PATCH 4/4] home: services: Add ‘transien t’ and ‘timer’ to ‘%bas e-home-services’.
(address . 74997@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
c4b557c6745a7dd90c9c25617be5ec6b2bfd1aaa.1737152078.git.ludo@gnu.org
* gnu/home.scm (%base-home-services): Add
‘home-shepherd-timer-service-type’ and
‘home-shepherd-transient-service-type’.

Change-Id: Ib48744b82c7e4c6ff6b8ac3d669774feda813f4b
---
gnu/home.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/home.scm b/gnu/home.scm
index 3b479f64f9..1172b1a0ab 100644
--- a/gnu/home.scm
+++ b/gnu/home.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
-;;; Copyright © 2022, 2024 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2022, 2024-2025 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +21,7 @@ (define-module (gnu home)
#:use-module (gnu home services)
#:use-module (gnu home services symlink-manager)
#:use-module (gnu home services shells)
+ #:use-module (gnu home services shepherd)
#:use-module (gnu home services xdg)
#:use-module (gnu home services fontutils)
#:use-module (gnu home services admin)
@@ -80,7 +81,9 @@ (define-record-type* <home-environment> home-environment
(define %base-home-services
;; Non-essential but useful services to have by default.
- (list (service home-log-rotation-service-type)))
+ (list (service home-log-rotation-service-type)
+ (service home-shepherd-timer-service-type)
+ (service home-shepherd-transient-service-type)))
(define (home-environment-default-essential-services he)
"Return the list of essential services for home environment."
--
2.47.1
Maxim Cournoyer wrote 2 months ago
Re: [bug#74997] [PATCH 1/4] services: shepherd: Add ‘transient’ and ‘timer’.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87wmer8e0k.fsf@gmail.com
Hi Ludovic,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (33 lines)
> * gnu/services/shepherd.scm (shepherd-timer-service-type)
> (shepherd-transient-service-type): New variables.
> * doc/guix.texi (Shepherd Services): Document them.
>
> Change-Id: I9b622e7e947e7a6384c2701a313d0c7080a0a5f6
> ---
> doc/guix.texi | 33 ++++++++++++++++++++++++
> gnu/services/shepherd.scm | 54 +++++++++++++++++++++++++++++++++++++--
> 2 files changed, 85 insertions(+), 2 deletions(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index 0015d739bb..3e377ca9f4 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -45684,6 +45684,39 @@ Shepherd Services
> (shepherd my-shepherd))))))
> @end lisp
>
> +@cindex @code{transient} service, Shepherd
> +@defvar shepherd-transient-service-type
> +This service type represents the Shepherd's @code{transient} service,
> +which lets you spawn commands in the background and interact with them
> +as regular Shepherd service; it is similar to @command{systemd-run}.
> +
> +For example, the command below spawns @command{rsync} in the background,
> +in an environment where the @env{SSH_AUTH_SOCK} environment variable has
> +the given value:
> +
> +@example
> +herd spawn transient -E SSH_AUTH_SOCK=$SSH_AUTH_SOCK -- \
> + rsync -e ssh -vur . backup.example.org:
> +@end example

Neat!

Toggle quote (14 lines)
> +@xref{Transient Service Maker,,, shepherd, The GNU Shepherd Manual}, for
> +more info on the @code{transient} service.
> +@end defvar
> +
> +@cindex @code{timer} service, Shepherd
> +@defvar shepherd-timer-service-type
> +This is the service type representing the Shepherd's @code{timer}
> +service, which lets you schedule the execution of commands, similar to
> +the venerable @command{at} command. Here is an example:
> +
> +@example
> +herd schedule timer at 07:00 -- mpg123 Music/alarm.mp3
> +@end example

Also nice, though I'd use 'ogg123 Music/alarm.ogg' to promote more free
formats!

[...]

Toggle quote (26 lines)
> -;;; shepherd.scm ends here
> +
> +;;;
> +;;; Timer and transient service maker.
> +;;;
> +
> +(define shepherd-timer-service-type
> + (shepherd-service-type
> + 'shepherd-timer
> + (const (shepherd-service
> + (provision '(timer))
> + (requirement '(user-processes))
> + (modules '((shepherd service timer)))
> + (free-form #~(timer-service
> + '#$provision
> + #:requirement '#$requirement))))
> + #t ;ignored
> + (description "The Shepherd @code{timer} service lets you schedule commands
> +dynamically, similar to the @code{at} command that your grandparents would use
> +on that Slackware they got on a floppy disk. For example, consider this
> +command:
> +
> +@example
> +herd schedule timer at 07:00 -- mpg123 Music/alarm.mp3
> +@end example

Ditto (I'd use Ogg Vorbis in the example).

Toggle quote (25 lines)
> +It does exactly what you would expect.")))
> +
> +(define shepherd-transient-service-type
> + (shepherd-service-type
> + 'shepherd-transient
> + (const (shepherd-service
> + (provision '(transient))
> + (requirement '(user-processes))
> + (modules '((shepherd service transient)))
> + (free-form #~(transient-service
> + '#$provision
> + #:requirement '#$requirement))))
> + #t ;ignored
> + (description "The Shepherd @code{transient} service lets you run commands
> +asynchronously, in the background, similar to @command{systemd-run}, as in
> +this example:
> +
> +@example
> +herd spawn transient -E SSH_AUTH_SOCK=$SSH_AUTH_SOCK -- \\
> + rsync -e ssh -vur . backup.example.org:
> +@end example
> +
> +This runs @command{rsync} in the background, as a service that you can inspect
> +with @command{herd status} and stop with @command{herd stop}.")))

Neat! Taking into account my previous nitpick:

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Maxim Cournoyer wrote 2 months ago
Re: [bug#74997] [PATCH 2/4] services: Add the Shepherd ’s ‘transient’ and ‘tim er’ to ‘%base-services’.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87sepf8dw1.fsf@gmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (3 lines)
> * gnu/services/base.scm (%base-services): Add instances of
> ‘shepherd-timer-service-type’ and ‘shepherd-transient-service-type’.

The above changelog is incomplete (missing the refactor in
gnu/services/shepherd.scm)

Otherwise,

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74997@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74997
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help