MSavoritias wrote 3 months ago
(address . guix-patches@gnu.org)
Doing:
@localhost ~$ guix import go code.forgejo.org/f3/gof3/v3
guix import: Importing package "code.forgejo.org/f3/gof3/v3"...
guix import: varoitus: Unable to determine repository root of
'code.forgejo.org/f3/gof3'. Guessing 'code.forgejo.org/f3/gof3'.
(define-public go-code-forgejo-org-f3-gof3
(package
(name "go-code-forgejo-org-f3-gof3")
(version "3.10.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1ysqlj5aa7bhsyghzhycngg45wclc1j2yhq1l27d5crb0pq0wfwg"))))
(build-system go-build-system)
(arguments
(list
#:go 1.22
#:import-path "code.forgejo.org/f3/gof3/v3"
#:unpack-path "code.forgejo.org/f3/gof3"))
(propagated-inputs (list go-golang-org-x-crypto
go-github-com-xanzy-go-gitlab
go-github-com-urfave-cli-v2
go-github-com-stretchr-testify
go-github-com-santhosh-tekuri-jsonschema-v6
go-github-com-hashicorp-go-version
go-github-com-google-go-cmp
go-github-com-davidmz-go-pageant
go-github-com-42wim-httpsig))
(home-page "https://code.forgejo.org/f3/gof3")
(synopsis "gof3")
(description
"As a CLI or as a library, @code{GoF3} provides a single
operation: mirroring.
The origin and destination are designated by the URL of a forge and a
path to
the resource. For instance, @@code{mirror --from-type forgejo --from
https://code.forgejo.org/forgejo/lxc-helpers--to-type F3 --to
/some/directory}
will mirror a project in a local directory using the F3 format.")
(license license:expat)))
This package definition is not valid.
#:go 1.22 should be written like #:go go-1.22
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure struct-vtable: Wrong type argument in position 1 (expecting
struct): 1.22
MSavoritias