[PATCH] gnu: python-cheroot: Update to 10.0.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 3 months ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
1c7913f4f0361fbe86a31dc9bf79c580c55c4a8c.1734646286.git.sarg@sarg.org.ru
* gnu/packages/python-web.scm (python-cheroot): Update to 10.0.1.
[native-inputs]: New test dependencies.
[propagated-inputs]: Remove python-six.
---
gnu/packages/python-web.scm | 27 ++++++++++++++-------------
1 file changed, 14 insertions(+), 13 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a14db7bd9f..c97f2b3ce6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1402,14 +1402,14 @@ (define-public python-httplib2
(define-public python-cheroot
(package
(name "python-cheroot")
- (version "10.0.0")
+ (version "10.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cheroot" version))
(sha256
(base32
- "1w0ind0dza9j1py56y23344piqkpyfmcm060qfrnk6gggy3s3i2r"))))
+ "0h0p3fnpa4dxi589s7ljlzb6p3mhqdivb3pc2f36pljqfrwjzf70"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -1419,8 +1419,13 @@ (define-public python-cheroot
;; "--numprocesses=auto"
"--doctest-modules"
"--showlocals"
- ;; Disable test requiring networking.
- "-k" "not test_tls_client_auth")
+ "-k" (string-append
+ ;; Disable test requiring networking.
+ "not test_tls_client_auth"
+ ;; TypeError: HTTPConnection.request() got an unexpected keyword
+ ;; argument 'chunked'
+ " and not test_peercreds_unix_sock"
+ " and not test_peercreds_unix_sock_with_lookup"))
#:phases
#~(modify-phases %standard-phases
(replace 'check
@@ -1430,25 +1435,21 @@ (define-public python-cheroot
(apply invoke "pytest" "-v"
(append test-flags (list #$output))))))))))
(propagated-inputs
- (list python-jaraco-functools
- python-more-itertools
- python-six))
+ (list python-jaraco-functools python-more-itertools))
(native-inputs
- (list python-cryptography
- python-jaraco-text
+ (list python-jaraco-text
python-portend
python-pyopenssl
python-pypytools
- python-pytest
python-pytest-cov
python-pytest-mock
- python-pytest-xdist
python-requests
python-requests-toolbelt
python-requests-unixsocket
+ python-setuptools
python-setuptools-scm
- python-setuptools-scm-git-archive
- python-trustme))
+ python-trustme
+ python-wheel))
(home-page "https://cheroot.cherrypy.dev")
(synopsis "Highly-optimized, pure-python HTTP server")
(description

base-commit: 07b4b1d055c36c6c61d39273c26974771dbfe805
--
2.46.0
jgart wrote 3 months ago
(address . 74982-done@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
875xn9t1a3.fsf@dismail.de
Thanks for your contribution. Applied.
--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74982@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74982
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help