[PATCH] add font-monaspace package

  • Open
  • quality assurance status badge
Details
2 participants
  • Josep Bigorra
  • Noé Lopez
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal
J
J
Josep Bigorra wrote on 19 Dec 2024 14:46
(address . guix-patches@gnu.org)
CAM_04A2JdXLe6BkhnVCgPQoP4YoxvuOR1gdf0JrXWWKOTdkrHw@mail.gmail.com
Hi all,
I hereby submit a patch adding the beautiful Monaspace font families.
This works nicely in my Guix system so I want to upstream it. Hope I
didn't miss anything.

Regards,
Joe
From 030da8462240259aac4c46f398d7e2b4e9db9aa0 Mon Sep 17 00:00:00 2001
Message-ID: <030da8462240259aac4c46f398d7e2b4e9db9aa0.1734615915.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Thu, 19 Dec 2024 14:44:46 +0100
Subject: [PATCH] add font-monaspace package

---
gnu/packages/fonts.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 69d7d03..d7afe14 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2023 chris <chris@bumblehead.com>
;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3893,3 +3894,23 @@ (define-public font-dina
It is relatively compact to allow a lot of code on screen, while (hopefully) clear
enough to remain readable even at high resolutions.")
(license license:expat)))
+
+(define-public font-monaspace
+ (package
+ (name "font-monaspace")
+ (version "1.101")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/githubnext/monaspace/archive/refs/tags/v1.101.tar.gz")
+ (sha256
+ (base32 "076gx85and4xb262y0rbqvy7f6w732krzlh236xr7v3zbsw1h872"))))
+ (build-system font-build-system)
+ (home-page "https://monaspace.githubnext.com")
+ (synopsis "An innovative superfamily of fonts for code")
+ (description
+ "The Monaspace type system is a monospaced type superfamily with some modern tricks up its sleeve.
+ It consists of five variable axis typefaces. Each one has a distinct voice, but they are all metrics-compatible with one another,
+ allowing you to mix and match them for a more expressive typographical palette.")
+ (license license:silofl1.1)))
--
2.46.0
N
N
Noé Lopez wrote on 20 Dec 2024 16:25
[PATCH v2] gnu: fonts: Add font-monaspace.
(address . 74972@debbugs.gnu.org)(name . Noé Lopez)(address . noe@xn--no-cja.eu)
9a6af7b460c198604bac47acf7ec067082d6276a.1734706855.git.noelopez@free.fr
From: Josep Bigorra <jjbigorra@gmail.com>

* gnu/packages/fonts.scm (font-monaspace): New variable.

Change-Id: I25559696f792a8dbf4961dfba2be906fb6d5f0c0
---
gnu/packages/fonts.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 69d7d039aa..b36a46ebb3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2023 chris <chris@bumblehead.com>
;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3893,3 +3894,27 @@ (define-public font-dina
It is relatively compact to allow a lot of code on screen, while (hopefully) clear
enough to remain readable even at high resolutions.")
(license license:expat)))
+
+(define-public font-monaspace
+ (package
+ (name "font-monaspace")
+ (version "1.101")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/githubnext/monaspace")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00bpzzpwz5m20ap0c1gy0rf99pc76g8lk6jr0wh7xs8fjazq7lf1"))))
+ (build-system font-build-system)
+ (home-page "https://monaspace.githubnext.com")
+ (synopsis "Innovative superfamily of fonts for code")
+ (description
+ "The Monaspace type system is a monospaced type superfamily with some modern
+tricks up its sleeve. It consists of five variable axis typefaces. Each one has a
+distinct voice, but they are all metrics-compatible with one another, allowing you to
+mix and match them for a more expressive typographical palette.")
+ (license license:silofl1.1)))

base-commit: 5e82c33839b1c02a3db8ef22f7b52e10d97a2f78
--
2.46.0
N
N
Noé Lopez wrote on 20 Dec 2024 16:31
Re: [PATCH] add font-monaspace package
(address . 74972@debbugs.gnu.org)(name . Josep Bigorra)(address . jjbigorra@gmail.com)
87bjx6e5g8.fsf@xn--no-cja.eu
Hi,

Thank you for your patch, there are a few issues with it that are
reported by guix lint: it is better to use a git origin instead of an
archive, your synopsys starts with an article (”an”) and sentences in
the description are not separated with two spaces. It is also missing a
commit messages.

These are only small changes, the rest of the patch works well :) I have
sent a second version to fix the issues listed.

Have a good day,
Noé Lopez

Toggle quote (55 lines)
> Hi all,
> I hereby submit a patch adding the beautiful Monaspace font families.
> This works nicely in my Guix system so I want to upstream it. Hope I
> didn't miss anything.
>
> Regards,
> Joe
> From 030da8462240259aac4c46f398d7e2b4e9db9aa0 Mon Sep 17 00:00:00 2001
> Message-ID: <030da8462240259aac4c46f398d7e2b4e9db9aa0.1734615915.git.jjbigorra@gmail.com>
> From: Josep Bigorra <jjbigorra@gmail.com>
> Date: Thu, 19 Dec 2024 14:44:46 +0100
> Subject: [PATCH] add font-monaspace package
>
> ---
> gnu/packages/fonts.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 69d7d03..d7afe14 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -60,6 +60,7 @@
> ;;; Copyright © 2023 chris <chris@bumblehead.com>
> ;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
> ;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
> +;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -3893,3 +3894,23 @@ (define-public font-dina
> It is relatively compact to allow a lot of code on screen, while (hopefully) clear
> enough to remain readable even at high resolutions.")
> (license license:expat)))
> +
> +(define-public font-monaspace
> + (package
> + (name "font-monaspace")
> + (version "1.101")
> + (source
> + (origin
> + (method url-fetch)
> + (uri
> + "https://github.com/githubnext/monaspace/archive/refs/tags/v1.101.tar.gz")
> + (sha256
> + (base32 "076gx85and4xb262y0rbqvy7f6w732krzlh236xr7v3zbsw1h872"))))
> + (build-system font-build-system)
> + (home-page "https://monaspace.githubnext.com")
> + (synopsis "An innovative superfamily of fonts for code")
> + (description
> + "The Monaspace type system is a monospaced type superfamily with some modern tricks up its sleeve.
> + It consists of five variable axis typefaces. Each one has a distinct voice, but they are all metrics-compatible with one another,
> + allowing you to mix and match them for a more expressive typographical palette.")
> + (license license:silofl1.1)))
> --
> 2.46.0
N
N
Noé Lopez wrote on 20 Dec 2024 16:34
Control message for 74972
878qsae5bk.fsf@xn--no-cja.eu
user guix
tags 74972 + reviewed-looks-good
thanks
J
J
Josep Bigorra wrote on 20 Dec 2024 18:24
(address . 74972@debbugs.gnu.org)
CAM_04A3PBBDnZqy0w696GgtjLEug2vVKUgyXwDZvCHhJ4e71pQ@mail.gmail.com
Thanks a lot for your work Noé LGTM
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74972@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74972
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch