(address . guix-patches@gnu.org)
Hi all,
I hereby submit a patch adding the beautiful Monaspace font families.
This works nicely in my Guix system so I want to upstream it. Hope I
didn't miss anything.
Regards,
Joe
From 030da8462240259aac4c46f398d7e2b4e9db9aa0 Mon Sep 17 00:00:00 2001
Message-ID: <030da8462240259aac4c46f398d7e2b4e9db9aa0.1734615915.git.jjbigorra@gmail.com>
From: Josep Bigorra <jjbigorra@gmail.com>
Date: Thu, 19 Dec 2024 14:44:46 +0100
Subject: [PATCH] add font-monaspace package
---
gnu/packages/fonts.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 69d7d03..d7afe14 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2023 chris <chris@bumblehead.com>
;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <sirgazil@zoho.com>
;;; Copyright © 2024 Christina O'Donnell <cdo@mutix.org>
+;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3893,3 +3894,23 @@ (define-public font-dina
It is relatively compact to allow a lot of code on screen, while (hopefully) clear
enough to remain readable even at high resolutions.")
(license license:expat)))
+
+(define-public font-monaspace
+ (package
+ (name "font-monaspace")
+ (version "1.101")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/githubnext/monaspace/archive/refs/tags/v1.101.tar.gz")
+ (sha256
+ (base32 "076gx85and4xb262y0rbqvy7f6w732krzlh236xr7v3zbsw1h872"))))
+ (build-system font-build-system)
+ (home-page "https://monaspace.githubnext.com")
+ (synopsis "An innovative superfamily of fonts for code")
+ (description
+ "The Monaspace type system is a monospaced type superfamily with some modern tricks up its sleeve.
+ It consists of five variable axis typefaces. Each one has a distinct voice, but they are all metrics-compatible with one another,
+ allowing you to mix and match them for a more expressive typographical palette.")
+ (license license:silofl1.1)))
--
2.46.0