(address . bug-guix@gnu.org)
Hi,
after recent python updates in master, tests in trash-cli fail and
therefore, the derivation fails to build:
Toggle snippet (108 lines)
============================= test session starts
==============================
platform linux -- Python 3.10.7, pytest-8.3.3, pluggy-1.5.0
rootdir: /tmp/guix-build-trash-cli-0.22.10.20.drv-0/source
configfile: pyproject.toml
plugins: hypothesis-6.54.5
collected 354 items / 6 errors
==================================== ERRORS
====================================
________ ERROR collecting
tests/test_empty/empty_cmd/test_empty_cmd.py _________
tests/test_empty/empty_cmd/test_empty_cmd.py:9: in <module>
from flexmock import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
_____________ ERROR collecting tests/test_put/test_file_trasher.py
_____________
tests/test_put/test_file_trasher.py:3: in <module>
import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
_______ ERROR collecting
tests/test_put/test_trash_directory_for_put.py ________
tests/test_put/test_trash_directory_for_put.py:6: in <module>
from flexmock import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
____________ ERROR collecting tests/test_put/test_trash_file_in.py
_____________
tests/test_put/test_trash_file_in.py:3: in <module>
import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
_______________ ERROR collecting tests/test_put/test_trasher.py
________________
tests/test_put/test_trasher.py:5: in <module>
import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
_________________ ERROR collecting tests/test_put/test_user.py
_________________
tests/test_put/test_user.py:4: in <module>
import flexmock
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1246:
in <module>
_hook_into_pytest()
/gnu/store/nz16773zhc6f8xs5dhglwf6qpg8avxcz-python-flexmock-0.10.4/lib/python3.10/site-packages/flexmock.py:1228:
in _hook_into_pytest
saved = runner.call_runtest_hook
E AttributeError: module '_pytest.runner' has no attribute
'call_runtest_hook'
=========================== short test summary info
============================
ERROR tests/test_empty/empty_cmd/test_empty_cmd.py -
AttributeError: module '...
ERROR tests/test_put/test_file_trasher.py - AttributeError: module
'_pytest.r...
ERROR tests/test_put/test_trash_directory_for_put.py -
AttributeError: module...
ERROR tests/test_put/test_trash_file_in.py - AttributeError:
module '_pytest....
ERROR tests/test_put/test_trasher.py - AttributeError: module
'_pytest.runner...
ERROR tests/test_put/test_user.py - AttributeError: module
'_pytest.runner' h...
!!!!!!!!!!!!!!!!!!! Interrupted: 6 errors during collection
!!!!!!!!!!!!!!!!!!!!
============================== 6 errors in 0.50s
===============================
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "pytest" arguments: ()
exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 0.6 seconds
command "pytest" failed with status 2
build process 18 exited with status 256
cheers,
nutcase
-----BEGIN PGP SIGNATURE-----
iHMEAREKADMWIQSZos45zYG9CgQjO52pmOo730U57wUCZ2P9JRUcZmxha2VAdW5p
LWtvYmxlbnouZGUACgkQqZjqO99FOe/WaQCdGoB0dBBrdsy/WXTACfVlYs4juR0A
mweCzqFA5Eskpxfkh1XwmlvrjPLs
=w4kr
-----END PGP SIGNATURE-----