[PATCH 0/2] Enable plugins for cyrus-sasl and add xoauth2 plugin

  • Open
  • quality assurance status badge
Details
One participant
  • reza
Owner
unassigned
Submitted by
reza
Severity
normal

Debbugs page

reza wrote 3 months ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)(name . reza)(address . reza@housseini.me)
01020193d8f8a66e-7dd5cc5a-93c6-458f-8eff-500a10f05ef6-000000@eu-west-1.amazonses.com
This patch series adds the plugin search path to cyrus-sasl and a first plugin
cyrus-sasl-xoauth2.
Reza Housseini (2):
gnu: cyrus-sasl: Add native-search-paths.
gnu: Add cyrus-sasl-xoauth2.
gnu/packages/cyrus-sasl.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
base-commit: 20b1613484f512649f919d89285e981998592497
--
2.46.0
reza wrote 3 months ago
[PATCH 1/2] gnu: cyrus-sasl: Add native-search-paths.
(name . 74938@debbugs.gnu.org)(address . 74938@debbugs.gnu.org)(name . reza)(address . reza@housseini.me)
01020193d8fda869-d73cd4ff-442f-45af-99ec-338c1bcab265-000000@eu-west-1.amazonses.com
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)
[native-search-paths]: Add 'SASL_PATH'.

Change-Id: I553473c7707480ac422b2c6aa70363ba04f4b1e2
---
gnu/packages/cyrus-sasl.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index ef408f2dd7..ee8ad14d08 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -64,6 +64,10 @@ (define-public cyrus-sasl
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
;; fail with EEXIST when building things in parallel.
#:parallel-build? #f))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "SASL_PATH")
+ (files (list "lib/sasl2")))))
(synopsis "Simple Authentication Security Layer implementation")
(description
"SASL (Simple Authentication Security Layer) is an Internet
--
2.46.0
reza wrote 3 months ago
[PATCH 2/2] gnu: Add cyrus-sasl-xoauth2.
(name . 74938@debbugs.gnu.org)(address . 74938@debbugs.gnu.org)(name . reza)(address . reza@housseini.me)
01020193d8fde8da-f22a8a06-dc8d-4e4b-a11f-ae25b8f943ba-000000@eu-west-1.amazonses.com
* gnu/packages/cyrus-sasl.scm (cyrus-sasl-xoauth2): New variable.

Change-Id: I2e7d415c2ae18467d9901118c987155aa3f0edca
---
gnu/packages/cyrus-sasl.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index ee8ad14d08..4ef5564d41 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -77,3 +77,35 @@ (define-public cyrus-sasl
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))
(home-page "https://cyrusimap.org/sasl/")))
+
+(define-public cyrus-sasl-xoauth2
+ (package
+ (name "cyrus-sasl-xoauth2")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/moriyoshi/"
+ "cyrus-sasl-xoauth2/archive/tags/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hz95rp2n0xrkc0y2fgif2s7d61hlhd4qki5m8q0s44qc1b2cb56"))))
+ (build-system gnu-build-system)
+ (inputs (list autoconf
+ automake
+ libtool
+ cyrus-sasl))
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-cyrus-sasl=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'add-shebang
+ (lambda _
+ (substitute* "autogen.sh"
+ (("libtoolize") "#!/bin/sh\nlibtoolize")))))))
+ (synopsis "XOAUTH2 mechanism plugin for cyrus-sasl")
+ (description
+ "This is a plugin implementation of XOAUTH2 for cyrus-sasl.")
+ (home-page "https://github.com/moriyoshi/cyrus-sasl-xoauth2")
+ (license license:expat)))
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 74938@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74938
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help