* gnu/packages/hardware.scm (ddcutil): Update to 2.1.4.
[source]: Switch to git-fetch.
[arguments]: Remove it.
[inputs]: Add jansson.
[native-inputs]: Add autoconf, automake, and libtool.
Change-Id: I3024ac4d12c531f36eb4624b11d5f1f3e59e2672
---
gnu/packages/hardware.scm | 24 ++++++++++--------------
1 file changed, 10 insertions(+), 14 deletions(-)
Toggle diff (52 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 2922b14a42b..02664c1872c 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2023 Spencer Skylar Chan <schan12@umd.edu>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -544,28 +545,23 @@ (define-public ckb-next
(define-public ddcutil
(package
(name "ddcutil")
- (version "1.4.5")
+ (version "2.1.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.ddcutil.com/tarballs/"
- "ddcutil-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rockowitz/ddcutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "17zrqdz5mzwyccvc5m166yjlbbg9k2m9cwyg0y30h3184p1b2wlq"))))
+ (base32 "0wk82cdg7vddk6pbnn6qq3p71j4bppq13is2ck40glig08ax1bg5"))))
(build-system gnu-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-missing-pkgconfig-file
- (lambda _
- (install-file "ddcutil.pc"
- (string-append #$output "/lib/pkgconfig")))))))
(native-inputs
- (list pkg-config))
+ (list autoconf automake libtool pkg-config))
(inputs
(list eudev
glib
+ jansson
kmod
i2c-tools
libdrm ;enhanced diagnostics
--
2.46.0