[PATCH 0/3] yggdrasil: Update to 0.5.11.

  • Done
  • quality assurance status badge
Details
One participant
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1734464648.git.poptsov.artyom@gmail.com
This patchset updates Yggdrasil to the version 0.5.11.

Artyom V. Poptsov (3):
gnu: go-github-com-arceliar-ironwood: Update to
v0.0.0-20241210120540-9deb08d9f8f9.
gnu: Add go-suah-dev-protect.
gnu: yggdrasil: Update to 0.5.11.

gnu/packages/golang-web.scm | 4 ++--
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
gnu/packages/networking.scm | 7 ++++---
3 files changed, 32 insertions(+), 5 deletions(-)


base-commit: 15c657f80a58b589eda8ae1965c431da6c267dd6
--
2.46.0
Artyom V. Poptsov wrote 3 months ago
[PATCH 1/3] gnu: go-github-com-arceliar-ironwood: Update to v0.0.0-20241210120540-9deb08d9f8f9.
(address . 74932@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
6d9369a56717c856ad9491bebb8722b2640be979.1734464648.git.poptsov.artyom@gmail.com
* gnu/packages/golang-web.scm (go-github-com-arceliar-ironwood): Update to v0.0.0-20241210120540-9deb08d9f8f9.

Change-Id: I4896468e6ccab9a4c68c72363a99e16b65c3f474
---
gnu/packages/golang-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e895ba59ce..0c95e3c323 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -213,7 +213,7 @@ (define-public go-github-com-alexliesenfeld-health
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")
- (version "v0.0.0-20241122002527-75a6e82fa380")
+ (version "v0.0.0-20241210120540-9deb08d9f8f9")
(source
(origin
(method git-fetch)
@@ -223,7 +223,7 @@ (define-public go-github-com-arceliar-ironwood
(file-name (git-file-name name version))
(sha256
(base32
- "1xrdy5yn2y8q147n6fafc8cqjf6my06wzlhghv0c5ra9rqg1dii7"))))
+ "08i4zm8jxq89dznxx76marn5zfkyscmbn6cdsx0adz6pzwgpd1cz"))))
(build-system go-build-system)
(arguments
(list
--
2.46.0
Artyom V. Poptsov wrote 3 months ago
[PATCH 2/3] gnu: Add go-suah-dev-protect.
(address . 74932@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
46e901401de4bb2b4bf794a7c1dd51f483f97007.1734464648.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-suah-dev-protect): New variable.

Change-Id: Idf224b6571da2aefb99811ee3cd9fead67614d61
---
gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f8c63976d6..ae19116b51 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8842,6 +8842,32 @@ (define-public go-sentences
" This package provides an command line interface (CLI)
tool."))))
+(define-public go-suah-dev-protect
+ (package
+ (name "go-suah-dev-protect")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/qbit/protect")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f36w2435xivggl4d31813ggk37ya9v8q6w8ygbp35ypzwfgzlh3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "suah.dev/protect"))
+ (home-page "https://codeberg.org/qbit/protect")
+ (synopsis "Wrapper for OpenBSD's pledge and unveil system calls.")
+ (description
+ "Package protect is a wrapper for OpenBSD's @code{pledge} and @code{unveil}
+system calls.
+
+It allows one to safely call Unveil / Pledge on non-OpenBSD operating systems.")
+ (license license:isc)))
+
(define-public go-tengo
(package
(inherit go-github-com-d5-tengo-v2)
--
2.46.0
Artyom V. Poptsov wrote 3 months ago
[PATCH 3/3] gnu: yggdrasil: Update to 0.5.11.
(address . 74932@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
9e228de656055ae581f6121c55ac5fc39ddc4bb7.1734464648.git.poptsov.artyom@gmail.com
* gnu/packages/networking.scm (yggdrasil): Update to 0.5.11.
[propagated-inputs]: Add go-suah-dev-protect.

Change-Id: I9a7bfcfb66e76fca18a0cec5ac447d7e3900227f
---
gnu/packages/networking.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1a2af6d790..ee56631f1e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4670,7 +4670,7 @@ (define-public ngtcp2
(define-public yggdrasil
(package
(name "yggdrasil")
- (version "0.5.10")
+ (version "0.5.11")
(source
(origin
(method git-fetch)
@@ -4681,7 +4681,7 @@ (define-public yggdrasil
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0dd5181p07xshbd7q6p0hf3cvq1ahq6q36qjij0vzdil8dka6fmx"))
+ (base32 "0l7lvqmvzw89wv53lpxa44k7y148y7japvy77yir4467ghdmnvyk"))
(patches (search-patches "yggdrasil-extra-config.patch"))))
(build-system go-build-system)
(arguments
@@ -4729,7 +4729,8 @@ (define-public yggdrasil
go-golang-org-x-net
go-golang-org-x-sys
go-golang-org-x-text
- go-golang-zx2c4-com-wireguard))
+ go-golang-zx2c4-com-wireguard
+ go-suah-dev-protect))
(home-page "https://yggdrasil-network.github.io/blog.html")
(synopsis
"Experiment in scalable routing as an encrypted IPv6 overlay network")
--
2.46.0
Artyom V. Poptsov wrote 3 months ago
Re: [PATCH 0/3] yggdrasil: Update to 0.5.11.
(address . 74932-done@debbugs.gnu.org)
87msgqkua9.fsf@gmail.com
Merged to the "master" branch as the following commits:

Toggle snippet (5 lines)
d7bd22a4863214fd1df427bbebd1859eddd71f9b gnu: yggdrasil: Update to 0.5.11.
e518d2f8546a5dfde8d4644e3e9c55ac358efab7 gnu: Add go-suah-dev-protect.
163843c78ebd673044e14320f539462fa5826d14 gnu: go-github-com-arceliar-ironwood: Update to v0.0.0-20241210120540-9deb08d9f8f9.

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmdlyrEZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfmcjD/0cFzhG/ClxmoKLlyvsoSeV
wJ0plwZd3tX1Ps8j7LT/KXKn+zQ0q/LMXdV+ojY6ylSFlLMU0AqM1iPeidJ2TqA9
3kHyPxrs9zioSlCP1Vq+UurajFa3KcOGTOgPNbdtAFA2z8Z1vJPjoebopbFgZALG
XxAXFbxNxnqc1bd5HcxK4FDlJHStD6uj+1KBF1xi/jru212qLwtdEQlRKPNVqe7N
G+ijID/yVfVAHZd2eW7TiVPeT2uJZ0pg63b2nuPjoa+w1nq5LOeMi7iXcKEcep5f
oVu8kIw+B3XEgWQ2VWWzdGUjtOkhMuxNPXR6cV4ytJ1uVN8yXAVzcSn/a0T6Rx7v
n77NEzUle6nCBW165uIfrHe4iW3y2vYZx1SEkynee/mRxh3Z0EQIuu16i2GNw1gc
JThnmhQr+8f+/Fwa0wQaf6tOVJbMvmukD28yqJ6uWMxDK6rvUg6IwbSL+AtSQAWF
so+V3r7ViuJxxh47/4cnUEo6ZWhkwwxay1NDHhoFFP298uQXVOAOJXAxgWFkgl3Z
gqbwcDiYr9+g34LLN6nfCanQb1X2vOzHZc8Blh8taxYs6NIxFbdJHHvLGiq/Slkh
rbO4kUNRC3Mib7KFBP+ozv+5KIdUE2nzFKDzwaXhbY9mlAAgtw0HbNdTC2IK69S4
RpNCb3blIBB1SZFbyhug0g==
=ExH8
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 74932@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 74932
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help